Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0043181
TypeCategorySeverityReproducibilityDate SubmittedLast Update
backport[Openbravo ERP] A. Platformminoralways2020-02-10 19:322020-02-19 09:46
ReportershuehnerView Statuspublic 
Assigned Toalostale 
PrioritynormalResolutionfixedFixed in Version
StatusclosedFix in branchFixed in SCM revisiond26ac45d515a
ProjectionnoneETAnoneTarget Version3.0PR19Q4.2
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Tojarmendariz
Web browser
ModulesCore
Regression levelProduction - Confirmed Stable
Regression date2018-10-30
Regression introduced in release3.0PR19Q1
Regression introduced by commithttps://gitlab.com/openbravo/product/dbsm/-/commit/789aa22ca2be4190e5f07a4770c2172e0e5c0552 [^]
Triggers an Emergency PackNo
Summary

0043181: Update.database message about local changes in application dictionary is missing table name

DescriptionThe update.database mechanism to check for local changes consists of 2 parts:
a.) structure changes
b.) changes in AD

For part b.) the code did show the table having changes also but is no longer doing so -> Regression.

Checking code of code in dbsm-main repo OBDataset.java method hasChanged:
  if (log != null) {
              log.warn("Change detected in table: " + table.getName());

So issue could be either:
- logger being null (even if seems to be set in OBDBSMOBUtil.java)
- logger being not configured to show by default.
Steps To Reproduce1.) Have clean base (i.e. install.source or previous update.database ran)
2.) Cause local change in AD
update ad_window set updated=now() where ad_window_id = '100';
3.) Run update.database

4.) Check output missing info about table
     [java] 18844 [main] INFO org.openbravo.ddlutils.util.DBSMOBUtil - Checking if database structure was modified locally.
     [java] 19425 [main] INFO org.openbravo.ddlutils.util.DBSMOBUtil - Checking if data has changed in the application dictionary.
     [java] 19465 [main] ERROR org.openbravo.ddlutils.task.AlterDatabaseDataAll - Database has local changes. Update.database will not be done. You should export your changed modules before doing update.database, so that your Application Dictionary changes are preserved.
     [java] Database has local changes. Update.database not done.
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
blocks defect 0043175 closedalostale Update.database message about local changes in application dictionary is missing table name 

-  Notes
(0117901)
alostale (developer)
2020-02-18 10:20

dbsm commit: https://gitlab.com/openbravo/product/dbsm/-/commit/6baf13acc458411bce363f12187c74fab4b462d9 [^]
(0117903)
hgbot (developer)
2020-02-18 10:22

Repository: erp/backports/3.0PR19Q4.2
Changeset: d26ac45d515a776a26709ce451a0edbcb3ac75ea
Author: Asier Lostalé <asier.lostale <at> openbravo.com>
Date: Tue Feb 18 10:19:53 2020 +0100
URL: http://code.openbravo.com/erp/backports/3.0PR19Q4.2/rev/d26ac45d515a776a26709ce451a0edbcb3ac75ea [^]

fixed BUG-43181: AD local changes not logged

  When updating database having local changes in AD, the tables with
  changes were not logged.

  While project to upgrade to log4j2 the API, old API passing old logger
  was kept but it become unusable as null logger was used.

---
M src-db/database/lib/dbsourcemanager.jar
---
(0117938)
jarmendariz (developer)
2020-02-19 09:46

Reviewed

- Issue History
Date Modified Username Field Change
2020-02-11 10:39 alostale Type defect => backport
2020-02-11 10:39 alostale Target Version => 3.0PR19Q4.2
2020-02-13 10:32 alostale Target Version 3.0PR19Q4.2 => 3.0PR20Q4.3
2020-02-18 10:20 alostale Note Added: 0117901
2020-02-18 10:22 hgbot Checkin
2020-02-18 10:22 hgbot Note Added: 0117903
2020-02-18 10:22 hgbot Status scheduled => resolved
2020-02-18 10:22 hgbot Resolution open => fixed
2020-02-18 10:22 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/backports/3.0PR19Q4.2/rev/d26ac45d515a776a26709ce451a0edbcb3ac75ea [^]
2020-02-18 12:47 alostale Target Version 3.0PR20Q4.3 => 3.0PR19Q4.2
2020-02-19 09:46 jarmendariz Note Added: 0117938
2020-02-19 09:46 jarmendariz Status resolved => closed


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker