Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0041016
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] A. Platformminoralways2019-06-04 09:482019-06-14 11:00
ReporteregoitzView Statuspublic 
Assigned Tocaristu 
PrioritynormalResolutionfixedFixed in Version3.0PR19Q3
StatusclosedFix in branchFixed in SCM revision6beb7213986f
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Toalostale
Web browser
ModulesCore
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0041016: creating new record in grid, empty record generated if clicking line while retrieving defaults

DescriptionWhen creating a new record in grid view, if the new line is clicked while retrieving default values before it becomes editable, a new empty record is created.
Steps To Reproduce1. Apply the attached patch to make FIC slower
2. Open Sales Order window and create a new header
3. Go to child tab
4. Click on create one link
5. Before the new line becomes editable, click on Ordered Quantity field
  -> ERROR:
      - new empty record is created with all its fields in red and without any default value set



*see attached image
TagsNo tags attached.
Attached Filespng file icon Screenshot from 2019-06-04 09-47-57.png [^] (119,592 bytes) 2019-06-04 09:48


diff file icon 41016-mcve.diff [^] (1,299 bytes) 2019-06-04 10:41 [Show Content]

- Relationships Relation Graph ] Dependency Graph ]
related to defect 00398653.0PR19Q3 closedAugustoMauch [19Q1] [KS] It is possible to create an empty record from an empty record 
related to defect 0031571 closedcaristu Error after canceling a record edition under some circumstances 
related to defect 00252173.0MP30 closedAugustoMauch When using tab to save a new record in the grid, the focus does not go to the next record 
related to defect 00247413.0MP28 closedAugustoMauch Error when inserting a row on grid mode pressing tab key for selecting a value on a selector 
related to defect 0019830 closedAugustoMauch Error message is not shown when using Enter key to exit an invalid row 

-  Notes
(0112369)
egoitz (developer)
2019-06-04 10:18

Other way to reproduce:

1- Create header (Sales order)
2- cick on the child tab
3- click on the create one link
4-A new line appear
5- click on the header section
6 - the line appears in read
7 - click again on the child section and you are able to click on the new line tool bar button
(0112530)
hgbot (developer)
2019-06-10 09:45

Repository: erp/devel/pi
Changeset: 6beb7213986ff94c24d50bd7ee23ab1b4f72e4b6
Author: Carlos Aristu <carlos.aristu <at> openbravo.com>
Date: Fri Jun 07 15:20:19 2019 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/6beb7213986ff94c24d50bd7ee23ab1b4f72e4b6 [^]

fixes bug 41016: empty record created if clicking line while retrieving defaults

  The cell edition was being completed when clicking on a cell in the same row which is disabled. Because of this, it was possible to create an empty record without all the mandatory fields set.

  To avoid this problem, now the doCellEditEnd function takes into account if we are trying to move to a disabled cell and, in that case, if we have mandatory fields pending to be filled then the cell edit end process is not completed.

  Note that the getNextEditCell() function of the OBViewGrid returns null if the next cell to be edited is disabled. That is why are adding the "nextEditCell === null" check.

---
M modules/org.openbravo.client.application/web/org.openbravo.client.application/js/grid/ob-view-grid.js
---
(0112538)
hudsonbot (developer)
2019-06-10 14:05

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/3a803275fa99 [^]
Maturity status: Test
(0112785)
alostale (developer)
2019-06-14 11:00

reviewed + tested

- Issue History
Date Modified Username Field Change
2019-06-04 09:48 egoitz New Issue
2019-06-04 09:48 egoitz Assigned To => platform
2019-06-04 09:48 egoitz File Added: Screenshot from 2019-06-04 09-47-57.png
2019-06-04 09:48 egoitz Modules => Core
2019-06-04 09:48 egoitz Triggers an Emergency Pack => No
2019-06-04 09:48 egoitz Relationship added related to 0039865
2019-06-04 10:18 egoitz Note Added: 0112369
2019-06-04 10:41 alostale File Added: 41016-mcve.diff
2019-06-04 10:48 alostale Summary It is possible to create an empty record from an empty record (2) => creating new record in grid, empty record generated if clicking line while retrieving defaults
2019-06-04 10:48 alostale Description Updated View Revisions
2019-06-04 10:48 alostale Steps to Reproduce Updated View Revisions
2019-06-04 11:16 alostale Status new => acknowledged
2019-06-07 12:06 caristu Relationship added related to 0031571
2019-06-07 12:07 caristu Relationship added related to 0025217
2019-06-07 12:09 caristu Relationship added related to 0024741
2019-06-07 13:47 caristu Relationship added related to 0019830
2019-06-07 13:47 caristu Assigned To platform => caristu
2019-06-07 13:47 caristu Status acknowledged => scheduled
2019-06-10 09:45 hgbot Checkin
2019-06-10 09:45 hgbot Note Added: 0112530
2019-06-10 09:45 hgbot Status scheduled => resolved
2019-06-10 09:45 hgbot Resolution open => fixed
2019-06-10 09:45 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/6beb7213986ff94c24d50bd7ee23ab1b4f72e4b6 [^]
2019-06-10 09:45 caristu Review Assigned To => alostale
2019-06-10 14:05 hudsonbot Checkin
2019-06-10 14:05 hudsonbot Note Added: 0112538
2019-06-14 11:00 alostale Note Added: 0112785
2019-06-14 11:00 alostale Status resolved => closed
2019-06-14 11:00 alostale Fixed in Version => 3.0PR19Q3


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker