Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0019830
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] B. User interfacemajorhave not tried2012-02-21 21:072012-09-26 17:19
ReporterplujanView Statuspublic 
Assigned ToAugustoMauch 
PrioritynormalResolutionfixedFixed in Version3.0MP16
StatusclosedFix in branchpiFixed in SCM revision0ff1cc0c83af
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionpiSCM revision 
Review Assigned Todbaz
Web browser
ModulesCore
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0019830: Error message is not shown when using Enter key to exit an invalid row

DescriptionWhen using the Insert Row button to go to a new record, an error message is displayed about the mandatory fields not filled. The message is not shown when using the Enter key. See steps.
Steps To Reproduce1. Go to Unit of Measure window
2. Click the Insert Row button
3. With no field filled in, click the Insert Row button again.
4. As expected, a new record is created and an error message about the mandatory fields is displayed
5. Close the message.
6. Press the Enter key. The new record is created but there is no error message. See screenshot.
TagsNo tags attached.
Attached Filespng file icon New+Row+in+Grid.png [^] (67,532 bytes) 2012-02-21 21:07

- Relationships Relation Graph ] Dependency Graph ]
related to defect 00197063.0MP9 closeddbaz It is not possible to save but a new row is added when hitting Enter key in the grid 
related to defect 00201473.0MP9 closedAugustoMauch When clicking enter is not creating a new line 
related to defect 00202413.0MP11 closedAugustoMauch Down arrow in grid view does not work correctly 
related to defect 00217233.0MP16 closedAugustoMauch Not possible to move to another row while editing if current row has not been changed 
related to defect 0041016 closedcaristu creating new record in grid, empty record generated if clicking line while retrieving defaults 

-  Notes
(0045368)
hgbot (developer)
2012-02-22 15:57

Repository: erp/devel/pi
Changeset: 2e1947ca8bbc2b07f59477db7dd9c292c3f2f23a
Author: Augusto Mauch <augusto.mauch <at> openbravo.com>
Date: Wed Feb 22 15:56:50 2012 +0100
URL: http://code.openbravo.com/erp/devel/pi/rev/2e1947ca8bbc2b07f59477db7dd9c292c3f2f23a [^]

Fixes issue 19830: Error message is shown after failed save

---
M modules/org.openbravo.client.application/web/org.openbravo.client.application/js/grid/ob-view-grid.js
---
(0045369)
AugustoMauch (developer)
2012-02-22 16:04

The code that controlled when the autosave was going to be performed after moving from a record that was being edited was faulty.

Now if autosave is enabled it will be performed when a record is being edited and the user presses enter or the up and down arrow keys.
(0045371)
AugustoMauch (developer)
2012-02-22 16:09

Test plan:
- Open the Unit of Measure window
- Click the Insert Row button
- With no field filled in, create a new record by pushing the Enter key.
- A new record should be created, and a error message should be shown.

- Open the Unit of Measure window
- Click the Insert Row button
- With no field filled in, create a new record by pushing the Down Arrow key.
- A new record should be created, and a error message should be shown.

- Open the Unit of Measure window
- Click the Insert Row button
- With no field filled in, move to the previous record by pushing the Up Arrow key.
- The previous record should be selected, and a error message should be shown.

- Open the Unit of Measure window
- Click the Insert Row button
- Enter some valid data, move to the previous record by pushing the Up Arrow key.
- The previous record should be selected, and the new record should have been saved successfully.
(0045373)
AugustoMauch (developer)
2012-02-22 16:11

The change is very local and it should not have any side consequences. The fix is not risky.
(0045428)
dbaz (developer)
2012-02-23 22:37

I can still reproduce it by doing:

- Open the Unit of Measure window
- Select any row (one of the middle)
- Click the Insert Row button
- Push the Enter key
- The error message is not shown

Note, if you click the pencil icon to edit any existing record, and you remove the content of a required field, and you press "Enter", the error message is not shown neither. Even more, in the same case, if you press the save button of the beginning of the row, the error message is, again, not shown.
I say that because I think (just a feeling) that three cases are related.
(0045924)
hudsonbot (developer)
2012-03-02 15:38

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/544d64e0c159 [^]

Maturity status: Test
(0046904)
hgbot (developer)
2012-03-29 16:55

Repository: erp/devel/pi
Changeset: 01f4307bcdea5262807bb0eef2eb0d8a66ed1d35
Author: Augusto Mauch <augusto.mauch <at> openbravo.com>
Date: Thu Mar 29 16:54:24 2012 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/01f4307bcdea5262807bb0eef2eb0d8a66ed1d35 [^]

Fixes issue 20147: A new record is created in the grid when pushing the enter key

A change (changeset 2e1947ca8bbc) introduced for trying to fix issue 19830 prevented a new line from being created when the user pushed the enter key while editing the last reco
rd in the grid. This change has been reverted, and the functionality is working again.

This change does not modify the status of issue 19830, because the changeset that has been reverted only solved part of the problem.

---
M modules/org.openbravo.client.application/web/org.openbravo.client.application/js/grid/ob-view-grid.js
---
(0047024)
hgbot (developer)
2012-04-01 20:35

Repository: erp/devel/pi
Changeset: 13d387213fdd8ba66cff095b0b52d3fc7f7d3013
Author: Augusto Mauch <augusto.mauch <at> openbravo.com>
Date: Thu Mar 29 16:54:24 2012 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/13d387213fdd8ba66cff095b0b52d3fc7f7d3013 [^]

Fixes issue 20147: A new record is created in the grid when pushing the enter key

A change (changeset 2e1947ca8bbc) introduced for trying to fix issue 19830 prevented a new line from being created when the user pushed the enter key while editing the last reco
rd in the grid. This change has been reverted, and the functionality is working again.

This change does not modify the status of issue 19830, because the changeset that has been reverted only solved part of the problem.

---
M modules/org.openbravo.client.application/web/org.openbravo.client.application/js/grid/ob-view-grid.js
---
(0047271)
hudsonbot (developer)
2012-04-02 06:13

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/7814864461ac [^]

Maturity status: Test
(0047534)
hgbot (developer)
2012-04-12 16:19

Repository: erp/devel/pi
Changeset: 67c0f9be4dff39910c11fcd865323f356b61eff5
Author: Augusto Mauch <augusto.mauch <at> openbravo.com>
Date: Thu Apr 12 16:14:19 2012 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/67c0f9be4dff39910c11fcd865323f356b61eff5 [^]

Fixes issue 20241: It is possible to move between records while editing in grid.

In the changeset 2e1947ca8bbc, related to issue 19830, a change was done that had a side effect that prevented the user from beign able to move between records while editing the grid when the records were modified.

This change has been reverted and it does not have any consequence in issue 19830, because when the backout was done the issue was still not fixed.

---
M modules/org.openbravo.client.application/web/org.openbravo.client.application/js/grid/ob-view-grid.js
---
(0047644)
hudsonbot (developer)
2012-04-17 05:31

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/cedf57621434 [^]

Maturity status: Test
(0052073)
hgbot (developer)
2012-09-13 15:58

Repository: erp/devel/pi
Changeset: 163c8afae1d752d8eef21cc4c30b9937fa7efeaa
Author: Augusto Mauch <augusto.mauch <at> openbravo.com>
Date: Thu Sep 13 15:54:51 2012 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/163c8afae1d752d8eef21cc4c30b9937fa7efeaa [^]

Fixes issue 19830: message shown when using enter key to exit an invalid row

When a row was saved by pushing the Enter key while editing it, the validation of the form was not being done. This has been fixed by doing the validation in the cellEditEnd function when the editCompletionEvent is 'enter'

---
M modules/org.openbravo.client.application/web/org.openbravo.client.application/js/grid/ob-view-grid.js
---
(0052074)
AugustoMauch (developer)
2012-09-13 15:59

Reopened to enter closed by field
(0052092)
dbaz (developer)
2012-09-13 20:52

I can still reproduce the issue (no message bar shown) by doing this:

- Open the Unit of Measure window
- Click the Insert Row button
- With no field filled in, create a new record by pushing the Down Arrow key.
- A new record should be created, and a error message should be shown.

- Open the Unit of Measure window
- Click the Insert Row button
- With no field filled in, move to the previous record by pushing the Up Arrow key.
- The previous record should be selected, and a error message should be shown.
(0052121)
hgbot (developer)
2012-09-14 11:32

Repository: erp/devel/pi
Changeset: 0ff1cc0c83af02cea0e04e401bbf82d5ed8ae2d8
Author: Augusto Mauch <augusto.mauch <at> openbravo.com>
Date: Fri Sep 14 11:30:37 2012 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/0ff1cc0c83af02cea0e04e401bbf82d5ed8ae2d8 [^]

Fixes issue 19830: Grid error message shown whenever the focus leaves the row

When a row has validation errors, the error message should be shown whenever the focus leaves the row. That happens when either the enter, up arrow or down ar
row key is pressed.

---
M modules/org.openbravo.client.application/web/org.openbravo.client.application/js/grid/ob-view-grid.js
---
(0052226)
dbaz (developer)
2012-09-19 14:04

Reviewed @ changeset: 17978 - 571b10dd474d
(0052305)
AugustoMauch (developer)
2012-09-24 10:02

This fix should be included with the fix of the issue 21723.
(0052746)
hudsonbot (developer)
2012-09-26 17:19

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/b780e90c6452 [^]

Maturity status: Test
(0052758)
hudsonbot (developer)
2012-09-26 17:19

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/b780e90c6452 [^]

Maturity status: Test

- Issue History
Date Modified Username Field Change
2012-02-21 21:07 plujan New Issue
2012-02-21 21:07 plujan Assigned To => dbaz
2012-02-21 21:07 plujan File Added: New+Row+in+Grid.png
2012-02-21 21:07 plujan Modules => Core
2012-02-21 21:07 plujan Relationship added related to 0019706
2012-02-22 15:22 AugustoMauch Assigned To dbaz => AugustoMauch
2012-02-22 15:57 hgbot Checkin
2012-02-22 15:57 hgbot Note Added: 0045368
2012-02-22 15:57 hgbot Status new => resolved
2012-02-22 15:57 hgbot Resolution open => fixed
2012-02-22 15:57 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/2e1947ca8bbc2b07f59477db7dd9c292c3f2f23a [^]
2012-02-22 16:04 AugustoMauch Note Added: 0045369
2012-02-22 16:09 AugustoMauch Note Added: 0045371
2012-02-22 16:11 AugustoMauch Note Added: 0045373
2012-02-23 22:37 dbaz Note Added: 0045428
2012-02-23 22:37 dbaz Status resolved => new
2012-02-23 22:37 dbaz Resolution fixed => open
2012-03-02 15:38 hudsonbot Checkin
2012-03-02 15:38 hudsonbot Note Added: 0045924
2012-03-29 16:39 AugustoMauch Relationship added related to 0020147
2012-03-29 16:55 hgbot Checkin
2012-03-29 16:55 hgbot Note Added: 0046904
2012-04-01 20:35 hgbot Checkin
2012-04-01 20:35 hgbot Note Added: 0047024
2012-04-02 06:13 hudsonbot Checkin
2012-04-02 06:13 hudsonbot Note Added: 0047271
2012-04-11 15:45 plujan Relationship added related to 0020241
2012-04-12 16:19 hgbot Checkin
2012-04-12 16:19 hgbot Note Added: 0047534
2012-04-17 05:31 hudsonbot Checkin
2012-04-17 05:31 hudsonbot Note Added: 0047644
2012-09-13 15:58 hgbot Checkin
2012-09-13 15:58 hgbot Note Added: 0052073
2012-09-13 15:58 hgbot Status new => resolved
2012-09-13 15:58 hgbot Resolution open => fixed
2012-09-13 15:58 hgbot Fixed in SCM revision http://code.openbravo.com/erp/devel/pi/rev/2e1947ca8bbc2b07f59477db7dd9c292c3f2f23a [^] => http://code.openbravo.com/erp/devel/pi/rev/163c8afae1d752d8eef21cc4c30b9937fa7efeaa [^]
2012-09-13 15:59 AugustoMauch Note Added: 0052074
2012-09-13 15:59 AugustoMauch Status resolved => new
2012-09-13 15:59 AugustoMauch Resolution fixed => open
2012-09-13 16:01 AugustoMauch Closed by => dbaz
2012-09-13 16:03 AugustoMauch Status new => scheduled
2012-09-13 16:03 AugustoMauch fix_in_branch => pi
2012-09-13 16:04 AugustoMauch Status scheduled => resolved
2012-09-13 16:04 AugustoMauch Resolution open => fixed
2012-09-13 20:52 dbaz Note Added: 0052092
2012-09-13 20:52 dbaz Status resolved => new
2012-09-13 20:52 dbaz Resolution fixed => open
2012-09-14 11:32 hgbot Checkin
2012-09-14 11:32 hgbot Note Added: 0052121
2012-09-14 11:32 hgbot Status new => resolved
2012-09-14 11:32 hgbot Resolution open => fixed
2012-09-14 11:32 hgbot Fixed in SCM revision http://code.openbravo.com/erp/devel/pi/rev/163c8afae1d752d8eef21cc4c30b9937fa7efeaa [^] => http://code.openbravo.com/erp/devel/pi/rev/0ff1cc0c83af02cea0e04e401bbf82d5ed8ae2d8 [^]
2012-09-19 14:04 dbaz Note Added: 0052226
2012-09-19 14:04 dbaz Status resolved => closed
2012-09-19 14:04 dbaz Fixed in Version => 3.0MP16
2012-09-24 09:43 AugustoMauch Relationship added related to 0021723
2012-09-24 10:02 AugustoMauch Note Added: 0052305
2012-09-26 17:19 hudsonbot Checkin
2012-09-26 17:19 hudsonbot Note Added: 0052746
2012-09-26 17:19 hudsonbot Checkin
2012-09-26 17:19 hudsonbot Note Added: 0052758
2019-06-07 13:47 caristu Relationship added related to 0041016


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker