Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0020241
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] A. Platformmajoralways2012-04-11 13:122012-04-17 05:31
ReporterjonalegriaesarteView Statuspublic 
Assigned ToAugustoMauch 
PriorityimmediateResolutionfixedFixed in Version3.0MP11
StatusclosedFix in branchFixed in SCM revision67c0f9be4dff
ProjectionnoneETAnoneTarget Version3.0MP11
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product Version3.0MP9SCM revision 
Review Assigned To
Web browser
ModulesCore
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0020241: Down arrow in grid view does not work correctly

DescriptionDown arrow in grid view does not work correctly. This key should save and edit the next line, but it only saves the registry.
Steps To Reproduce- Business partner window in grid view
- Edit the first one.
- Change the name
- Down arrow
- The new name is saved but the focus does not change the line (and the next line does not appear as editable)
TagsRegression
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
related to defect 0019830 closedAugustoMauch Error message is not shown when using Enter key to exit an invalid row 

-  Notes
(0047535)
hgbot (developer)
2012-04-12 16:19

Repository: erp/devel/pi
Changeset: 67c0f9be4dff39910c11fcd865323f356b61eff5
Author: Augusto Mauch <augusto.mauch <at> openbravo.com>
Date: Thu Apr 12 16:14:19 2012 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/67c0f9be4dff39910c11fcd865323f356b61eff5 [^]

Fixes issue 20241: It is possible to move between records while editing in grid.

In the changeset 2e1947ca8bbc, related to issue 19830, a change was done that had a side effect that prevented the user from beign able to move between records while editing the grid when the records were modified.

This change has been reverted and it does not have any consequence in issue 19830, because when the backout was done the issue was still not fixed.

---
M modules/org.openbravo.client.application/web/org.openbravo.client.application/js/grid/ob-view-grid.js
---
(0047560)
alostale (developer)
2012-04-13 11:43

Code review and tested on pi@5dd00d376163
(0047643)
hudsonbot (developer)
2012-04-17 05:31

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/cedf57621434 [^]

Maturity status: Test

- Issue History
Date Modified Username Field Change
2012-04-11 13:12 jonalegriaesarte New Issue
2012-04-11 13:12 jonalegriaesarte Assigned To => jonalegriaesarte
2012-04-11 13:12 jonalegriaesarte Modules => Core
2012-04-11 13:12 jonalegriaesarte Assigned To jonalegriaesarte => alostale
2012-04-11 13:12 jonalegriaesarte Tag Attached: Regression
2012-04-11 13:22 alostale Assigned To alostale => AugustoMauch
2012-04-11 15:45 plujan Relationship added related to 0019830
2012-04-12 16:19 hgbot Checkin
2012-04-12 16:19 hgbot Note Added: 0047535
2012-04-12 16:19 hgbot Status new => resolved
2012-04-12 16:19 hgbot Resolution open => fixed
2012-04-12 16:19 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/67c0f9be4dff39910c11fcd865323f356b61eff5 [^]
2012-04-13 11:43 alostale Note Added: 0047560
2012-04-13 11:43 alostale Status resolved => closed
2012-04-13 11:43 alostale Fixed in Version => 3.0MP11
2012-04-17 05:31 hudsonbot Checkin
2012-04-17 05:31 hudsonbot Note Added: 0047643


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker