Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0024741
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] A. Platformmajoralways2013-09-11 13:542013-09-17 19:03
ReporteregoitzView Statuspublic 
Assigned ToAugustoMauch 
PriorityimmediateResolutionfixedFixed in Version3.0MP28
StatusclosedFix in branchFixed in SCM revision9138cdfbcb9b
ProjectionnoneETAnoneTarget Version3.0MP28
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Toshankarb
Web browser
ModulesCore
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0024741: Error when inserting a row on grid mode pressing tab key for selecting a value on a selector

DescriptionError when inserting a row on grid mode pressing tab key for selecting a value on a selector
Steps To Reproduce-Access to the sales invoice window
-Click on insert on grid view
-Using the keyboardand tab fill the records.
-On the partner selector start righting a name of an existing selector.
-When the partner appears click on tab key to select it

*See that on the first exection the row is not saved and a new row to insert is opened.

Close the new row and cancel the insertiion of the row.

-Repeat the process to inert a new row

*On this time after click on tab key on the partner field the save button change to loading (saving) but never ends.
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
related to defect 0024863 closedAugustoMauch Not possible to save a row on grid having a window personalization 
related to defect 0041016 closedcaristu creating new record in grid, empty record generated if clicking line while retrieving defaults 

-  Notes
(0061139)
egoitz (developer)
2013-09-13 12:16
edited on: 2013-09-13 12:28

The problems seems to be caused because the callout on a field on the grid trying to update a field not on the grid.
Also with a validation of a field not in grid referring to a field changed on the grid

(0061143)
AugustoMauch (developer)
2013-09-13 14:58

This happens because the datasource request to save the record is issued before receiving the FIC response. The FIC response contains the values updated after executing the callouts, so the datasource request does not have this updated data.

To solve this, the datasource request needs to be delayed until the FIC response is processed.
(0061174)
hgbot (developer)
2013-09-16 15:18

Repository: erp/devel/pi
Changeset: 9138cdfbcb9badfceaf1a0eb54b4be87fec6eb35
Author: Augusto Mauch <augusto.mauch <at> openbravo.com>
Date: Mon Sep 16 15:06:01 2013 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/9138cdfbcb9badfceaf1a0eb54b4be87fec6eb35 [^]

Fixes issue 24741: Row saved by pressing a tab for picking a selector value

The problem was that the request to the datasource to save the new record was being done before the response of the FIC (it was called because picking a business partner triggers a callout to select its location) was received and processed. This has been fixed by delaying the execution of the cellEditEnd function until the FIC response has been processed.

---
M modules/org.openbravo.client.application/web/org.openbravo.client.application/js/grid/ob-view-grid.js
---
(0061187)
shankarb (developer)
2013-09-17 09:06

Code reviewed and verified in pi changeset a549285cc9f0
(0061257)
hudsonbot (developer)
2013-09-17 19:03

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/1c53d622fc50 [^]

Maturity status: Test

- Issue History
Date Modified Username Field Change
2013-09-11 13:54 egoitz New Issue
2013-09-11 13:54 egoitz Assigned To => AugustoMauch
2013-09-11 13:54 egoitz Modules => Core
2013-09-11 13:54 egoitz Triggers an Emergency Pack => No
2013-09-12 12:04 egoitz Priority urgent => immediate
2013-09-13 11:56 egoitz Assigned To AugustoMauch => alostale
2013-09-13 12:16 egoitz Note Added: 0061139
2013-09-13 12:28 egoitz Note Edited: 0061139 View Revisions
2013-09-13 12:34 AugustoMauch Assigned To alostale => AugustoMauch
2013-09-13 14:58 AugustoMauch Note Added: 0061143
2013-09-16 15:17 AugustoMauch Issue Monitored: shankarb
2013-09-16 15:17 AugustoMauch Review Assigned To => shankarb
2013-09-16 15:18 hgbot Checkin
2013-09-16 15:18 hgbot Note Added: 0061174
2013-09-16 15:18 hgbot Status new => resolved
2013-09-16 15:18 hgbot Resolution open => fixed
2013-09-16 15:18 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/9138cdfbcb9badfceaf1a0eb54b4be87fec6eb35 [^]
2013-09-17 09:06 shankarb Note Added: 0061187
2013-09-17 09:06 shankarb Status resolved => closed
2013-09-17 09:06 shankarb Fixed in Version => 3.0MP28
2013-09-17 19:03 hudsonbot Checkin
2013-09-17 19:03 hudsonbot Note Added: 0061257
2013-10-02 09:08 egoitz Relationship added related to 0024863
2019-06-07 12:09 caristu Relationship added related to 0041016


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker