Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0040552
TypeCategorySeverityReproducibilityDate SubmittedLast Update
feature request[Openbravo ERP] A. Platformminorhave not tried2019-04-08 18:032019-05-21 15:16
ReportercaristuView Statuspublic 
Assigned Tocaristu 
PriorityhighResolutionfixedFixed in Version3.0PR19Q3
StatusclosedFix in branchFixed in SCM revisionbdd63e1a8341
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Toalostale
Web browser
ModulesCore
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0040552: upgrade hibernate to version 5.4

DescriptionIt would be nice to upgrade hibernate to version 5.4.x

See: http://wiki.openbravo.com/wiki/Projects:Upgrade_To_Hibernate_5.4 [^]
Steps To Reproduce-
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
related to feature request 0037064 closedcaristu Openbravo ERP upgrade hibernate 
related to defect 0040187 closedcaristu Openbravo ERP export.database gets stuck using old pool 
related to defect 0039128 closedcaristu Openbravo ERP ant compile.apply.module task gets stuck when updating from 2.50 to pi 
related to design defect 0039032 closedplatform Openbravo ERP Illegal Access warning in jaxb-impl-2.2.6 library 
related to defect 0040614 closedcaristu Openbravo ERP API change: support method chaining in OBQuery and OBCriteria 
related to defect 0040649 closedalostale Openbravo ERP no need to open modules for reflection in build tasks 
causes defect 0040631 closedcaristu Modules Analytics module fails to compile after Hibernate upgrade to version 5.4 
causes defect 0040653 closedcaristu Modules Unnecessary @SuppressWarnings("unchecked") after Hibernate upgrade 

-  Notes
(0111170)
hgbot (developer)
2019-04-16 18:33

Repository: erp/devel/pi
Changeset: bdd63e1a834142c97bca4bee8ad1f5afbfadaafd
Author: Carlos Aristu <carlos.aristu <at> openbravo.com>
Date: Tue Apr 16 18:32:16 2019 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/bdd63e1a834142c97bca4bee8ad1f5afbfadaafd [^]

fixes issue 40552: upgrade hibernate to version 5.4

---
M legal/Licensing.txt
M src-db/database/lib/dbsourcemanager.jar
M src-test/src/org/openbravo/test/dal/DalTest.java
M src-test/src/org/openbravo/test/model/DBModifiedTest.java
M src/org/openbravo/dal/service/OBCriteria.java
M src/org/openbravo/dal/service/OBDal.java
M src/org/openbravo/dal/service/OBQuery.java
M src/org/openbravo/dal/xml/XMLEntityConverter.java
M src/org/openbravo/erpCommon/modules/ApplyModuleTask.java
A lib/runtime/FastInfoset-1.2.15.jar
A lib/runtime/byte-buddy-1.9.10.jar
A lib/runtime/dom4j-2.1.1.jar
A lib/runtime/hibernate-commons-annotations-5.1.0.Final.jar
A lib/runtime/hibernate-core-5.4.2.Final.jar
A lib/runtime/istack-commons-runtime-3.0.7.jar
A lib/runtime/javassist-3.24.0-GA.jar
A lib/runtime/jaxb-api-2.3.1.jar
A lib/runtime/jaxb-runtime-2.3.1.jar
A lib/runtime/stax-ex-1.8.jar
A lib/runtime/txw2-2.3.1.jar
R lib/runtime/byte-buddy-1.8.12.jar
R lib/runtime/dom4j-1.6.1.jar
R lib/runtime/hibernate-commons-annotations-5.0.4.Final.jar
R lib/runtime/hibernate-core-5.3.2.Final.jar
R lib/runtime/javassist-3.22.0-GA.jar
R lib/runtime/jaxb-api-2.2.12.jar
R lib/runtime/jaxb-impl-2.2.6.jar
---
(0111171)
hgbot (developer)
2019-04-16 18:36

Repository: erp/devel/dbsm-main
Changeset: 8351dc1d78216400de82f3a1ab9698ef6ebbc3b2
Author: Carlos Aristu <carlos.aristu <at> openbravo.com>
Date: Tue Apr 09 18:24:51 2019 +0200
URL: http://code.openbravo.com/erp/devel/dbsm-main/rev/8351dc1d78216400de82f3a1ab9698ef6ebbc3b2 [^]

related to issue 40552: DBSM changes

  Reverting explicit hibernate closing introduced with[1]. This closing is no longer needed because the validation thread used by the hibernate pool is now a daemon thread[2].

  [1] https://issues.openbravo.com/view.php?id=40187 [^]
  [2] https://hibernate.atlassian.net/browse/HHH-12921 [^]

---
M src/org/openbravo/ddlutils/task/ExportDatabase.java
---
(0111211)
alostale (developer)
2019-04-19 08:07

reviewed + tested
(0111225)
hgbot (developer)
2019-04-23 10:11

Repository: erp/devel/pi
Changeset: bbafbe13a0c24a61c7082b46bc490a50f1e2bebf
Author: Carlos Aristu <carlos.aristu <at> openbravo.com>
Date: Tue Apr 23 10:01:58 2019 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/bbafbe13a0c24a61c7082b46bc490a50f1e2bebf [^]

related to issue 40552: update legal information

---
M legal/Licensing.txt
---
(0111978)
hudsonbot (developer)
2019-05-21 15:16

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/9b8f37d9d85e [^]
Maturity status: Test
(0111991)
hudsonbot (developer)
2019-05-21 15:16

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/9b8f37d9d85e [^]
Maturity status: Test

- Issue History
Date Modified Username Field Change
2019-04-08 18:03 caristu New Issue
2019-04-08 18:03 caristu Assigned To => caristu
2019-04-08 18:03 caristu Modules => Core
2019-04-08 18:03 caristu Triggers an Emergency Pack => No
2019-04-08 18:03 caristu Issue generated from 0037064
2019-04-08 18:03 caristu Relationship added related to 0037064
2019-04-09 17:57 caristu Relationship added related to 0040187
2019-04-09 17:57 caristu Relationship added related to 0039128
2019-04-09 18:45 caristu Relationship added related to 0039032
2019-04-15 09:17 caristu Relationship added related to 0040614
2019-04-16 18:33 hgbot Checkin
2019-04-16 18:33 hgbot Note Added: 0111170
2019-04-16 18:33 hgbot Status new => resolved
2019-04-16 18:33 hgbot Resolution open => fixed
2019-04-16 18:33 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/bdd63e1a834142c97bca4bee8ad1f5afbfadaafd [^]
2019-04-16 18:34 caristu Review Assigned To => alostale
2019-04-16 18:36 hgbot Checkin
2019-04-16 18:36 hgbot Note Added: 0111171
2019-04-17 09:58 caristu Relationship added causes 0040631
2019-04-19 08:07 alostale Note Added: 0111211
2019-04-19 08:07 alostale Status resolved => closed
2019-04-19 08:07 alostale Fixed in Version => 3.0PR19Q3
2019-04-19 08:36 alostale Relationship added related to 0040649
2019-04-23 10:11 hgbot Checkin
2019-04-23 10:11 hgbot Note Added: 0111225
2019-04-23 10:26 caristu Relationship added causes 0040653
2019-05-21 15:16 hudsonbot Checkin
2019-05-21 15:16 hudsonbot Note Added: 0111978
2019-05-21 15:16 hudsonbot Checkin
2019-05-21 15:16 hudsonbot Note Added: 0111991


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker