Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0039128
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] A. Platformminorhave not tried2018-08-13 15:052018-09-03 08:54
ReportercaristuView Statuspublic 
Assigned Tocaristu 
PriorityhighResolutionfixedFixed in Version3.0PR18Q4
StatusclosedFix in branchFixed in SCM revision3ed849d672ae
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned ToAugustoMauch
Web browser
ModulesCore
Regression levelAutomated tests
Regression date2017-07-24
Regression introduced in releasepi
Regression introduced by commithttps://code.openbravo.com/erp/devel/pi/rev/95dcfa93d706654e1fbddfc3966bec7280081ac1 [^]
Triggers an Emergency PackNo
Summary

0039128: ant compile.apply.module task gets stuck when updating from 2.50 to pi

DescriptionWhen updating from 2.50 release to a revision containing the changes of issue 0037064, the ant compile.apply.module task is never finishing.

See the failing job in CI: https://ci.openbravo.com/job/up-2.50topi-oracle/256/console [^]
Steps To Reproduce1) hg up -C 2.50MP24
2) ant install.source
3) Run the following SQL command: delete from C_BP_CUSTOMER_ACCT where C_BP_CUSTOMER_ACCT_id in ('1000020', '1000019', '1000024', '1000022', '1000021');
4) hg up -C tip
5) ant smartbuild -Dlocal=no

Note that the compilation gets stuck at the end of the ApllyModulesTask task:
[java] 10540 [main] INFO org.openbravo.erpCommon.modules.ApplyModule - Looking for translation modules
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
related to design defect 0039056 closedcaristu Hibernate pool is being used by some ant tasks 
caused by feature request 0037064 closedcaristu upgrade hibernate 
related to defect 0040187 closedcaristu export.database gets stuck using old pool 
related to feature request 0040552 closedcaristu upgrade hibernate to version 5.4 

-  Notes
(0106410)
hgbot (developer)
2018-08-20 11:10

Repository: erp/devel/pi
Changeset: 3ed849d672ae34b8bcec1d16aaea800ea68e5c61
Author: Carlos Aristu <carlos.aristu <at> openbravo.com>
Date: Mon Aug 20 09:17:57 2018 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/3ed849d672ae34b8bcec1d16aaea800ea68e5c61 [^]

fixes bug 39128: compile.apply.module task gets stuck on 2.50 to pi updating

  The compile.apply.module ant task uses the Hibernate pool during the process of updating 2.50 to pi. Under this scenario, the task was never finishing because although all its actions were completed, the jvm was not able to terminate due to a non-daemon thread used by the Hibernate pool to validate its status.

  To avoid this problem, we force the stop of the non-daemon thread by explicitly closing the Hibernate pool once the task has finished using DAL.

---
M src/org/openbravo/erpCommon/modules/ApplyModuleTask.java
---
(0106451)
hudsonbot (developer)
2018-08-23 04:10

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/e67e370df884 [^]
Maturity status: Test
(0106457)
caristu (developer)
2018-08-23 10:06
edited on: 2018-08-23 10:07

Reported to Hibernate, as the thread used to validate the pool should be defined as daemon:

https://hibernate.atlassian.net/browse/HHH-12921 [^]

Reported also a feature request to give a descriptive name to the thread:

https://hibernate.atlassian.net/browse/HHH-12922 [^]

Note that both issues have been already fixed:

https://github.com/hibernate/hibernate-orm/commit/6911efdfb71beff3a30162b663c308dbacca7c76 [^]

(0106577)
AugustoMauch (developer)
2018-09-03 08:54

Code reviewed and verified

- Issue History
Date Modified Username Field Change
2018-08-13 15:05 caristu New Issue
2018-08-13 15:05 caristu Assigned To => platform
2018-08-13 15:05 caristu Modules => Core
2018-08-13 15:05 caristu Triggers an Emergency Pack => No
2018-08-13 15:05 caristu Relationship added related to 0039056
2018-08-13 15:05 caristu Relationship added caused by 0037064
2018-08-13 15:06 caristu Regression level => Automated tests
2018-08-13 15:06 caristu Regression date => 2017-07-24
2018-08-13 15:06 caristu Regression introduced in release => pi
2018-08-13 15:06 caristu Regression introduced by commit => https://code.openbravo.com/erp/devel/pi/rev/95dcfa93d706654e1fbddfc3966bec7280081ac1 [^]
2018-08-13 15:07 caristu Description Updated View Revisions
2018-08-13 15:07 caristu Steps to Reproduce Updated View Revisions
2018-08-13 15:27 caristu File Added: issue39128.export
2018-08-20 11:06 caristu Assigned To platform => caristu
2018-08-20 11:06 caristu File Deleted: issue39128.export
2018-08-20 11:10 hgbot Checkin
2018-08-20 11:10 hgbot Note Added: 0106410
2018-08-20 11:10 hgbot Status new => resolved
2018-08-20 11:10 hgbot Resolution open => fixed
2018-08-20 11:10 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/3ed849d672ae34b8bcec1d16aaea800ea68e5c61 [^]
2018-08-20 11:14 caristu Review Assigned To => AugustoMauch
2018-08-23 04:10 hudsonbot Checkin
2018-08-23 04:10 hudsonbot Note Added: 0106451
2018-08-23 10:06 caristu Note Added: 0106457
2018-08-23 10:07 caristu Note Edited: 0106457 View Revisions
2018-09-03 08:54 AugustoMauch Note Added: 0106577
2018-09-03 08:54 AugustoMauch Status resolved => closed
2018-09-03 08:54 AugustoMauch Fixed in Version => 3.0PR18Q4
2019-02-12 19:20 caristu Relationship added related to 0040187
2019-04-09 17:57 caristu Relationship added related to 0040552


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker