Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0040649
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] A. Platformtrivialhave not tried2019-04-19 08:352019-04-26 08:41
ReporteralostaleView Statuspublic 
Assigned Toalostale 
PrioritynormalResolutionfixedFixed in Version3.0PR19Q3
StatusclosedFix in branchFixed in SCM revision349c4b630c6c
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Tocaristu
Web browser
ModulesCore
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0040649: no need to open modules for reflection in build tasks

DescriptionJDK's java.lang and java.base modules were opened for refection in order to prevent illegal reflective access in build tasks caused by jaxb 2.2.6. Now that jaxb has been updated to 2.3.1, this is not required anymore.
Steps To ReproduceUsing JDK9+ run ant generate.entities.quick -Djvm.arg.line='--illegal-access=debug'
  -> now no warning is displayed
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
related to defect 00393723.0PR18Q4 closedalostale Illegal Access warning in ant tasks 
related to feature request 0040552 closedcaristu upgrade hibernate to version 5.4 
depends on design defect 0039032 closedplatform Illegal Access warning in jaxb-impl-2.2.6 library 
blocks design defect 0039031 newplatform Tracking issue: Remove illegal access warnings shown since java9 by updating affected jar libraries 

-  Notes
(0111215)
hgbot (developer)
2019-04-19 08:39

Repository: erp/devel/pi
Changeset: 349c4b630c6c4ca41210e400b864899924eebe55
Author: Asier Lostalé <asier.lostale <at> openbravo.com>
Date: Fri Apr 19 08:38:44 2019 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/349c4b630c6c4ca41210e400b864899924eebe55 [^]

fixes 40649: no need to open modules for reflection in build tasks

  Reverted changeset done for 0039372 as after updating jaxb this is no
  longer needed.

---
M build.xml
M src/build.xml
---
(0111338)
caristu (developer)
2019-04-26 08:41

Reviewed

- Issue History
Date Modified Username Field Change
2019-04-19 08:35 alostale New Issue
2019-04-19 08:35 alostale Assigned To => alostale
2019-04-19 08:35 alostale Modules => Core
2019-04-19 08:35 alostale Triggers an Emergency Pack => No
2019-04-19 08:35 alostale Relationship added depends on 0039032
2019-04-19 08:35 alostale Relationship added related to 0039372
2019-04-19 08:36 alostale Relationship added blocks 0039031
2019-04-19 08:36 alostale Relationship added related to 0040552
2019-04-19 08:39 hgbot Checkin
2019-04-19 08:39 hgbot Note Added: 0111215
2019-04-19 08:39 hgbot Status new => resolved
2019-04-19 08:39 hgbot Resolution open => fixed
2019-04-19 08:39 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/349c4b630c6c4ca41210e400b864899924eebe55 [^]
2019-04-19 08:39 alostale Review Assigned To => caristu
2019-04-26 08:41 caristu Note Added: 0111338
2019-04-26 08:41 caristu Status resolved => closed
2019-04-26 08:41 caristu Fixed in Version => 3.0PR19Q3


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker