Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0035658
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] A. Platformmajoralways2017-03-30 16:222017-05-29 17:43
ReporterJONHMView Statuspublic 
Assigned Toinigosanchez 
PrioritynormalResolutionfixedFixed in Version3.0PR17Q3
StatusclosedFix in branchFixed in SCM revisionbcf679ab26bb
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionpiSCM revision 
Review Assigned Tocaristu
Web browser
ModulesCore
Regression levelProduction - Confirmed Stable
Regression date2016-02-11
Regression introduced in release3.0PR16Q2
Regression introduced by commithttps://code.openbravo.com/erp/devel/pi/rev/670d9903e7053700dad4cd2321b3df166571e122 [^]
Triggers an Emergency PackNo
Summary

0035658: Fields redraws in grid view when a numeric field is referenced by a read only logic

DescriptionWhen editing a numeric field in grid view which is referenced by read only logic by some other field of the same table, it redraws and format its value automatically
Steps To ReproduceAs System Administrator:
1) Open 'Tables and columns' window
2) Select C_OrderLine table and PriceActual field
3) Edit its Read Only Logic adding the reference to the PriceList column:
 @Processed@='Y' | @GROSSPRICE@='Y' & @PriceList@!0
4) Then, make the same step with the PriceList field, referencing the PriceActual column:
 @Processed@='Y' & @PriceActual@!0

As 'F&B International Group Admin':
4) Open Sales Order window and create a new record
5) Create a new record in grid view into [Lines] subtab also change its 'Net Unit Price'
--> The net unit price will be redrawed inmediately
TagsNo tags attached.
Attached Files? file icon redraw.mp4 [^] (575,614 bytes) 2017-03-30 16:22

- Relationships Relation Graph ] Dependency Graph ]
related to defect 0031198 closedinigosanchez Read Only logic does not work properly in grid view with combo type fields. 
related to defect 0023136 closedshankarb Quantity field behaves differently in Sales Order Line and Purchase Order Line 
depends on backport 00358053.0PR17Q2 closedinigosanchez Fields redraws in grid view when a numeric field is referenced by a read only logic 
depends on backport 00358063.0PR17Q1.1 closedinigosanchez Fields redraws in grid view when a numeric field is referenced by a read only logic 
depends on backport 00358073.0PR16Q4.4 closedinigosanchez Fields redraws in grid view when a numeric field is referenced by a read only logic 
caused by defect 00322023.0PR16Q2 closedcaristu Error in add payment when editing the amount of a record in order/invoice grid 
related to defect 0035665 closedcaristu Wrong behaviour filling some fields. In Financial Acc. || Transaction while filling Transaction Date, Accounting Date is deleted 
causes defect 0035873 closedinigosanchez On change functions not executed for numeric parameters 

-  Notes
(0095850)
inigosanchez (developer)
2017-04-05 17:03

This issue is not reproducible with the provided steps. Please update it properly.
(0096087)
inigosanchez (developer)
2017-04-20 13:21

Added to testlink following tests in Platform > [ROL] Read Only Logic:
-[ROLa] Read Only in grid > ROLa040 RO works as expected with number fields.
-[ROLb] Read Only in form > ROLb040 RO works as expected with number fields.
(0096103)
hgbot (developer)
2017-04-21 13:56

Repository: erp/devel/pi
Changeset: bcf679ab26bb68d6e390d0d443c36349811b2918
Author: Inigo Sanchez <inigo.sanchez <at> openbravo.com>
Date: Fri Apr 21 13:55:46 2017 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/bcf679ab26bb68d6e390d0d443c36349811b2918 [^]

Fixed issue 35658: Fields redraw instantly in grid under some circumstances

The problem was that numeric fields redraws instantly in grid view when a numeric field
was referenced by a read only logic. This reported problem was caused by the partial fix
of 0032202 regression.

The fix of 0032202 was partial because the added condition did not taken into account the
grid view properly. This problem has been resolved by take into account form and grid view.

Besides another problem was found and resolved with this fix. Since this regression was
introduced, the 0023136 issue was broken too. This problem has been resolved too with this
solution.

---
M modules/org.openbravo.client.application/web/org.openbravo.client.application/js/form/formitem/ob-formitem-number.js
---
(0096104)
inigosanchez (developer)
2017-04-21 13:57

Several manual test can be found here: https://docs.google.com/a/openbravo.com/spreadsheets/d/1jSu4XQdd9tSsiUf9mU8iP5pbw68oQa2xmypOs-zxnPg/edit?usp=sharing [^]
(0096110)
caristu (developer)
2017-04-24 09:41

Reopened to improve the check and cover all the cases. For more info see: https://docs.google.com/spreadsheets/d/18l2biKWeG6iGDIPqO6VuYQ_TtP_6YxyQU4KSrPvQlJ8/edit#gid=0 [^]
(0096124)
hgbot (developer)
2017-04-24 12:13

Repository: erp/devel/pi
Changeset: 9b4f2a32e438f514ed632c83f4601a08a39b7599
Author: Inigo Sanchez <inigo.sanchez <at> openbravo.com>
Date: Mon Apr 24 12:06:00 2017 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/9b4f2a32e438f514ed632c83f4601a08a39b7599 [^]

Related with issue 35658: Codereview take into account all the cases

Now it is take into account when a parameter window with grid is opened from the menu.
Rest of the cases sucha as grid, form and parameter window from a button is working as
expected too.

---
M modules/org.openbravo.client.application/web/org.openbravo.client.application/js/form/formitem/ob-formitem-number.js
---
(0096125)
inigosanchez (developer)
2017-04-24 12:14

Aditional manual test for the codereview:
-Sales order > Lines > In grid view
-Sales Order > Lines > In Form view
-Payment in > Add details > Edit a value in the grid
-Add Payment* from menu > Edit value in the grid

*This module[1] is used to check a parameter window with grid (Add Payment) launched from a menu entry.

[1].- http://centralrepository.openbravo.com/openbravo/org.openbravo.forge.ui/ForgeModuleDetail/Add-Payment-Credit-Payments-Grid [^]
(0096132)
caristu (developer)
2017-04-24 13:43

Code reviewed + tested in pi@9b4f2a32e438
(0096899)
hudsonbot (developer)
2017-05-29 17:43

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/1ee70113bdc4 [^]
Maturity status: Test
(0096902)
hudsonbot (developer)
2017-05-29 17:43

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/1ee70113bdc4 [^]
Maturity status: Test

- Issue History
Date Modified Username Field Change
2017-03-30 16:22 JONHM New Issue
2017-03-30 16:22 JONHM Assigned To => platform
2017-03-30 16:22 JONHM File Added: redraw.mp4
2017-03-30 16:22 JONHM Modules => Core
2017-03-30 16:22 JONHM Triggers an Emergency Pack => No
2017-04-05 16:26 inigosanchez Steps to Reproduce Updated View Revisions
2017-04-05 17:03 inigosanchez Note Added: 0095850
2017-04-05 17:03 inigosanchez Assigned To platform => JONHM
2017-04-05 17:03 inigosanchez Status new => feedback
2017-04-06 13:19 JONHM Status feedback => new
2017-04-06 13:19 JONHM Steps to Reproduce Updated View Revisions
2017-04-06 13:30 JONHM Assigned To JONHM => platform
2017-04-07 09:05 alostale Status new => acknowledged
2017-04-07 09:06 alostale Relationship added related to 0035665
2017-04-18 09:07 inigosanchez Status acknowledged => scheduled
2017-04-18 09:07 inigosanchez Assigned To platform => inigosanchez
2017-04-18 14:32 inigosanchez Relationship added related to 0031198
2017-04-20 10:52 inigosanchez Relationship added caused by 0032202
2017-04-20 10:55 inigosanchez Regression level => Production - Confirmed Stable
2017-04-20 10:55 inigosanchez Regression date => 2016-02-11
2017-04-20 10:55 inigosanchez Regression introduced in release => 3.0PR16Q2
2017-04-20 10:55 inigosanchez Regression introduced by commit => https://code.openbravo.com/erp/devel/pi/rev/670d9903e7053700dad4cd2321b3df166571e122 [^]
2017-04-20 10:57 inigosanchez Status scheduled => acknowledged
2017-04-20 10:57 inigosanchez Status acknowledged => scheduled
2017-04-20 13:21 inigosanchez Note Added: 0096087
2017-04-21 12:44 inigosanchez Review Assigned To => caristu
2017-04-21 13:56 hgbot Checkin
2017-04-21 13:56 hgbot Note Added: 0096103
2017-04-21 13:56 hgbot Status scheduled => resolved
2017-04-21 13:56 hgbot Resolution open => fixed
2017-04-21 13:56 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/bcf679ab26bb68d6e390d0d443c36349811b2918 [^]
2017-04-21 13:57 inigosanchez Note Added: 0096104
2017-04-21 13:57 inigosanchez Relationship added related to 0023136
2017-04-24 09:41 caristu Note Added: 0096110
2017-04-24 09:41 caristu Status resolved => new
2017-04-24 09:41 caristu Resolution fixed => open
2017-04-24 11:54 inigosanchez Status new => scheduled
2017-04-24 12:13 hgbot Checkin
2017-04-24 12:13 hgbot Note Added: 0096124
2017-04-24 12:14 inigosanchez Note Added: 0096125
2017-04-24 13:16 inigosanchez Status scheduled => resolved
2017-04-24 13:16 inigosanchez Resolution open => fixed
2017-04-24 13:43 caristu Note Added: 0096132
2017-04-24 13:43 caristu Status resolved => closed
2017-04-24 13:43 caristu Fixed in Version => 3.0PR17Q3
2017-04-28 11:20 caristu Relationship added causes 0035873
2017-05-29 17:43 hudsonbot Checkin
2017-05-29 17:43 hudsonbot Note Added: 0096899
2017-05-29 17:43 hudsonbot Checkin
2017-05-29 17:43 hudsonbot Note Added: 0096902


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker