Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0032202
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] A. Platformminoralways2016-02-11 12:492016-03-17 10:56
ReporteraferrazView Statuspublic 
Assigned Tocaristu 
PriorityimmediateResolutionfixedFixed in Version3.0PR16Q2
StatusclosedFix in branchFixed in SCM revision670d9903e705
ProjectionnoneETAnoneTarget Version3.0PR16Q2
OSLinux 64 bitDatabasePostgreSQLJava version1.6.0_18
OS VersionProfessional ApplianceDatabase version8.3.9Ant version1.7.1
Product VersionSCM revision 
Review Assigned Toalostale
Web browser
ModulesCore
Regression levelPre packaging ( pi )
Regression date2016-01-25
Regression introduced in releasepi
Regression introduced by commithttps://code.openbravo.com/erp/devel/pi/rev/69d968879453d377cda8501a1cf0a6c9772d3693 [^]
Triggers an Emergency PackNo
Summary

0032202: Error in add payment when editing the amount of a record in order/invoice grid

DescriptionError in add payment when editing the amount of a record in order/invoice grid
Steps To Reproduce- Create a Sales Order and complete it.
- Click on Add Payment
  Edit amount of selected record in order/invoice grid
  Realize the following error is shown: "Value is not a valid number"
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
related to defect 00230563.0MP21 closedshankarb Ordered Quantiy field of Sales Order is not properly auto filling the grouping separator 
caused by defect 0031901 closedcaristu decimal value can't be changed by trigger/observer after manual edition in form view 
causes defect 0035658 closedinigosanchez Fields redraws in grid view when a numeric field is referenced by a read only logic 

-  Notes
(0084111)
caristu (developer)
2016-02-11 15:53
edited on: 2016-02-11 16:01

The error is fired by the orderInvoiceGridValidation() method because it is receiving the decimal value as a string.

This is caused because the value is being set every time it changes, with the entered value. This is done to solve issue 0023056 to make sure that the grouping separator is not placed in a wrong place. This problem only affects to standard windows.

Before solving issue 0031901 the value was not being set on change in pick and execute windows. So, to solve this issue we just need to avoid setting the value in that event for this kind of windows, as it was done before.

(0084112)
hgbot (developer)
2016-02-11 16:00

Repository: erp/devel/pi
Changeset: 670d9903e7053700dad4cd2321b3df166571e122
Author: Carlos Aristu <carlos.aristu <at> openbravo.com>
Date: Thu Feb 11 15:57:36 2016 +0100
URL: http://code.openbravo.com/erp/devel/pi/rev/670d9903e7053700dad4cd2321b3df166571e122 [^]

fixes issue 32202: Error in add payment when editing the amount of a record

The entered value is being set on the changed method for number items. This is done in order to prevent placing the decimal separator in a wrong place. This problem only affects to standard windows.

To solve the problem we only set the number item value in the changed method when we are not in a pick and edit window but in a standard window.

---
M modules/org.openbravo.client.application/web/org.openbravo.client.application/js/form/formitem/ob-formitem-number.js
---
(0084138)
alostale (developer)
2016-02-12 08:44

code reviewed + tested
(0085128)
hudsonbot (developer)
2016-03-17 10:56

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/b22fb0500156 [^]
Maturity status: Test

- Issue History
Date Modified Username Field Change
2016-02-11 12:49 aferraz New Issue
2016-02-11 12:49 aferraz Assigned To => caristu
2016-02-11 12:49 aferraz Modules => Core
2016-02-11 12:49 aferraz Regression level => Pre packaging ( pi )
2016-02-11 12:49 aferraz Regression introduced in release => pi
2016-02-11 12:49 aferraz Triggers an Emergency Pack => No
2016-02-11 14:11 caristu Status new => scheduled
2016-02-11 15:45 caristu Relationship added caused by 0031901
2016-02-11 15:46 caristu Relationship added related to 0023056
2016-02-11 15:53 caristu Note Added: 0084111
2016-02-11 15:54 caristu Regression date => 2016-01-25
2016-02-11 15:54 caristu Regression introduced by commit => https://code.openbravo.com/erp/devel/pi/rev/69d968879453d377cda8501a1cf0a6c9772d3693 [^]
2016-02-11 16:00 hgbot Checkin
2016-02-11 16:00 hgbot Note Added: 0084112
2016-02-11 16:00 hgbot Status scheduled => resolved
2016-02-11 16:00 hgbot Resolution open => fixed
2016-02-11 16:00 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/670d9903e7053700dad4cd2321b3df166571e122 [^]
2016-02-11 16:01 caristu Review Assigned To => alostale
2016-02-11 16:01 caristu Issue Monitored: alostale
2016-02-11 16:01 caristu Note Edited: 0084111 View Revisions
2016-02-12 08:44 alostale Note Added: 0084138
2016-02-12 08:44 alostale Status resolved => closed
2016-02-12 08:44 alostale Fixed in Version => 3.0PR16Q2
2016-03-17 10:56 hudsonbot Checkin
2016-03-17 10:56 hudsonbot Note Added: 0085128
2017-04-20 10:52 inigosanchez Relationship added causes 0035658


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker