Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0023136
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] A. Platformminoralways2013-02-21 11:002013-02-27 11:03
ReporterAugustoMauchView Statuspublic 
Assigned Toshankarb 
PrioritynormalResolutionfixedFixed in Version3.0MP21
StatusclosedFix in branchpiFixed in SCM revision485822d38b74
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned ToAugustoMauch
Web browser
ModulesCore
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0023136: Quantity field behaves differently in Sales Order Line and Purchase Order Line

DescriptionThe quantity field of the Line tab is not working the same way in Sales Order and in Purchase Order. In Sales Order the group separator is added while the user enters texts, while in Purchase Order the grouping separator is not added until the field loses the focus.
Steps To Reproduce- Open Sales Order
- Create a Header
- Create a line, and enter 10000 in the quantity field. Notice that the group separator is added while the text is being entered

- Open Purchase Order
- Create a Header
- Create a line, and enter 10000 in the quantity field. Notice that the group separator is not added until field loses the focus
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
related to defect 00230563.0MP21 closedshankarb Ordered Quantiy field of Sales Order is not properly auto filling the grouping separator 
related to defect 0031901 closedcaristu decimal value can't be changed by trigger/observer after manual edition in form view 
related to defect 0035658 closedinigosanchez Fields redraws in grid view when a numeric field is referenced by a read only logic 

-  Notes
(0056798)
shankarb (developer)
2013-02-27 07:47

Fixed in pi changeset https://code.openbravo.com/erp/devel/pi/rev/485822d38b74 [^]
(0056800)
AugustoMauch (developer)
2013-02-27 11:03

Code reviewed and verified in pi@2502e500a99d

The quantity field in the sales order window was being formatted after each change because the visibility of another field depended on its value, so it was marked as redrawonchange=true.

- Issue History
Date Modified Username Field Change
2013-02-21 11:00 AugustoMauch New Issue
2013-02-21 11:00 AugustoMauch Assigned To => shankarb
2013-02-21 11:00 AugustoMauch Modules => Core
2013-02-21 11:00 AugustoMauch Triggers an Emergency Pack => No
2013-02-21 11:01 AugustoMauch Relationship added related to 0023056
2013-02-27 07:42 shankarb Review Assigned To => AugustoMauch
2013-02-27 07:42 shankarb Issue Monitored: AugustoMauch
2013-02-27 07:45 shankarb Status new => scheduled
2013-02-27 07:45 shankarb fix_in_branch => pi
2013-02-27 07:46 shankarb Status scheduled => resolved
2013-02-27 07:46 shankarb Fixed in SCM revision => https://code.openbravo.com/erp/devel/pi/rev/485822d38b74 [^]
2013-02-27 07:46 shankarb Resolution open => fixed
2013-02-27 07:47 shankarb Note Added: 0056798
2013-02-27 11:03 AugustoMauch Note Added: 0056800
2013-02-27 11:03 AugustoMauch Status resolved => closed
2013-02-27 11:03 AugustoMauch Fixed in Version => 3.0MP21
2016-01-25 12:49 caristu Relationship added related to 0031901
2017-04-21 13:57 inigosanchez Relationship added related to 0035658


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker