Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0034938
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] 07. Sales managementminorhave not tried2017-01-13 09:332017-01-17 13:45
ReporteralostaleView Statuspublic 
Assigned Toalostale 
PriorityimmediateResolutionfixedFixed in Version3.0PR17Q2
StatusclosedFix in branchFixed in SCM revision6398d4e21157
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Tovmromanos
Web browser
ModulesCore
Regression levelProduction - QA Approved
Regression date2016-08-29
Regression introduced in release3.0PR16Q4
Regression introduced by commithttps://code.openbravo.com/erp/devel/pi/rev/e3d66eaa40b5 [^]
Triggers an Emergency PackNo
Summary

0034938: can't select product in Return from Customer > Insert Orphan Line

DescriptionWhen trying to insert an orphan line in a return from customer, it is not possible to select the product: the selector is not displayed.

This is caused by a JS error which prevents the flow to continue:
  
  Uncaught TypeError: Cannot read property 'register' of undefined

  in file cancelAndReplace.js, line:

  OB.EventHandlerRegistry.register(OB.CancelAndReplace.SALES_ORDERLINES_TAB, OB.EventHandlerRegistry.PREDELETE, OB.CancelAndReplace.ClientSideEventHandlersPreDelete.showMessage, 'OBCancelAndReplace_ShowMessage');


The problem is caused because cancelAndReplace.js is loaded within js static resources for classic windows, but the infrastructure it relies on (OB.EventHandlerRegistry) is not causing to fail when tried to be loaded in classic mode.
Steps To Reproduce1. Create a preference 'RM Allow Orphan Line' with value 'Y'
2. Log in again
3. Create a new record in Return from Customer window
4. Click on Insert Orphan line
  -> ERROR:
      * realize it's not possible to select a product as the product selector is not available.
      * JS error can be seen in console
Proposed SolutionCancel and Replace is not designed to work in classic mode, so its JS shouldn't be loaded in this case.
TagsNo tags attached.
Attached Filespng file icon Selection_145.png [^] (47,750 bytes) 2017-01-13 09:38

- Relationships Relation Graph ] Dependency Graph ]
depends on backport 00349393.0PR17Q1 closedalostale can't select product in Return from Customer > Insert Orphan Line 
depends on backport 00349403.0PR16Q4.1 closedalostale can't select product in Return from Customer > Insert Orphan Line 
caused by feature request 00349373.0PR16Q4 closedTriage Finance Cancel & Replace functionality 
blocks defect 0034797 closedalostale Insert Orphan line preference allows to insert products without having into account organization. 

-  Notes
(0093473)
alostale (developer)
2017-01-13 10:06

Incorrect issue number in commit message:

Repository: erp/devel/pi
Changeset: 6398d4e21157f2e64580a955ed56368ea5af1e50
Author: Asier Lostalé <asier.lostale <at> openbravo.com>
Date: Fri Jan 13 10:03:39 2017 +0100
URL: http://code.openbravo.com/erp/devel/pi/rev/6398d4e21157f2e64580a955ed56368ea5af1e50 [^] [^]

fixed bug 34939: 3.0 selectors cannot be used in classic mode

  When a 3.0 selector was included within classic mode, the JS failed to load.

  The problem was cancelAndReplace.js was included within classic mode JS but it
  depends on resources not available in this mode.

  Because cancel and replace is not designed to work in classic mode, its JS is
  now not included in this mode.

---
M modules/org.openbravo.client.application/src/org/openbravo/client/application/ApplicationComponentProvider.java
---
(0093474)
alostale (developer)
2017-01-13 10:27

Added test case to TestLink: https://testlink.openbravo.com/testlink/linkto.php?tprojectPrefix=Communit&item=testcase&id=Communit-10520 [^]
(0093637)
vmromanos (developer)
2017-01-17 13:45

Code review + testing OK.
Verified Cancel and Replace keeps on working fine.

- Issue History
Date Modified Username Field Change
2017-01-13 09:33 alostale New Issue
2017-01-13 09:33 alostale Assigned To => Triage Finance
2017-01-13 09:33 alostale Modules => Core
2017-01-13 09:33 alostale Triggers an Emergency Pack => No
2017-01-13 09:38 alostale File Added: Selection_145.png
2017-01-13 09:42 alostale Description Updated View Revisions
2017-01-13 09:42 alostale Steps to Reproduce Updated View Revisions
2017-01-13 09:42 alostale Proposed Solution updated
2017-01-13 09:45 alostale Regression level => Production - QA Approved
2017-01-13 09:45 alostale Regression date => 2016-08-29
2017-01-13 09:45 alostale Regression introduced in release => 3.0PR16Q4
2017-01-13 09:45 alostale Regression introduced by commit => https://code.openbravo.com/erp/devel/pi/rev/e3d66eaa40b5 [^]
2017-01-13 09:45 alostale Priority normal => immediate
2017-01-13 09:45 alostale Assigned To Triage Finance => alostale
2017-01-13 09:45 alostale Review Assigned To => vmromanos
2017-01-13 09:46 alostale Relationship added caused by 0034937
2017-01-13 09:46 alostale Relationship added blocks 0034797
2017-01-13 09:47 alostale Status new => scheduled
2017-01-13 10:06 alostale Note Added: 0093473
2017-01-13 10:06 alostale Status scheduled => resolved
2017-01-13 10:06 alostale Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/6398d4e21157f2e64580a955ed56368ea5af1e50 [^]
2017-01-13 10:06 alostale Resolution open => fixed
2017-01-13 10:27 alostale Note Added: 0093474
2017-01-17 13:45 vmromanos Note Added: 0093637
2017-01-17 13:45 vmromanos Status resolved => closed
2017-01-17 13:45 vmromanos Fixed in Version => 3.0PR17Q2


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker