Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0034940
TypeCategorySeverityReproducibilityDate SubmittedLast Update
backport[Openbravo ERP] 07. Sales managementminorhave not tried2017-01-13 09:332017-01-17 13:45
ReporteralostaleView Statuspublic 
Assigned Toalostale 
PriorityimmediateResolutionfixedFixed in Version3.0PR16Q4.1
StatusclosedFix in branchFixed in SCM revisionafb941dffaf8
ProjectionnoneETAnoneTarget Version3.0PR16Q4.1
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Tovmromanos
Web browser
ModulesCore
Regression levelProduction - QA Approved
Regression date2016-08-29
Regression introduced in release3.0PR16Q4
Regression introduced by commithttps://code.openbravo.com/erp/devel/pi/rev/e3d66eaa40b5 [^]
Triggers an Emergency PackNo
Summary

0034940: can't select product in Return from Customer > Insert Orphan Line

DescriptionWhen trying to insert an orphan line in a return from customer, it is not possible to select the product: the selector is not displayed.

This is caused by a JS error which prevents the flow to continue:
  
  Uncaught TypeError: Cannot read property 'register' of undefined

  in file cancelAndReplace.js, line:

  OB.EventHandlerRegistry.register(OB.CancelAndReplace.SALES_ORDERLINES_TAB, OB.EventHandlerRegistry.PREDELETE, OB.CancelAndReplace.ClientSideEventHandlersPreDelete.showMessage, 'OBCancelAndReplace_ShowMessage');


The problem is caused because cancelAndReplace.js is loaded within js static resources for classic windows, but the infrastructure it relies on (OB.EventHandlerRegistry) is not causing to fail when tried to be loaded in classic mode.
Steps To Reproduce1. Create a preference 'RM Allow Orphan Line' with value 'Y'
2. Log in again
3. Create a new record in Return from Customer window
4. Click on Insert Orphan line
  -> ERROR:
      * realize it's not possible to select a product as the product selector is not available.
      * JS error can be seen in console
Proposed SolutionCancel and Replace is not designed to work in classic mode, so its JS shouldn't be loaded in this case.
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
blocks defect 0034938 closedalostale can't select product in Return from Customer > Insert Orphan Line 

-  Notes
(0093633)
hgbot (developer)
2017-01-17 13:39

Repository: erp/backports/3.0PR16Q4.1
Changeset: afb941dffaf8adc83579364324f9eb9b0145886d
Author: Asier Lostalé <asier.lostale <at> openbravo.com>
Date: Fri Jan 13 10:03:39 2017 +0100
URL: http://code.openbravo.com/erp/backports/3.0PR16Q4.1/rev/afb941dffaf8adc83579364324f9eb9b0145886d [^]

Fixed bug 34940: 3.0 selectors cannot be used in classic mode

  When a 3.0 selector was included within classic mode, the JS failed to load.

  The problem was cancelAndReplace.js was included within classic mode JS but it
  depends on resources not available in this mode.

  Because cancel and replace is not designed to work in classic mode, its JS is
  now not included in this mode.

---
M modules/org.openbravo.client.application/src/org/openbravo/client/application/ApplicationComponentProvider.java
---
(0093635)
vmromanos (developer)
2017-01-17 13:45

Code review + testing OK.
Verified Cancel and Replace keeps on working fine.

- Issue History
Date Modified Username Field Change
2017-01-13 09:47 alostale Type defect => backport
2017-01-13 09:47 alostale Target Version => 3.0PR16Q4.1
2017-01-13 09:49 alostale Assigned To alostale => Triage Finance
2017-01-13 09:49 alostale Status scheduled => feedback
2017-01-13 09:50 alostale Status feedback => new
2017-01-17 13:33 vmromanos Status new => scheduled
2017-01-17 13:33 vmromanos Assigned To Triage Finance => alostale
2017-01-17 13:39 hgbot Checkin
2017-01-17 13:39 hgbot Note Added: 0093633
2017-01-17 13:39 hgbot Status scheduled => resolved
2017-01-17 13:39 hgbot Resolution open => fixed
2017-01-17 13:39 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/backports/3.0PR16Q4.1/rev/afb941dffaf8adc83579364324f9eb9b0145886d [^]
2017-01-17 13:45 vmromanos Note Added: 0093635
2017-01-17 13:45 vmromanos Status resolved => closed
2017-01-17 13:45 vmromanos Fixed in Version => 3.0PR16Q4.1


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker