Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0034939
TypeCategorySeverityReproducibilityDate SubmittedLast Update
backport[Openbravo ERP] 07. Sales managementminorhave not tried2017-01-13 09:332017-03-15 20:18
ReporteralostaleView Statuspublic 
Assigned Toalostale 
PriorityimmediateResolutionfixedFixed in Version3.0PR17Q1
StatusclosedFix in branchFixed in SCM revision2d974ebf8d14
ProjectionnoneETAnoneTarget Version3.0PR17Q1
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Tovmromanos
Web browser
ModulesCore
Regression levelProduction - QA Approved
Regression date2016-08-29
Regression introduced in release3.0PR16Q4
Regression introduced by commithttps://code.openbravo.com/erp/devel/pi/rev/e3d66eaa40b5 [^]
Triggers an Emergency PackNo
Summary

0034939: can't select product in Return from Customer > Insert Orphan Line

DescriptionWhen trying to insert an orphan line in a return from customer, it is not possible to select the product: the selector is not displayed.

This is caused by a JS error which prevents the flow to continue:
  
  Uncaught TypeError: Cannot read property 'register' of undefined

  in file cancelAndReplace.js, line:

  OB.EventHandlerRegistry.register(OB.CancelAndReplace.SALES_ORDERLINES_TAB, OB.EventHandlerRegistry.PREDELETE, OB.CancelAndReplace.ClientSideEventHandlersPreDelete.showMessage, 'OBCancelAndReplace_ShowMessage');


The problem is caused because cancelAndReplace.js is loaded within js static resources for classic windows, but the infrastructure it relies on (OB.EventHandlerRegistry) is not causing to fail when tried to be loaded in classic mode.
Steps To Reproduce1. Create a preference 'RM Allow Orphan Line' with value 'Y'
2. Log in again
3. Create a new record in Return from Customer window
4. Click on Insert Orphan line
  -> ERROR:
      * realize it's not possible to select a product as the product selector is not available.
      * JS error can be seen in console
Proposed SolutionCancel and Replace is not designed to work in classic mode, so its JS shouldn't be loaded in this case.
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
blocks defect 0034938 closedalostale can't select product in Return from Customer > Insert Orphan Line 

-  Notes
(0093471)
hgbot (developer)
2017-01-13 10:04

Repository: erp/devel/pi
Changeset: 6398d4e21157f2e64580a955ed56368ea5af1e50
Author: Asier Lostalé <asier.lostale <at> openbravo.com>
Date: Fri Jan 13 10:03:39 2017 +0100
URL: http://code.openbravo.com/erp/devel/pi/rev/6398d4e21157f2e64580a955ed56368ea5af1e50 [^]

fixed bug 34939: 3.0 selectors cannot be used in classic mode

  When a 3.0 selector was included within classic mode, the JS failed to load.

  The problem was cancelAndReplace.js was included within classic mode JS but it
  depends on resources not available in this mode.

  Because cancel and replace is not designed to work in classic mode, its JS is
  now not included in this mode.

---
M modules/org.openbravo.client.application/src/org/openbravo/client/application/ApplicationComponentProvider.java
---
(0093472)
alostale (developer)
2017-01-13 10:05

reopening: incorrectly marked as fixed due to wrong commit message
(0093634)
hgbot (developer)
2017-01-17 13:39

Repository: erp/backports/3.0PR17Q1
Changeset: 2d974ebf8d1480c1b68b896c4229ccab4c983eef
Author: Asier Lostalé <asier.lostale <at> openbravo.com>
Date: Fri Jan 13 10:03:39 2017 +0100
URL: http://code.openbravo.com/erp/backports/3.0PR17Q1/rev/2d974ebf8d1480c1b68b896c4229ccab4c983eef [^]

Fixed bug 34939: 3.0 selectors cannot be used in classic mode

  When a 3.0 selector was included within classic mode, the JS failed to load.

  The problem was cancelAndReplace.js was included within classic mode JS but it
  depends on resources not available in this mode.

  Because cancel and replace is not designed to work in classic mode, its JS is
  now not included in this mode.

---
M modules/org.openbravo.client.application/src/org/openbravo/client/application/ApplicationComponentProvider.java
---
(0093636)
vmromanos (developer)
2017-01-17 13:45

Code review + testing OK.
Verified Cancel and Replace keeps on working fine.
(0095091)
hudsonbot (developer)
2017-03-15 20:18

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/54e102bef53e [^]
Maturity status: Test

- Issue History
Date Modified Username Field Change
2017-01-13 09:47 alostale Type defect => backport
2017-01-13 09:47 alostale Target Version => 3.0PR17Q1
2017-01-13 09:49 alostale Assigned To alostale => Triage Finance
2017-01-13 09:49 alostale Status scheduled => feedback
2017-01-13 09:49 alostale Status feedback => new
2017-01-13 10:04 hgbot Checkin
2017-01-13 10:04 hgbot Note Added: 0093471
2017-01-13 10:04 hgbot Status new => resolved
2017-01-13 10:04 hgbot Resolution open => fixed
2017-01-13 10:04 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/6398d4e21157f2e64580a955ed56368ea5af1e50 [^]
2017-01-13 10:05 alostale Note Added: 0093472
2017-01-13 10:05 alostale Status resolved => new
2017-01-13 10:05 alostale Resolution fixed => open
2017-01-17 13:33 vmromanos Status new => scheduled
2017-01-17 13:33 vmromanos Assigned To Triage Finance => alostale
2017-01-17 13:39 hgbot Checkin
2017-01-17 13:39 hgbot Note Added: 0093634
2017-01-17 13:39 hgbot Status scheduled => resolved
2017-01-17 13:39 hgbot Resolution open => fixed
2017-01-17 13:39 hgbot Fixed in SCM revision http://code.openbravo.com/erp/devel/pi/rev/6398d4e21157f2e64580a955ed56368ea5af1e50 [^] => http://code.openbravo.com/erp/backports/3.0PR17Q1/rev/2d974ebf8d1480c1b68b896c4229ccab4c983eef [^]
2017-01-17 13:45 vmromanos Note Added: 0093636
2017-01-17 13:45 vmromanos Status resolved => closed
2017-01-17 13:45 vmromanos Fixed in Version => 3.0PR17Q1
2017-03-15 20:18 hudsonbot Checkin
2017-03-15 20:18 hudsonbot Note Added: 0095091


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker