Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0030464
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] A. Platformmajoralways2015-07-30 15:472015-08-20 23:16
ReporterdbazView Statuspublic 
Assigned Tocaristu 
PriorityhighResolutionfixedFixed in Version3.0PR15Q4
StatusclosedFix in branchFixed in SCM revisionc3118a9e5203
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Toalostale
Web browser
ModulesCore
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0030464: Openbravo ERP 3 doesn't work on Microsoft Edge

DescriptionOpenbravo ERP 3 doesn't work on Microsoft Edge (it doesn't pass the 'Loading' screen), and the "Not supported browser" alert is not either shown in the Login window.

https://en.wikipedia.org/wiki/Microsoft_Edge [^]
Steps To ReproduceInstall Windows 10 (you can download a testing VM from here: https://www.modern.ie/es-es/virtualization-tools [^] )
Proposed SolutionStep 1: Ensure the Login window warns the user about using a non-supported browser

Step 2: Do the needed fixes to guaranteee Openbravo 3 ERP runs ok in Microsoft Edge (and revert the changes of 'Step 1').
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
depends on backport 00305313.0PR15Q3 closedcaristu Openbravo ERP Openbravo ERP 3 doesn't work on Microsoft Edge 
depends on backport 00305323.0PR15Q2.4 closedcaristu Openbravo ERP Openbravo ERP 3 doesn't work on Microsoft Edge 
related to defect 0030534 closedcaristu Openbravo ERP Some pop-ups are not displayed properly on Microsoft Edge 
related to defect 0030552 newRetail Retail Modules Microsoft Edge is not detected as not supported by WebPOS 
related to defect 0031254 closedcaristu Openbravo ERP The style of some toolbar buttons looks different in Microsoft Edge 
related to defect 0031286 acknowledgedplatform Openbravo ERP From and To fields in date range filter widget are not displayed properly on Edge 
related to defect 0031391 closedcaristu Openbravo ERP Current combo value is not selected when opening drop down list with mouse in Edge 
related to defect 0031397 acknowledgedplatform Openbravo ERP Direct Print is not working on MS Edge 
related to defect 0031401 acknowledgedplatform Openbravo ERP Upload image pop-up is not properly displayed on MS Edge 
related to defect 0031411 closedcaristu Openbravo ERP Not possible to install a module from the Module Management window in Edge 
related to defect 0031412 acknowledgedplatform Openbravo ERP Combos not aligned in Settings tab of Module Management window using Edge 
related to defect 0031492 closedcaristu Openbravo ERP [MS Edge] In the business partner selector, vendor checkbox not rendered properly 
related to defect 0031491 closedplatform Openbravo ERP [MS Edge] In grid view,(un) select checkbox not properly rendered 
related to defect 0031495 closedplatform Openbravo ERP [MS Edge] Save view icon not rendered properly at organization window 
related to defect 0031494 closedplatform Openbravo ERP [MS Edge]sales order window at lines tab, click to (un)select this record check box not rendered properly 
related to defect 0031490 closedplatform Openbravo ERP [MS Edge] in grid view, sort arrow key not rendered properly 
related to defect 0031489 closedplatform Openbravo ERP [MS EDGE]Funnel icon to clear all filters not rendered properly 
related to defect 0031507 closedplatform Openbravo ERP [MS Edge] At request process popup, Action regarding document dropdown box values are not rendered properly 
related to defect 0031504 closedplatform Openbravo ERP [MS Edge] location selector popup opens in full window 
related to defect 0031766 closedcaristu Openbravo ERP Application unexpectedly closed after opening the location selector in Edge 
related to feature request 0032227 closedcaristu Openbravo ERP Mark MS Edge as supported browser 

-  Notes
(0079276)
hgbot (developer)
2015-08-10 12:56

Repository: erp/mods/org.openbravo.userinterface.smartclient.dev
Changeset: 4c3b97e8cf6075ddd3a5bdc1a01db9d5ba1352f5
Author: Carlos Aristu <carlos.aristu <at> openbravo.com>
Date: Mon Aug 10 12:55:40 2015 +0200
URL: http://code.openbravo.com/erp/mods/org.openbravo.userinterface.smartclient.dev/rev/4c3b97e8cf6075ddd3a5bdc1a01db9d5ba1352f5 [^]

Fixes issue 30464: Openbravo ERP 3 doesn't work on Microsoft Edge

---
M web/org.openbravo.userinterface.smartclient/isomorphic/client/browser/Browser.js
M web/org.openbravo.userinterface.smartclient/isomorphic/client/widgets/TreeGrid.js
M web/org.openbravo.userinterface.smartclient/isomorphic/system/development/ISC_Core.js
M web/org.openbravo.userinterface.smartclient/isomorphic/system/development/ISC_FileLoader.js
M web/org.openbravo.userinterface.smartclient/isomorphic/system/development/ISC_Grids.js
M web/org.openbravo.userinterface.smartclient/isomorphic/system/development/ISC_History.js
M web/org.openbravo.userinterface.smartclient/isomorphic/system/modules-debug/ISC_Core.js
M web/org.openbravo.userinterface.smartclient/isomorphic/system/modules-debug/ISC_Grids.js
M web/org.openbravo.userinterface.smartclient/isomorphic/system/modules-debug/ISC_History.js
M web/org.openbravo.userinterface.smartclient/isomorphic/system/modules/ISC_Core.js
M web/org.openbravo.userinterface.smartclient/isomorphic/system/modules/ISC_Grids.js
M web/org.openbravo.userinterface.smartclient/isomorphic/system/modules/ISC_History.js
---
(0079277)
hgbot (developer)
2015-08-10 13:28

Repository: erp/devel/pi
Changeset: c3118a9e5203275cf57dea1339a001f2fbba065a
Author: Carlos Aristu <carlos.aristu <at> openbravo.com>
Date: Mon Aug 10 13:18:48 2015 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/c3118a9e5203275cf57dea1339a001f2fbba065a [^]

Fixes issue 30464: Openbravo ERP 3 doesn't work on Microsoft Edge


The application was crashing silently during the login process, because Smartclient sources were not identyfing properly the browser. This caused an error in the SC getStackTrace() method. In addition, the OB function getBrowserInfo() has been updated to identify the Microsft Edge browser in order to declare it as not supported for the time being

---
M modules/org.openbravo.userinterface.smartclient/web/org.openbravo.userinterface.smartclient/isomorphic/ISC_Combined.js
M modules/org.openbravo.userinterface.smartclient/web/org.openbravo.userinterface.smartclient/isomorphic/ISC_History.js
M web/js/utils.js
---
(0079297)
hgbot (developer)
2015-08-11 09:18

Repository: erp/devel/pi
Changeset: b8552936f24127c5e7ccd2d87fe50560faa023f9
Author: Carlos Aristu <carlos.aristu <at> openbravo.com>
Date: Tue Aug 11 09:16:33 2015 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/b8552936f24127c5e7ccd2d87fe50560faa023f9 [^]

Related to issue 30464: updated revision control number

---
M src/org/openbravo/erpCommon/security/Login.html
M src/org/openbravo/erpCommon/security/Login_F1.html
M web/js/utils.js
---
(0079300)
alostale (developer)
2015-08-11 09:46

code reviewed

tested with MS Edge:
-Login page: Edge is not officially supported, a popup appears informing about it
-Login can be completed
-Basic flow: create and complete a sales order can be executed
-Logout
(0079537)
hudsonbot (developer)
2015-08-20 23:16

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/8c91718397a5 [^]
Maturity status: Test
(0079539)
hudsonbot (developer)
2015-08-20 23:16

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/8c91718397a5 [^]
Maturity status: Test

- Issue History
Date Modified Username Field Change
2015-07-30 15:47 dbaz New Issue
2015-07-30 15:47 dbaz Assigned To => platform
2015-07-30 15:47 dbaz Modules => Core
2015-07-30 15:47 dbaz Triggers an Emergency Pack => No
2015-07-30 16:09 dbaz Description Updated View Revisions
2015-07-31 09:50 alostale Status new => scheduled
2015-07-31 09:50 alostale Assigned To platform => caristu
2015-08-10 12:44 caristu Status scheduled => acknowledged
2015-08-10 12:44 caristu Status acknowledged => scheduled
2015-08-10 12:56 hgbot Checkin
2015-08-10 12:56 hgbot Note Added: 0079276
2015-08-10 12:56 hgbot Status scheduled => resolved
2015-08-10 12:56 hgbot Resolution open => fixed
2015-08-10 12:56 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/mods/org.openbravo.userinterface.smartclient.dev/rev/4c3b97e8cf6075ddd3a5bdc1a01db9d5ba1352f5 [^]
2015-08-10 13:28 hgbot Checkin
2015-08-10 13:28 hgbot Note Added: 0079277
2015-08-10 13:28 hgbot Fixed in SCM revision http://code.openbravo.com/erp/mods/org.openbravo.userinterface.smartclient.dev/rev/4c3b97e8cf6075ddd3a5bdc1a01db9d5ba1352f5 [^] => http://code.openbravo.com/erp/devel/pi/rev/c3118a9e5203275cf57dea1339a001f2fbba065a [^]
2015-08-10 13:44 caristu Relationship added related to 0030534
2015-08-11 09:18 hgbot Checkin
2015-08-11 09:18 hgbot Note Added: 0079297
2015-08-11 09:46 alostale Review Assigned To => alostale
2015-08-11 09:46 alostale Note Added: 0079300
2015-08-11 09:46 alostale Status resolved => closed
2015-08-11 09:46 alostale Fixed in Version => 3.0PR15Q4
2015-08-11 14:49 alostale Relationship added related to 0030552
2015-08-20 23:16 hudsonbot Checkin
2015-08-20 23:16 hudsonbot Note Added: 0079537
2015-08-20 23:16 hudsonbot Checkin
2015-08-20 23:16 hudsonbot Note Added: 0079539
2015-10-26 19:12 caristu Relationship added related to 0031254
2015-10-29 08:47 caristu Relationship added related to 0031286
2015-11-06 12:27 alostale Relationship added related to 0031391
2015-11-06 15:18 caristu Relationship added related to 0031397
2015-11-09 09:03 caristu Relationship added related to 0031401
2015-11-10 09:11 caristu Relationship added related to 0031411
2015-11-10 09:20 caristu Relationship added related to 0031412
2015-11-16 12:05 alostale Relationship added related to 0031492
2015-11-16 12:06 alostale Relationship added related to 0031491
2015-11-16 14:26 alostale Relationship added related to 0031495
2015-11-16 14:26 alostale Relationship added related to 0031494
2015-11-16 14:26 alostale Relationship added related to 0031490
2015-11-16 14:26 alostale Relationship added related to 0031489
2015-11-16 15:56 alostale Relationship added related to 0031507
2015-11-16 15:57 alostale Relationship added related to 0031504
2015-12-22 19:31 caristu Relationship added related to 0031766
2016-02-12 15:31 caristu Relationship added related to 0032227


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker