Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0030531
TypeCategorySeverityReproducibilityDate SubmittedLast Update
backport[Openbravo ERP] A. Platformmajoralways2015-07-30 15:472015-08-11 09:46
ReporterdbazView Statuspublic 
Assigned Tocaristu 
PriorityhighResolutionfixedFixed in Version3.0PR15Q3
StatusclosedFix in branchFixed in SCM revisionb28798b52483
ProjectionnoneETAnoneTarget Version3.0PR15Q3
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Toalostale
Web browser
ModulesCore
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0030531: Openbravo ERP 3 doesn't work on Microsoft Edge

DescriptionOpenbravo ERP 3 doesn't work on Microsoft Edge (it doesn't pass the 'Loading' screen), and the "Not supported browser" alert is not either shown in the Login window.

https://en.wikipedia.org/wiki/Microsoft_Edge [^]
Steps To ReproduceInstall Windows 10 (you can download a testing VM from here: https://www.modern.ie/es-es/virtualization-tools [^] )
Proposed SolutionStep 1: Ensure the Login window warns the user about using a non-supported browser

Step 2: Do the needed fixes to guaranteee Openbravo 3 ERP runs ok in Microsoft Edge (and revert the changes of 'Step 1').
TagsApproved
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
blocks defect 0030464 closedcaristu Openbravo ERP 3 doesn't work on Microsoft Edge 

-  Notes
(0079283)
hgbot (developer)
2015-08-10 14:27

Repository: erp/backports/3.0PR15Q3
Changeset: b28798b5248318493e91b0e33dbb477261cdc89e
Author: Carlos Aristu <carlos.aristu <at> openbravo.com>
Date: Mon Aug 10 14:26:44 2015 +0200
URL: http://code.openbravo.com/erp/backports/3.0PR15Q3/rev/b28798b5248318493e91b0e33dbb477261cdc89e [^]

Fixes issue 30531: Openbravo ERP 3 doesn't work on Microsoft Edge

The application was crashing silently during the login process, because Smartclient sources were not identyfing properly the browser. This caused an error in the SC getStackTrace() method. In addition, the OB function getBrowserInfo() has been updated to identify the Microsft Edge browser in order to declare it as not supported for the time being

---
M modules/org.openbravo.userinterface.smartclient/web/org.openbravo.userinterface.smartclient/isomorphic/ISC_Combined.js
M modules/org.openbravo.userinterface.smartclient/web/org.openbravo.userinterface.smartclient/isomorphic/ISC_History.js
M web/js/utils.js
---
(0079298)
hgbot (developer)
2015-08-11 09:24

Repository: erp/backports/3.0PR15Q3
Changeset: c13047cce241612f9f0e599b2421a9bc8f878cff
Author: Carlos Aristu <carlos.aristu <at> openbravo.com>
Date: Tue Aug 11 09:23:51 2015 +0200
URL: http://code.openbravo.com/erp/backports/3.0PR15Q3/rev/c13047cce241612f9f0e599b2421a9bc8f878cff [^]

Related to issue 30531: updated revision control number

---
M src/org/openbravo/erpCommon/security/Login.html
M src/org/openbravo/erpCommon/security/Login_F1.html
M web/js/utils.js
---
(0079301)
alostale (developer)
2015-08-11 09:46

code reviewed

tested with MS Edge:
-Login page: Edge is not officially supported, a popup appears informing about it
-Login can be completed
-Basic flow: create and complete a sales order can be executed
-Logout

- Issue History
Date Modified Username Field Change
2015-08-10 12:44 caristu Type defect => backport
2015-08-10 12:44 caristu Target Version => 3.0PR15Q3
2015-08-10 14:17 alostale Tag Attached: Approved
2015-08-10 14:27 hgbot Checkin
2015-08-10 14:27 hgbot Note Added: 0079283
2015-08-10 14:27 hgbot Status scheduled => resolved
2015-08-10 14:27 hgbot Resolution open => fixed
2015-08-10 14:27 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/backports/3.0PR15Q3/rev/b28798b5248318493e91b0e33dbb477261cdc89e [^]
2015-08-11 09:24 hgbot Checkin
2015-08-11 09:24 hgbot Note Added: 0079298
2015-08-11 09:46 alostale Review Assigned To => alostale
2015-08-11 09:46 alostale Note Added: 0079301
2015-08-11 09:46 alostale Status resolved => closed
2015-08-11 09:46 alostale Fixed in Version => 3.0PR15Q3


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker