Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0031766
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] A. Platformmajoralways2015-12-22 19:312016-03-17 10:56
ReportercaristuView Statuspublic 
Assigned Tocaristu 
PrioritynormalResolutionfixedFixed in Version3.0PR16Q2
StatusclosedFix in branchFixed in SCM revision4ad163e229c5
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Toalostale
Web browser
ModulesCore
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0031766: Application unexpectedly closed after opening the location selector in Edge

DescriptionThe application is unexpectedly closed after opening the location selector in Edge
Steps To Reproduce1) Using MS Edge browser, go to the [Business Partner] window
2) Select any record in the header and move to the Location tab
3) Create a new record
4) Click on the magnifying glass of the Location selector. The application is unexpectedly closed
Proposed SolutionMS Edge currently has a weird behavior regarding window.open command and also it seems that window.focus is not working properly neither.

In any case opening the selector window outside of the application seems to work fine.
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
related to defect 0030464 closedcaristu Openbravo ERP 3 doesn't work on Microsoft Edge 
related to defect 0031504 closedplatform [MS Edge] location selector popup opens in full window 

-  Notes
(0083965)
hgbot (developer)
2016-02-05 13:15

Repository: erp/devel/pi
Changeset: 4ad163e229c542743a7a73bd2b3395458c5d71a2
Author: Carlos Aristu <carlos.aristu <at> openbravo.com>
Date: Fri Feb 05 13:14:11 2016 +0100
URL: http://code.openbravo.com/erp/devel/pi/rev/4ad163e229c542743a7a73bd2b3395458c5d71a2 [^]

fixes issue 31766: Application unexpectedly closed using some selectors in Edge

Now selectors based on OBSearchItem class are opened inside an Smartclient pop-up instead of using a new browser window.

---
M modules/org.openbravo.client.application/web/org.openbravo.client.application/js/form/formitem/ob-formitem-search.js
M modules/org.openbravo.client.application/web/org.openbravo.client.application/js/utilities/ob-utilities.js
M src/org/openbravo/erpCommon/info/Account.html
M src/org/openbravo/erpCommon/info/Account.java
M src/org/openbravo/erpCommon/info/AccountElementValue.html
M src/org/openbravo/erpCommon/info/AccountElementValue.java
M src/org/openbravo/erpCommon/info/AttributeSetInstance.html
M src/org/openbravo/erpCommon/info/BusinessPartner.html
M src/org/openbravo/erpCommon/info/BusinessPartner.java
M src/org/openbravo/erpCommon/info/DebtPayment.html
M src/org/openbravo/erpCommon/info/ImageInfo.html
M src/org/openbravo/erpCommon/info/ImageInfoBLOB.html
M src/org/openbravo/erpCommon/info/Invoice.html
M src/org/openbravo/erpCommon/info/Invoice.java
M src/org/openbravo/erpCommon/info/InvoiceLine.html
M src/org/openbravo/erpCommon/info/InvoiceLine.java
M src/org/openbravo/erpCommon/info/Location.java
M src/org/openbravo/erpCommon/info/Location_F1.html
M src/org/openbravo/erpCommon/info/Location_FS.html
M src/org/openbravo/erpCommon/info/Locator.html
M src/org/openbravo/erpCommon/info/Locator.java
M src/org/openbravo/erpCommon/info/Product.html
M src/org/openbravo/erpCommon/info/Product.java
M src/org/openbravo/erpCommon/info/ProductComplete.html
M src/org/openbravo/erpCommon/info/ProductComplete.java
M src/org/openbravo/erpCommon/info/Project.html
M src/org/openbravo/erpCommon/info/Project.java
M src/org/openbravo/erpCommon/info/SalesOrder.html
M src/org/openbravo/erpCommon/info/SalesOrder.java
M src/org/openbravo/erpCommon/info/SalesOrderLine.html
M src/org/openbravo/erpCommon/info/SalesOrderLine.java
M src/org/openbravo/erpCommon/info/SearchUniqueKeyResponse.html
M src/org/openbravo/erpCommon/info/ShipmentReceipt.html
M src/org/openbravo/erpCommon/info/ShipmentReceipt.java
M src/org/openbravo/erpCommon/info/ShipmentReceiptLine.html
M src/org/openbravo/erpCommon/info/ShipmentReceiptLine.java
---
(0084135)
alostale (developer)
2016-02-12 08:15

Reopened:

Before this change, title for Location Selector popup was "Location selector", now it is "New address entrance". Which is not correct because:
-Entrance has no sense in this context
-It is not necessarily new, it can be used to edit an existent location

Note Location selector is a frameset, title is taken from Location_F1.html.
(0084139)
hgbot (developer)
2016-02-12 09:02

Repository: erp/devel/pi
Changeset: 5f2dad834745f99fe2dd25392d890e9d16a3fd69
Author: Carlos Aristu <carlos.aristu <at> openbravo.com>
Date: Fri Feb 12 09:01:15 2016 +0100
URL: http://code.openbravo.com/erp/devel/pi/rev/5f2dad834745f99fe2dd25392d890e9d16a3fd69 [^]

related to issue 31766: put correct location selector title

---
M src-db/database/sourcedata/AD_TEXTINTERFACES.xml
M src/org/openbravo/erpCommon/info/Location_F1.html
---
(0084159)
alostale (developer)
2016-02-12 14:48

code reviewed

tested in chrome + edge
(0085108)
hudsonbot (developer)
2016-03-17 10:56

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/b22fb0500156 [^]
Maturity status: Test
(0085131)
hudsonbot (developer)
2016-03-17 10:56

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/b22fb0500156 [^]
Maturity status: Test

- Issue History
Date Modified Username Field Change
2015-12-22 19:31 caristu New Issue
2015-12-22 19:31 caristu Assigned To => platform
2015-12-22 19:31 caristu Modules => Core
2015-12-22 19:31 caristu Triggers an Emergency Pack => No
2015-12-22 19:31 caristu Relationship added related to 0030464
2015-12-22 19:31 caristu Proposed Solution updated
2015-12-22 19:31 caristu Proposed Solution updated
2015-12-22 19:32 caristu Relationship added related to 0031504
2015-12-23 10:14 alostale Status new => acknowledged
2015-12-23 13:02 caristu Assigned To platform => caristu
2015-12-23 13:02 caristu Status acknowledged => scheduled
2016-02-05 13:15 hgbot Checkin
2016-02-05 13:15 hgbot Note Added: 0083965
2016-02-05 13:15 hgbot Status scheduled => resolved
2016-02-05 13:15 hgbot Resolution open => fixed
2016-02-05 13:15 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/4ad163e229c542743a7a73bd2b3395458c5d71a2 [^]
2016-02-12 08:15 alostale Note Added: 0084135
2016-02-12 08:15 alostale Status resolved => new
2016-02-12 08:15 alostale Resolution fixed => open
2016-02-12 09:02 hgbot Checkin
2016-02-12 09:02 hgbot Note Added: 0084139
2016-02-12 09:02 caristu Review Assigned To => alostale
2016-02-12 09:02 caristu Status new => scheduled
2016-02-12 09:02 caristu Status scheduled => resolved
2016-02-12 09:02 caristu Resolution open => fixed
2016-02-12 09:03 caristu Issue Monitored: alostale
2016-02-12 14:48 alostale Note Added: 0084159
2016-02-12 14:48 alostale Status resolved => closed
2016-02-12 14:48 alostale Fixed in Version => 3.0PR16Q2
2016-03-17 10:56 hudsonbot Checkin
2016-03-17 10:56 hudsonbot Note Added: 0085108
2016-03-17 10:56 hudsonbot Checkin
2016-03-17 10:56 hudsonbot Note Added: 0085131


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker