Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0031411
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] A. Platformmajoralways2015-11-10 09:102015-11-23 21:17
ReportercaristuView Statuspublic 
Assigned Tocaristu 
PrioritynormalResolutionfixedFixed in Version3.0PR16Q1
StatusclosedFix in branchFixed in SCM revisiona8ad0086de56
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Toalostale
Web browser
ModulesCore
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0031411: Not possible to install a module from the Module Management window in Edge

DescriptionIs not possible to install a module from the file system in Edge. After clicking on the "Install Now" or "Browse File System" button, the pop-up to upload the file is showing the loading window forever (see attached image).
Steps To Reproduce1) Log in using Edge
2) Switch to the System Admin role
3) Navigate to the [Module Management] window, "Add Modules" tab.
4) Look for a module and click on its "Install Now" button. Notice that the loading pop-up appears forever.
5) The same happens when clicking on the "Browse File System" button.
TagsNo tags attached.
Attached Filespng file icon loadingmod.png [^] (10,684 bytes) 2015-11-10 09:10

- Relationships Relation Graph ] Dependency Graph ]
related to defect 0030464 closedcaristu Openbravo ERP 3 doesn't work on Microsoft Edge 
related to defect 0031528 closedcaristu Can't install modules using Internet explorer 11 

-  Notes
(0081670)
hgbot (developer)
2015-11-10 17:24

Repository: erp/devel/pi
Changeset: a8ad0086de560ce29708e5bf195cd4f9b80d23d6
Author: Carlos Aristu <carlos.aristu <at> openbravo.com>
Date: Tue Nov 10 17:21:18 2015 +0100
URL: http://code.openbravo.com/erp/devel/pi/rev/a8ad0086de560ce29708e5bf195cd4f9b80d23d6 [^]

fixes issue 31411: Not possible to install modules in Module Mgmt using Edge

The problem is that on MS Edge browser, the window.opener was lost. Now it is recovered in the same way as it was done for IE9. This avoids the javascript error that was being fired when trying to hide the loading screen in that browser.

Together with this the cache revision number has been updated in the required files.

---
M modules/org.openbravo.client.application/web/org.openbravo.client.application/js/classic/ob-classic-compatibility.js
M modules/org.openbravo.client.application/web/org.openbravo.client.application/js/utilities/ob-utilities.js
M src/org/openbravo/erpCommon/security/Login.html
M src/org/openbravo/erpCommon/security/Login_F1.html
M src/org/openbravo/erpCommon/utility/PopupLoading.html
M web/js/utils.js
---
(0081890)
alostale (developer)
2015-11-16 15:17

code reviewed + tested
(0082196)
hudsonbot (developer)
2015-11-23 21:17

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/7b56bebaaa88 [^]
Maturity status: Test

- Issue History
Date Modified Username Field Change
2015-11-10 09:10 caristu New Issue
2015-11-10 09:10 caristu Assigned To => platform
2015-11-10 09:10 caristu File Added: loadingmod.png
2015-11-10 09:10 caristu Modules => Core
2015-11-10 09:10 caristu Triggers an Emergency Pack => No
2015-11-10 09:11 caristu Relationship added related to 0030464
2015-11-10 09:28 caristu Severity minor => major
2015-11-10 09:28 caristu Summary Not possible to install a module from the file system in Edge => Not possible to install a module from the Module Management window in Edge
2015-11-10 09:28 caristu Description Updated View Revisions
2015-11-10 09:28 caristu Steps to Reproduce Updated View Revisions
2015-11-10 14:13 alostale Status new => acknowledged
2015-11-10 17:24 hgbot Checkin
2015-11-10 17:24 hgbot Note Added: 0081670
2015-11-10 17:24 hgbot Status acknowledged => resolved
2015-11-10 17:24 hgbot Resolution open => fixed
2015-11-10 17:24 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/a8ad0086de560ce29708e5bf195cd4f9b80d23d6 [^]
2015-11-10 17:25 caristu Review Assigned To => alostale
2015-11-10 17:25 caristu Issue Monitored: alostale
2015-11-16 14:28 alostale Assigned To platform => caristu
2015-11-16 15:17 alostale Note Added: 0081890
2015-11-16 15:17 alostale Status resolved => closed
2015-11-16 15:17 alostale Fixed in Version => 3.0PR16Q1
2015-11-19 10:29 caristu Relationship added related to 0031528
2015-11-23 21:17 hudsonbot Checkin
2015-11-23 21:17 hudsonbot Note Added: 0082196


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker