Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0031528
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] A. Platformmajoralways2015-11-18 22:432015-11-25 15:11
ReporterrbianchiniView Statuspublic 
Assigned Tocaristu 
PriorityhighResolutionfixedFixed in Version3.0PR16Q1
StatusclosedFix in branchFixed in SCM revision4e2d5ee66c49
ProjectionnoneETAnoneTarget Version
OSWindowsDatabasePostgreSQLJava version
OS Version8Database versionAnt version
Product Version3.0PR15Q3.3SCM revision 
Review Assigned Todbaz
Web browserInternet Explorer
ModulesCore
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0031528: Can't install modules using Internet explorer 11

DescriptionIf you need to install a module within the application accessed via IE11, the first pop up never loads the information
Tested in 3.0PR15Q1.3 and 3.0PR15Q3.3
Steps To Reproduce1- run Internet Explorer 11
2- go to livebuilds.openbravo.com
3- log in ERP 15Q3.3
4- switch role to system admin
5- go to module management window
6- go to add modules tab
7- click on install button of any module (example: Abonnement tiers)
8- observes the popup never finish to load (see the image attached)
TagsNo tags attached.
Attached Filespng file icon loading.png [^] (114,372 bytes) 2015-11-18 22:43

- Relationships Relation Graph ] Dependency Graph ]
related to defect 0031411 closedcaristu Not possible to install a module from the Module Management window in Edge 

-  Notes
(0081973)
caristu (developer)
2015-11-19 10:52

Note: the way to detect IE11 is slightly different different due to the name retrieved by the navigator.userAgent info: https://www.nczonline.net/blog/2013/07/02/internet-explorer-11-dont-call-me-ie/ [^]
(0081993)
hgbot (developer)
2015-11-19 16:17

Repository: erp/devel/pi
Changeset: 4e2d5ee66c49463d77c85301c69e921883d1a3cf
Author: Carlos Aristu <carlos.aristu <at> openbravo.com>
Date: Thu Nov 19 16:15:39 2015 +0100
URL: http://code.openbravo.com/erp/devel/pi/rev/4e2d5ee66c49463d77c85301c69e921883d1a3cf [^]

fixes issue 31528: Can't install modules using Internet Explorer 11

The problem is that on IE 11 browser, the window.opener was lost. Now it is recovered in the same way as it was done for IE9 and Edge. This avoids the javascript error that was being fired when trying to hide the loading screen in that browser.

Together with this the cache revision number has been updated in the required files.

---
M modules/org.openbravo.client.application/web/org.openbravo.client.application/js/classic/ob-classic-compatibility.js
M modules/org.openbravo.client.application/web/org.openbravo.client.application/js/utilities/ob-utilities.js
M src/org/openbravo/erpCommon/security/Login.html
M src/org/openbravo/erpCommon/security/Login_F1.html
M src/org/openbravo/erpCommon/utility/PopupLoading.html
M web/js/utils.js
---
(0082257)
hudsonbot (developer)
2015-11-23 21:17

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/7b56bebaaa88 [^]
Maturity status: Test
(0082287)
hgbot (developer)
2015-11-24 12:43

Repository: erp/devel/pi
Changeset: 9bd74e8a00d328f4af989e10fb1fa5e4736f857f
Author: Carlos Aristu <carlos.aristu <at> openbravo.com>
Date: Tue Nov 24 12:41:26 2015 +0100
URL: http://code.openbravo.com/erp/devel/pi/rev/9bd74e8a00d328f4af989e10fb1fa5e4736f857f [^]

related to issue 31528: code review improvements, use isIE9Strict for IE11 also

---
M modules/org.openbravo.client.application/web/org.openbravo.client.application/js/classic/ob-classic-compatibility.js
M modules/org.openbravo.client.application/web/org.openbravo.client.application/js/utilities/ob-utilities.js
M src/org/openbravo/erpCommon/security/Login.html
M src/org/openbravo/erpCommon/security/Login_F1.html
M src/org/openbravo/erpCommon/utility/PopupLoading.html
M web/js/utils.js
---
(0082288)
dbaz (developer)
2015-11-24 12:50

Reviewed @ changeset: 28036 - 9bd74e8a00d3
(0082327)
hudsonbot (developer)
2015-11-25 15:11

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/1c9b33d2091d [^]
Maturity status: Test

- Issue History
Date Modified Username Field Change
2015-11-18 22:43 rbianchini New Issue
2015-11-18 22:43 rbianchini Assigned To => Triage Finance
2015-11-18 22:43 rbianchini File Added: loading.png
2015-11-18 22:43 rbianchini Web browser => Internet Explorer
2015-11-18 22:43 rbianchini Modules => Core
2015-11-18 22:43 rbianchini Triggers an Emergency Pack => No
2015-11-19 10:29 caristu Assigned To Triage Finance => caristu
2015-11-19 10:29 caristu Relationship added related to 0031411
2015-11-19 10:52 caristu Note Added: 0081973
2015-11-19 12:05 caristu Web browser Internet Explorer => Internet Explorer
2015-11-19 12:05 caristu Category 01. General setup => A. Platform
2015-11-19 16:17 hgbot Checkin
2015-11-19 16:17 hgbot Note Added: 0081993
2015-11-19 16:17 hgbot Status new => resolved
2015-11-19 16:17 hgbot Resolution open => fixed
2015-11-19 16:17 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/4e2d5ee66c49463d77c85301c69e921883d1a3cf [^]
2015-11-19 16:18 caristu Issue Monitored: alostale
2015-11-19 16:18 caristu Review Assigned To => alostale
2015-11-19 16:18 caristu Web browser Internet Explorer => Internet Explorer
2015-11-19 18:44 alostale Review Assigned To alostale => dbaz
2015-11-19 18:44 alostale Web browser Internet Explorer => Internet Explorer
2015-11-19 18:44 alostale Issue Monitored: dbaz
2015-11-23 21:17 hudsonbot Checkin
2015-11-23 21:17 hudsonbot Note Added: 0082257
2015-11-24 12:43 hgbot Checkin
2015-11-24 12:43 hgbot Note Added: 0082287
2015-11-24 12:50 dbaz Note Added: 0082288
2015-11-24 12:50 dbaz Status resolved => closed
2015-11-24 12:50 dbaz Fixed in Version => 3.0PR16Q1
2015-11-25 15:11 hudsonbot Checkin
2015-11-25 15:11 hudsonbot Note Added: 0082327


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker