Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0030082
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] Z. Othersmajoralways2015-06-03 13:452016-02-02 09:35
Reporterjorge-garciaView Statuspublic 
Assigned Tojorge-garcia 
PriorityurgentResolutionfixedFixed in Version
StatusclosedFix in branchFixed in SCM revision99cc73c54bf0
ProjectionnoneETAnoneTarget Version3.0PR15Q3
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Tovmromanos
Web browser
ModulesAdvanced Payables and Receivables Mngmt
Regression levelProduction - Confirmed Stable
Regression date2014-07-18
Regression introduced in release3.0PR14Q3
Regression introduced by commithttps://code.openbravo.com/erp/devel/pi/diff/87765308f9bd/modules/org.openbravo.advpaymentmngt/src-db/database/model/functions/APRM_GEN_PAYMENTSCHEDULE_INV.xml [^]
Triggers an Emergency PackNo
Summary

0030082: Payment plan is updating wrong in some circunstancies

DescriptionPayment plan is updating wrong if Payment Method is set as Automatic Receipt and a sales order is partially paid.
Steps To ReproduceAs group admin role:
   Create a new Payment Method and set Automatic Receipt = 'Y'
   Add it to a financial account.
   Create a Sales Order, set the previously created payment method and Invoice Terms = Immediate.
   Click on Add Payment an create a partial payment for the Sales Order.
   Create a Sales Invoice from it and complete it
   Check the Received field of the Payment Plan of the invoice has been updated with the sum of the full payment and the partial payment of the order and the Outstanding amount is wrong as well.
  Check the payment details of the payment plan from both (order and invoice) are created correctly
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
depends on backport 00301213.0PR15Q2.2 closedjorge-garcia Payment plan is updating wrong in some circunstancies 
depends on backport 00301223.0PR15Q1.5 closedjorge-garcia Payment plan is updating wrong in some circunstancies 
caused by feature request 0025696 closedSandrahuguet Add invoice paid status control funcionality 
related to defect 00299723.0PR15Q3 closedjorge-garcia Outstanding amount of sales order payment plan is not updated when payment method is set as automatic receipt 
related to defect 0033500 closedAtulOpenbravo Wrong payment schedule details when return to vendor document is invoiced using credit a memo invoice 
blocks defect 0030007 closedaferraz Payment schedule amount incorrectly calculated when adding a payment from reconcile window to a sales order 
blocks defect 00301703.0PR15Q3 closedaferraz Generic UpdatePaymentPlan module script 

-  Notes
(0078060)
jorge-garcia (developer)
2015-06-04 12:53
edited on: 2015-06-04 12:53

Test Plan:

**Try this fix with the fix of the issue 29972 applied as well**

As group admin role:
 Create a new Payment Method and set Automatic Receipt = 'Y'
   Add it to a financial account.

 1) Test 1:
   Create a Sales Order, set the previously created payment method and Invoice Terms = Immediate.
   Click on Add Payment an create a partial payment for the Sales Order.
   Create a Sales Invoice from it and complete it
   Check the Received field and Outstanding field of the Payment Plan of the invoice has been updated correctly.
   Check the Received field and Outstanding field of the Payment Plan of the order has been updated correctly.
 
 2) Test 2:
   Create a Sales Order, set the previously created payment method and Invoice Terms = Immediate.
   Click on Add Payment an create a full payment for the Sales Order.
   Create a Sales Invoice from it and complete it
   Check the Received field and Outstanding field of the Payment Plan of the invoice has been updated correctly.
   Check the Received field and Outstanding field of the Payment Plan of the order has been updated correctly.

 3) Test 3:
   Create a Sales Order, set the previously created payment method and Invoice Terms = Immediate.
   Create a Sales Invoice from it and complete it
   Check the Received field and Outstanding field of the Payment Plan of the invoice has been updated correctly.
   Check the Received field and Outstanding field of the Payment Plan of the order has been updated correctly.

(0078244)
hgbot (developer)
2015-06-12 13:46

Repository: erp/devel/pi
Changeset: 99cc73c54bf0ac353efa16f2a8e47c815300df0e
Author: Jorge Garcia <jorge.garcia <at> openbravo.com>
Date: Wed Jun 10 13:09:56 2015 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/99cc73c54bf0ac353efa16f2a8e47c815300df0e [^]

Fixed issue 30082: Payment plan is updating wrong in some circumstances

Payment plan is updating wrong if Payment Method is set as Automatic Receipt
and a sales order is partially paid.

The problem was that the function duplicates the value of the received amount
created in the Complete process of the invoice, because the function searches
all the payment details of the payment plan that has an invoice paid
(invoicepaid column).

The solution is to search those payment details that are not pre-paid and then
update the payment plan.

Now, the values are filled correctly.

---
M modules/org.openbravo.advpaymentmngt/src-db/database/model/functions/APRM_GEN_PAYMENTSCHEDULE_INV.xml
---
(0078246)
hgbot (developer)
2015-06-12 13:46

Repository: erp/devel/pi
Changeset: ab5e144258614a33ed239fd3989894f752fb175e
Author: Víctor Martínez Romanos <victor.martinez <at> openbravo.com>
Date: Fri Jun 12 12:49:18 2015 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/ab5e144258614a33ed239fd3989894f752fb175e [^]

Related to issue 30082: code review improvements

The invoice's payment schedules and payment monitor is only updated when all the payment schedule details are paid.

This changeset covers the scenario where an order is partially paid. Before this change, the invoice's payment schedules and payment monitor were wrongly updated considering that the payment schedule was fully paid when any of its payment schedule details was paid. That asumption may be wrong in some scenarios, for example when the order is associated to one or more payment schedule details not yet paid (isinvoicepaid=N) and at least one already paid.

---
M modules/org.openbravo.advpaymentmngt/src-db/database/model/functions/APRM_GEN_PAYMENTSCHEDULE_INV.xml
---
(0078249)
vmromanos (developer)
2015-06-12 13:53

Code review + testing OK
(0078269)
hudsonbot (developer)
2015-06-14 19:58

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/1cf5ab8b5006 [^]
Maturity status: Test
(0078270)
hudsonbot (developer)
2015-06-14 19:58

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/1cf5ab8b5006 [^]
Maturity status: Test
(0083807)
hgbot (developer)
2016-02-02 09:35

Repository: tools/automation/int
Changeset: e7a1aa2cb768823f44b1948ffc91a2a63ec3aadc
Author: Alvaro Ferraz <alvaro.ferraz <at> openbravo.com>
Date: Fri Sep 25 09:39:00 2015 +0200
URL: http://code.openbravo.com/tools/automation/int/rev/e7a1aa2cb768823f44b1948ffc91a2a63ec3aadc [^]

Related to issue 30082: Added some automated tests

---
M src-test/com/openbravo/test/integration/erp/gui/procurement/transactions/purchaseorder/PurchaseOrderHeaderTab.java
M src-test/com/openbravo/test/integration/erp/modules/client/application/gui/GeneratedTab.java
M src-test/com/openbravo/test/integration/erp/modules/client/application/gui/OBStandardView.java
M src-test/com/openbravo/test/integration/erp/modules/functionalteam/addpayment/testsuites/APR_Regressions/RegressionSuite.java
M src-test/com/openbravo/test/integration/erp/modules/functionalteam/addpayment/testsuites/APR_Regressions/build.xml
M src-test/com/openbravo/test/integration/erp/testscripts/procurement/transactions/PurchaseOrder.java
A src-test/com/openbravo/test/integration/erp/modules/functionalteam/addpayment/testsuites/APR_Regressions/APRRegression021.java
A src-test/com/openbravo/test/integration/erp/modules/functionalteam/addpayment/testsuites/APR_Regressions/APRRegression022.java
---

- Issue History
Date Modified Username Field Change
2015-06-03 13:45 jorge-garcia New Issue
2015-06-03 13:45 jorge-garcia Assigned To => Triage Finance
2015-06-03 13:45 jorge-garcia Modules => Advanced Payables and Receivables Mngmt
2015-06-03 13:45 jorge-garcia Triggers an Emergency Pack => No
2015-06-03 16:36 jorge-garcia Relationship added related to 0029972
2015-06-04 12:53 jorge-garcia Note Added: 0078060
2015-06-04 12:53 jorge-garcia Note Edited: 0078060 View Revisions
2015-06-04 12:54 jorge-garcia Assigned To Triage Finance => jorge-garcia
2015-06-04 12:54 jorge-garcia Status new => acknowledged
2015-06-08 10:56 jorge-garcia Regression level => Production - Confirmed Stable
2015-06-08 10:56 jorge-garcia Regression date => 2014-07-18
2015-06-08 10:56 jorge-garcia Regression introduced in release => 3.0PR14Q3
2015-06-08 10:56 jorge-garcia Regression introduced by commit => https://code.openbravo.com/erp/devel/pi/rev/77b6251af841 [^]
2015-06-08 11:00 jorge-garcia Status acknowledged => scheduled
2015-06-08 11:01 jorge-garcia Target Version => 3.0PR15Q3
2015-06-09 17:51 jorge-garcia Regression introduced by commit https://code.openbravo.com/erp/devel/pi/rev/77b6251af841 [^] => https://code.openbravo.com/erp/devel/pi/diff/87765308f9bd/modules/org.openbravo.advpaymentmngt/src-db/database/model/functions/APRM_GEN_PAYMENTSCHEDULE_INV.xml [^]
2015-06-11 16:39 vmromanos Relationship added caused by 0025696
2015-06-12 13:46 hgbot Checkin
2015-06-12 13:46 hgbot Note Added: 0078244
2015-06-12 13:46 hgbot Status scheduled => resolved
2015-06-12 13:46 hgbot Resolution open => fixed
2015-06-12 13:46 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/99cc73c54bf0ac353efa16f2a8e47c815300df0e [^]
2015-06-12 13:46 hgbot Checkin
2015-06-12 13:46 hgbot Note Added: 0078246
2015-06-12 13:53 vmromanos Review Assigned To => vmromanos
2015-06-12 13:53 vmromanos Note Added: 0078249
2015-06-12 13:53 vmromanos Status resolved => closed
2015-06-14 19:58 hudsonbot Checkin
2015-06-14 19:58 hudsonbot Note Added: 0078269
2015-06-14 19:58 hudsonbot Checkin
2015-06-14 19:58 hudsonbot Note Added: 0078270
2015-06-22 11:58 vmromanos Relationship added blocks 0030007
2015-06-22 11:58 vmromanos Relationship added blocks 0030170
2016-02-02 09:35 hgbot Checkin
2016-02-02 09:35 hgbot Note Added: 0083807
2016-08-10 14:23 aferraz Relationship added related to 0033500


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker