Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0029972
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] Z. Othersmajoralways2015-05-22 09:562016-02-02 09:34
ReporterngarciaView Statuspublic 
Assigned Tojorge-garcia 
PriorityurgentResolutionfixedFixed in Version
StatusclosedFix in branchFixed in SCM revision209da9cda816
ProjectionnoneETAnoneTarget Version3.0PR15Q3
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Tovmromanos
Web browser
ModulesAdvanced Payables and Receivables Mngmt
Regression levelProduction - Confirmed Stable
Regression date2014-02-11
Regression introduced in release3.0PR14Q2
Regression introduced by commithttps://code.openbravo.com/erp/devel/pi/rev/87765308f9bd4cdc21b7b53b437f1ed014f5a483 [^]
Triggers an Emergency PackNo
Summary

0029972: Outstanding amount of sales order payment plan is not updated when payment method is set as automatic receipt

DescriptionOutstanding amount of sales order payment plan is not updated when payment method is set as automatic receipt
Steps To ReproduceAs group admin role:
   Create a new Payment Method and set Automatic Receipt = 'Y'
   Add it to a financial account
   Create a Sales Order, set the previously created payment method and Invoice Terms = Immediate
   Create a Sales Invoice from it and complete it
   Check the Received field of the Payment Plan of the order has been updated but the Outstanding amount has not been updated
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
related to defect 00300823.0PR15Q3 closedjorge-garcia Payment plan is updating wrong in some circunstancies 
depends on backport 00301153.0PR15Q2.2 closedjorge-garcia Outstanding amount of sales order payment plan is not updated when payment method is set as automatic receipt 
depends on backport 00301163.0PR15Q1.5 closedjorge-garcia Outstanding amount of sales order payment plan is not updated when payment method is set as automatic receipt 
caused by feature request 0025696 closedSandrahuguet Add invoice paid status control funcionality 
related to defect 00301703.0PR15Q3 closedaferraz Generic UpdatePaymentPlan module script 
related to defect 0033500 closedAtulOpenbravo Wrong payment schedule details when return to vendor document is invoiced using credit a memo invoice 

-  Notes
(0077884)
jorge-garcia (developer)
2015-05-29 10:23

Test Plan:

As group admin role:
   Create a new Payment Method and set Automatic Receipt = 'Y'
   Add it to a financial account

Test 1:
   Create a Sales Order, set the previously created payment method and Invoice Terms = Immediate. Book it
   Check the Payment Plan of the sales order.
   Create a Sales Invoice from it and complete it
   Check the Received field and the Outstanding Amount of the Payment Plan of the sales order has been updated.

Test 2:
   Create a Sales Order, set the previously created payment method and Invoice Terms = Immediate. Book it and Add the payment for the order.
   Check the Payment Plan of the sales order.
   Create a Sales Invoice from it and complete it
   Check the Received field and the Outstanding Amount of the Payment Plan of the sales order don't change.
(0078252)
vmromanos (developer)
2015-06-12 13:58

Repository: erp/backports/3.0PR15Q1.5
Changeset: 7d09d1580a03f1e0b3141534867414b5a00965a8
Author: Jorge Garcia <jorge.garcia <at> openbravo.com>
Date: Wed Jun 10 10:52:18 2015 +0200
URL: https://code.openbravo.com/erp/devel/pi/rev/209da9cda816 [^] [^]

Fixed issue 29972: Outstanding amount of sales order payment plan is not updated

The problem was that the outstanding amount of sales order payment plan is not
updated when payment method is set as automatic receipt.

Before the commit which introduces this regression, the function checked the
status of the payment. With the changes, the function checks if the payment
schedule detail is paid.

The problem was in the update of the payment plan of the sales order,
specifically in WHERE clause for outstanding amount.

Now, the where clause works as expected, and the outstanding amount is updated
properly.

---
M modules/org.openbravo.advpaymentmngt/src-db/database/model/functions/APRM_GEN_PAYMENTSCHEDULE_INV.xml
---
(0078253)
vmromanos (developer)
2015-06-12 13:58

Repository: erp/backports/3.0PR15Q1.5
Changeset: da877979571529ce8b82b9e812c59aa6bbd4fa85
Author: Víctor Martínez Romanos <victor.martinez <at> openbravo.com>
Date: Fri Jun 12 12:05:42 2015 +0200
URL: https://code.openbravo.com/erp/devel/pi/rev/70a9d6732cc5 [^] [^]

Related to issue 29972: code review improvements
Reduced useless query complexity to update outstanding amount.
It's only necessary to check fin_payment_detail_id is null (not associated payment) or isinvoicepaid='N' (associated payment but in a non paid yet status)

---
M modules/org.openbravo.advpaymentmngt/src-db/database/model/functions/APRM_GEN_PAYMENTSCHEDULE_INV.xml
---
(0078254)
vmromanos (developer)
2015-06-12 14:01

Code review + testing OK
(0078267)
hudsonbot (developer)
2015-06-14 19:57

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/1cf5ab8b5006 [^]
Maturity status: Test
(0078268)
hudsonbot (developer)
2015-06-14 19:57

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/1cf5ab8b5006 [^]
Maturity status: Test
(0083801)
hgbot (developer)
2016-02-02 09:34

Repository: tools/automation/int
Changeset: 94dbe8bacff5124cf287606da45964c911e9dd34
Author: Alvaro Ferraz <alvaro.ferraz <at> openbravo.com>
Date: Thu Sep 17 11:12:18 2015 +0200
URL: http://code.openbravo.com/tools/automation/int/rev/94dbe8bacff5124cf287606da45964c911e9dd34 [^]

Related to issue 29972: Added some automated tests

---
M src-test/com/openbravo/test/integration/erp/data/procurement/transactions/purchaseinvoice/PaymentDetailsData.java
M src-test/com/openbravo/test/integration/erp/data/procurement/transactions/purchaseinvoice/PaymentPlanData.java
M src-test/com/openbravo/test/integration/erp/data/procurement/transactions/purchaseorder/PaymentDetailsData.java
M src-test/com/openbravo/test/integration/erp/data/procurement/transactions/purchaseorder/PaymentPlanData.java
M src-test/com/openbravo/test/integration/erp/data/sales/transactions/salesinvoice/PaymentDetailsData.java
M src-test/com/openbravo/test/integration/erp/data/sales/transactions/salesinvoice/PaymentPlanData.java
M src-test/com/openbravo/test/integration/erp/data/sales/transactions/salesorder/PaymentDetailsData.java
M src-test/com/openbravo/test/integration/erp/data/sales/transactions/salesorder/PaymentPlanData.java
M src-test/com/openbravo/test/integration/erp/gui/procurement/transactions/purchaseorder/PaymentOutPlanTab.java
M src-test/com/openbravo/test/integration/erp/gui/sales/transactions/salesorder/HeaderTab.java
M src-test/com/openbravo/test/integration/erp/modules/functionalteam/addpayment/testsuites/APR_Regressions/RegressionSuite.java
M src-test/com/openbravo/test/integration/erp/modules/functionalteam/addpayment/testsuites/APR_Regressions/build.xml
M src-test/com/openbravo/test/integration/erp/testscripts/procurement/transactions/PurchaseOrder.java
M src-test/com/openbravo/test/integration/erp/testscripts/sales/transactions/SalesOrder.java
A src-test/com/openbravo/test/integration/erp/gui/procurement/transactions/purchaseorder/PaymentOutDetailsTab.java
A src-test/com/openbravo/test/integration/erp/gui/sales/transactions/salesorder/PaymentInDetailsTab.java
A src-test/com/openbravo/test/integration/erp/gui/sales/transactions/salesorder/PaymentInPlanTab.java
A src-test/com/openbravo/test/integration/erp/modules/functionalteam/addpayment/testsuites/APR_Regressions/APRRegression008.java
A src-test/com/openbravo/test/integration/erp/modules/functionalteam/addpayment/testsuites/APR_Regressions/APRRegression009.java
A src-test/com/openbravo/test/integration/erp/modules/functionalteam/addpayment/testsuites/APR_Regressions/APRRegression010.java
A src-test/com/openbravo/test/integration/erp/modules/functionalteam/addpayment/testsuites/APR_Regressions/APRRegression011.java
---

- Issue History
Date Modified Username Field Change
2015-05-22 09:56 ngarcia New Issue
2015-05-22 09:56 ngarcia Assigned To => Triage Finance
2015-05-22 09:56 ngarcia Modules => Advanced Payables and Receivables Mngmt
2015-05-22 09:56 ngarcia Triggers an Emergency Pack => No
2015-05-22 09:58 ngarcia Issue Monitored: networkb
2015-05-22 14:30 eugeni Issue Monitored: eugeni
2015-05-29 09:52 jorge-garcia Assigned To Triage Finance => jorge-garcia
2015-05-29 09:52 jorge-garcia Status new => acknowledged
2015-05-29 10:23 jorge-garcia Note Added: 0077884
2015-06-01 09:26 jorge-garcia Status acknowledged => scheduled
2015-06-03 16:36 jorge-garcia Relationship added related to 0030082
2015-06-05 11:46 jorge-garcia Regression level => Production - Confirmed Stable
2015-06-05 11:46 jorge-garcia Regression introduced in release => 3.0PR14Q2
2015-06-05 11:46 jorge-garcia Regression introduced by commit => https://code.openbravo.com/erp/devel/pi/rev/87765308f9bd4cdc21b7b53b437f1ed014f5a483 [^]
2015-06-05 11:46 jorge-garcia Target Version => pi
2015-06-05 11:47 jorge-garcia Status scheduled => acknowledged
2015-06-05 11:48 jorge-garcia Status acknowledged => scheduled
2015-06-05 11:48 jorge-garcia Target Version pi => 3.0PR15Q3
2015-06-05 13:07 jorge-garcia Regression date => 2014-02-11
2015-06-10 13:24 dmitry_mezentsev Relationship added caused by 0025696
2015-06-12 13:58 vmromanos Note Added: 0078252
2015-06-12 13:58 vmromanos Note Added: 0078253
2015-06-12 13:59 vmromanos Status scheduled => resolved
2015-06-12 13:59 vmromanos Fixed in SCM revision => 209da9cda816
2015-06-12 13:59 vmromanos Resolution open => fixed
2015-06-12 14:00 vmromanos Fixed in SCM revision 209da9cda816 => https://code.openbravo.com/erp/devel/pi/rev/209da9cda816 [^]
2015-06-12 14:01 vmromanos Review Assigned To => vmromanos
2015-06-12 14:01 vmromanos Note Added: 0078254
2015-06-12 14:01 vmromanos Status resolved => closed
2015-06-12 14:11 vmromanos Relationship added related to 0030170
2015-06-14 19:57 hudsonbot Checkin
2015-06-14 19:57 hudsonbot Note Added: 0078267
2015-06-14 19:57 hudsonbot Checkin
2015-06-14 19:57 hudsonbot Note Added: 0078268
2016-02-02 09:34 hgbot Checkin
2016-02-02 09:34 hgbot Note Added: 0083801
2016-08-10 14:25 aferraz Relationship added related to 0033500


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker