Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0030121
TypeCategorySeverityReproducibilityDate SubmittedLast Update
backport[Openbravo ERP] Z. Othersmajoralways2015-06-03 13:452015-06-12 13:51
Reporterjorge-garciaView Statuspublic 
Assigned Tojorge-garcia 
PriorityurgentResolutionfixedFixed in Version
StatusclosedFix in branchFixed in SCM revision5612ad11863b
ProjectionnoneETAnoneTarget Version3.0PR15Q2.2
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Tovmromanos
Web browser
ModulesAdvanced Payables and Receivables Mngmt
Regression levelProduction - Confirmed Stable
Regression date2014-07-18
Regression introduced in release3.0PR14Q3
Regression introduced by commithttps://code.openbravo.com/erp/devel/pi/diff/87765308f9bd/modules/org.openbravo.advpaymentmngt/src-db/database/model/functions/APRM_GEN_PAYMENTSCHEDULE_INV.xml [^]
Triggers an Emergency PackNo
Summary

0030121: Payment plan is updating wrong in some circunstancies

DescriptionPayment plan is updating wrong if Payment Method is set as Automatic Receipt and a sales order is partially paid.
Steps To ReproduceAs group admin role:
   Create a new Payment Method and set Automatic Receipt = 'Y'
   Add it to a financial account.
   Create a Sales Order, set the previously created payment method and Invoice Terms = Immediate.
   Click on Add Payment an create a partial payment for the Sales Order.
   Create a Sales Invoice from it and complete it
   Check the Received field of the Payment Plan of the invoice has been updated with the sum of the full payment and the partial payment of the order and the Outstanding amount is wrong as well.
  Check the payment details of the payment plan from both (order and invoice) are created correctly
TagsApproved
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
blocks defect 00300823.0PR15Q3 closedjorge-garcia Payment plan is updating wrong in some circunstancies 

-  Notes
(0078238)
hgbot (developer)
2015-06-12 13:46

Repository: erp/backports/3.0PR15Q2.2
Changeset: 5612ad11863bfd91463028ba7a796cbb9ab0e50d
Author: Jorge Garcia <jorge.garcia <at> openbravo.com>
Date: Wed Jun 10 13:09:56 2015 +0200
URL: http://code.openbravo.com/erp/backports/3.0PR15Q2.2/rev/5612ad11863bfd91463028ba7a796cbb9ab0e50d [^]

Fixed issue 30121: Payment plan is updating wrong in some circumstances

Payment plan is updating wrong if Payment Method is set as Automatic Receipt
and a sales order is partially paid.

The problem was that the function duplicates the value of the received amount
created in the Complete process of the invoice, because the function searches
all the payment details of the payment plan that has an invoice paid
(invoicepaid column).

The solution is to search those payment details that are not pre-paid and then
update the payment plan.

Now, the values are filled correctly.

---
M modules/org.openbravo.advpaymentmngt/src-db/database/model/functions/APRM_GEN_PAYMENTSCHEDULE_INV.xml
---
(0078241)
hgbot (developer)
2015-06-12 13:46

Repository: erp/backports/3.0PR15Q2.2
Changeset: 9887ec5384c1ff7b9ed56b52184bf7c7af8b45e2
Author: Víctor Martínez Romanos <victor.martinez <at> openbravo.com>
Date: Fri Jun 12 12:49:18 2015 +0200
URL: http://code.openbravo.com/erp/backports/3.0PR15Q2.2/rev/9887ec5384c1ff7b9ed56b52184bf7c7af8b45e2 [^]

Related to issue 30121: code review improvements

The invoice's payment schedules and payment monitor is only updated when all the payment schedule details are paid.

This changeset covers the scenario where an order is partially paid. Before this change, the invoice's payment schedules and payment monitor were wrongly updated considering that the payment schedule was fully paid when any of its payment schedule details was paid. That asumption may be wrong in some scenarios, for example when the order is associated to one or more payment schedule details not yet paid (isinvoicepaid=N) and at least one already paid.

---
M modules/org.openbravo.advpaymentmngt/src-db/database/model/functions/APRM_GEN_PAYMENTSCHEDULE_INV.xml
---
(0078247)
vmromanos (developer)
2015-06-12 13:51

Code review + testing OK

- Issue History
Date Modified Username Field Change
2015-06-08 11:00 jorge-garcia Type defect => backport
2015-06-08 11:00 jorge-garcia Target Version => 3.0PR15Q2.2
2015-06-09 17:52 jorge-garcia Regression introduced by commit https://code.openbravo.com/erp/devel/pi/rev/77b6251af841 [^] => https://code.openbravo.com/erp/devel/pi/diff/87765308f9bd/modules/org.openbravo.advpaymentmngt/src-db/database/model/functions/APRM_GEN_PAYMENTSCHEDULE_INV.xml [^]
2015-06-10 13:27 dmitry_mezentsev Tag Attached: Approved
2015-06-12 13:46 hgbot Checkin
2015-06-12 13:46 hgbot Note Added: 0078238
2015-06-12 13:46 hgbot Checkin
2015-06-12 13:46 hgbot Note Added: 0078239
2015-06-12 13:46 hgbot Status scheduled => resolved
2015-06-12 13:46 hgbot Resolution open => fixed
2015-06-12 13:46 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/backports/3.0PR15Q2.2/rev/5612ad11863bfd91463028ba7a796cbb9ab0e50d [^]
2015-06-12 13:46 hgbot Status scheduled => resolved
2015-06-12 13:46 hgbot Checkin
2015-06-12 13:46 hgbot Note Added: 0078241
2015-06-12 13:51 vmromanos Note Deleted: 0078239
2015-06-12 13:51 vmromanos Review Assigned To => vmromanos
2015-06-12 13:51 vmromanos Note Added: 0078247
2015-06-12 13:51 vmromanos Status resolved => closed


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker