Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0029618
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] 09. Financial managementmajoralways2015-04-16 19:292015-05-14 17:49
ReporteraferrazView Statuspublic 
Assigned Toaferraz 
PriorityimmediateResolutionfixedFixed in Version
StatusclosedFix in branchFixed in SCM revisiona810d05065cf
ProjectionnoneETAnoneTarget Version
OSLinux 64 bitDatabasePostgreSQLJava version1.6.0_18
OS VersionProfessional ApplianceDatabase version8.3.9Ant version1.7.1
Product VersionSCM revision 
Review Assigned Tovmromanos
Web browser
ModulesCore
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0029618: G/L Journal Accounting amounts are not setted correctly

DescriptionG/L Journal Accounting amounts are not setted correctly if allow negative is not setted, g/l journal header rate is different than one and g/l journal line amounts are negative
Steps To ReproduceAs group admin role:
   Set Allow negative as false for F&B España, S.A. US/A/Euro in General Ledger Configuration window
   Create a G/L Journal batch
      Organization: F&B España - Región Norte
      Currency: EUR
   Create a header
      Organization: F&B España - Región Norte
      General Ledger: F&B España, S.A. US/A/Euro
      Currency: USD
   Add two lines to it with negative amounts
   Complete and post the document
   Check that the rate is not applied in accounting amounts when converting from USD to EUR (general ledger currency)
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
related to defect 0029610 closedaferraz Error in GLJournalAccountingCheck validation 
related to defect 0029222 closedaferraz G/L Journal Accounting amounts are not setted correctly 
causes defect 0030820 closedAtulOpenbravo accounting process is not working with payment out and negative amount 

-  Notes
(0076623)
aferraz (developer)
2015-04-20 10:41

Test plan:

As group admin role:
   Set Allow negative as false for F&B España, S.A. US/A/Euro in General Ledger Configuration window
   Create a G/L Journal batch
      Organization: F&B España - Región Norte
      Currency: EUR
   Create a header
      Organization: F&B España - Región Norte
      General Ledger: F&B España, S.A. US/A/Euro
      Currency: USD
   Add two lines to it with negative amounts
   Complete and post the document
   Check that the rate is correctly applied in accounting amounts when converting from USD to EUR (general ledger currency)
(0077425)
hgbot (developer)
2015-05-14 10:08

Repository: erp/devel/pi
Changeset: a810d05065cfe7eb3199928ed9104c7b54989ecb
Author: Alvaro Ferraz <alvaro.ferraz <at> openbravo.com>
Date: Thu May 14 09:56:05 2015 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/a810d05065cfe7eb3199928ed9104c7b54989ecb [^]

Fixes issue 29618: G/L Journal Accounting amounts are setted correctly

Now, converted amounts are correctly setted when posting a G/L Journal although amounts are negative and rate is different than 1

---
M src/org/openbravo/erpCommon/ad_forms/Fact.java
---
(0077426)
vmromanos (developer)
2015-05-14 10:08

Code review + testing OK
(0077466)
hudsonbot (developer)
2015-05-14 17:49

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/3375171dd310 [^]
Maturity status: Test

- Issue History
Date Modified Username Field Change
2015-04-16 19:29 aferraz New Issue
2015-04-16 19:29 aferraz Assigned To => Triage Finance
2015-04-16 19:29 aferraz Modules => Core
2015-04-16 19:29 aferraz Regression level => Production - Confirmed Stable
2015-04-16 19:29 aferraz Regression date => 2012-09-11
2015-04-16 19:29 aferraz Regression introduced in release => 3.0MP16
2015-04-16 19:29 aferraz Regression introduced by commit => https://code.openbravo.com/erp/devel/pi/rev/05beb7bb79c27623c216afd0cd63aa758cb3f690 [^]
2015-04-16 19:29 aferraz Triggers an Emergency Pack => No
2015-04-16 19:30 aferraz Description Updated View Revisions
2015-04-16 19:31 aferraz Description Updated View Revisions
2015-04-17 08:28 aferraz Relationship added caused by 0021579
2015-04-17 11:55 aferraz Relationship added related to 0029610
2015-04-17 11:55 aferraz Relationship added related to 0029222
2015-04-17 13:32 aferraz Steps to Reproduce Updated View Revisions
2015-04-17 15:28 aferraz Regression level Production - Confirmed Stable =>
2015-04-17 15:28 aferraz Regression date 2012-09-11 =>
2015-04-17 15:28 aferraz Regression introduced in release 3.0MP16 =>
2015-04-17 15:28 aferraz Regression introduced by commit https://code.openbravo.com/erp/devel/pi/rev/05beb7bb79c27623c216afd0cd63aa758cb3f690 [^] =>
2015-04-20 10:34 aferraz Assigned To Triage Finance => aferraz
2015-04-20 10:36 aferraz Status new => scheduled
2015-04-20 10:36 aferraz Relationship deleted caused by 0021579
2015-04-20 10:41 aferraz Note Added: 0076623
2015-05-14 10:08 hgbot Checkin
2015-05-14 10:08 hgbot Note Added: 0077425
2015-05-14 10:08 hgbot Status scheduled => resolved
2015-05-14 10:08 hgbot Resolution open => fixed
2015-05-14 10:08 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/a810d05065cfe7eb3199928ed9104c7b54989ecb [^]
2015-05-14 10:08 vmromanos Review Assigned To => vmromanos
2015-05-14 10:08 vmromanos Note Added: 0077426
2015-05-14 10:08 vmromanos Status resolved => closed
2015-05-14 17:49 hudsonbot Checkin
2015-05-14 17:49 hudsonbot Note Added: 0077466
2015-09-14 18:19 vmromanos Relationship added causes 0030820


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker