Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0030820
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] 09. Financial managementmajoralways2015-09-14 17:442015-09-16 02:20
ReportermalsasuaView Statuspublic 
Assigned ToAtulOpenbravo 
PriorityimmediateResolutionfixedFixed in Version
StatusclosedFix in branchFixed in SCM revisiondb293dedb2ec
ProjectionnoneETAnoneTarget Version
OSLinux 32 bitDatabasePostgreSQLJava version1.6.0_18
OS VersionCommunity ApplianceDatabase version8.3.9Ant version1.7.1
Product Version3.0PR15Q3.1SCM revision 
Review Assigned Tovmromanos
Web browser
ModulesCore
Regression levelProduction - QA Approved
Regression date2015-05-14
Regression introduced in release3.0PR15Q3
Regression introduced by commithttps://code.openbravo.com/erp/devel/pi/rev/a810d05065cfe7eb3199928ed9104c7b54989ecb [^]
Triggers an Emergency PackNo
Summary

0030820: accounting process is not working with payment out and negative amount

Descriptionwhen you run the accounting process to negative payment amount, error is returned:
Error
Process failed during execution
Steps To Reproduce. in F&B
 . go to financial account "Cuenta de Banco"
  -> tab: "payment method" -> transferencia
   . upon payment use: in transit payment account

 . go to purchase invoice:
  . new header:
   bp: Generación Electrica
  . new lines:
   product: Sitemas de información
   qty: -20
   amt: 5
 . process invoice

 . add payment-> process and deposit
 . go to payment out -> the payment created above
  . post it
error is returned
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
depends on backport 00308213.0PR15Q3.2 closedAtulOpenbravo accounting process is not working with payment out and negative amount 
caused by defect 0029618 closedaferraz G/L Journal Accounting amounts are not setted correctly 

-  Notes
(0080389)
vmromanos (developer)
2015-09-14 18:18

Detected NPE when trying to access attributes from docLine object https://code.openbravo.com/erp/devel/pi/rev/a810d05065cfe7eb3199928ed9104c7b54989ecb#l1.24 [^]
(0080399)
AtulOpenbravo (developer)
2015-09-15 11:47
edited on: 2015-09-15 11:48

Test Plan
- Login as F&B International Group Admin
- Go to Financial Account "Cuenta de Banco".
- Go to Payment Method "Transferencia"
- Set upon payment use as in transit payment account.

- Go to purchase invoice:
- Create new record for business partner "Generación Electrica".
- In lines set following as:
   product: Sitemas de información
   qty: -20
   amt: 5
- Process invoice.
- Add payment and process it.
- Go to payment out and select above created payment record and post it.
- Check that posting is successful.

(0080412)
vmromanos (developer)
2015-09-15 16:50

Verified also scenario for 0029618
(0080413)
hgbot (developer)
2015-09-15 16:50

Repository: erp/devel/pi
Changeset: db293dedb2ec916914f093105d9d8abb2a61192f
Author: Atul Gaware <atul.gaware <at> openbravo.com>
Date: Tue Sep 15 15:07:15 2015 +0530
URL: http://code.openbravo.com/erp/devel/pi/rev/db293dedb2ec916914f093105d9d8abb2a61192f [^]

Fixes Issue 30820:Accounting process fails for payment out with negative amt

If the docbasetype is not GLJournal is null then docLine Object is null. A
docbasetype check is added before accessing docLine Object.

---
M src/org/openbravo/erpCommon/ad_forms/Fact.java
---
(0080416)
vmromanos (developer)
2015-09-15 16:51

Code review + testing OK
(0080426)
hudsonbot (developer)
2015-09-16 02:20

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/ab68e2868765 [^]
Maturity status: Test

- Issue History
Date Modified Username Field Change
2015-09-14 17:44 malsasua New Issue
2015-09-14 17:44 malsasua Assigned To => Triage Finance
2015-09-14 17:44 malsasua Modules => Core
2015-09-14 17:44 malsasua Regression level => Production - QA Approved
2015-09-14 17:44 malsasua Triggers an Emergency Pack => No
2015-09-14 18:18 vmromanos Regression date => 2015-05-14
2015-09-14 18:18 vmromanos Regression introduced in release => 3.0PR15Q3
2015-09-14 18:18 vmromanos Regression introduced by commit => https://code.openbravo.com/erp/devel/pi/rev/a810d05065cfe7eb3199928ed9104c7b54989ecb [^]
2015-09-14 18:18 vmromanos Note Added: 0080389
2015-09-14 18:18 vmromanos Status new => scheduled
2015-09-14 18:18 vmromanos Assigned To Triage Finance => AtulOpenbravo
2015-09-14 18:19 vmromanos Relationship added caused by 0029618
2015-09-15 11:47 AtulOpenbravo Note Added: 0080399
2015-09-15 11:48 AtulOpenbravo Note Edited: 0080399 View Revisions
2015-09-15 16:50 vmromanos Note Added: 0080412
2015-09-15 16:50 hgbot Checkin
2015-09-15 16:50 hgbot Note Added: 0080413
2015-09-15 16:50 hgbot Status scheduled => resolved
2015-09-15 16:50 hgbot Resolution open => fixed
2015-09-15 16:50 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/db293dedb2ec916914f093105d9d8abb2a61192f [^]
2015-09-15 16:51 vmromanos Review Assigned To => vmromanos
2015-09-15 16:51 vmromanos Note Added: 0080416
2015-09-15 16:51 vmromanos Status resolved => closed
2015-09-16 02:20 hudsonbot Checkin
2015-09-16 02:20 hudsonbot Note Added: 0080426


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker