Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0029222
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] 09. Financial managementmajoralways2015-03-10 14:022015-03-27 02:12
ReporteraferrazView Statuspublic 
Assigned Toaferraz 
PriorityimmediateResolutionfixedFixed in Versionpi
StatusclosedFix in branchFixed in SCM revisione1e05d8bbccb
ProjectionnoneETAnoneTarget Version
OSLinux 64 bitDatabasePostgreSQLJava version1.6.0_18
OS VersionProfessional ApplianceDatabase version8.3.9Ant version1.7.1
Product VersionSCM revision 
Review Assigned Toumartirena
Web browser
ModulesCore
Regression levelProduction - QA Approved
Regression date2014-11-28
Regression introduced in release3.0PR15Q1
Regression introduced by commithttps://code.openbravo.com/erp/devel/pi/rev/7c00db2d6532 [^]
Triggers an Emergency PackNo
Summary

0029222: G/L Journal Accounting amounts are not setted correctly

DescriptionG/L Journal Accounting amounts are not setted correctly when changing the header rate
Steps To ReproduceAs group admin role:
   Create a G/L Journal batch
      Organization: F&B España - Región Norte
      Currency: EUR
   Create a header
      Organization: F&B España - Región Norte
      General Ledger: F&B España, S.A. US/A/Euro
      Currency: USD
   Add two lines to it
   Change the rate of the header
   Complete and post the document
   Check that the new rate is not applied in accounting amounts when converting from USD to EUR (general ledger currency)
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
depends on backport 00292283.0PR15Q1.2 closedaferraz G/L Journal Accounting amounts are not setted correctly 
caused by feature request 0027104 closeddmiguelez New window: Simple GL Journal 
related to defect 0029256 closedaferraz It's not possible to complete a Simple G/L Journal in Oracle 
related to defect 0029257 closedaferraz It's not possible to post a Simple G/L Journal setted as multi-general ledger 
related to defect 0029315 closedaferraz Accounts are setted wrongly when posting a Simple G/L Journal setted as multi-general ledger 
related to defect 0029322 newTriage Finance It should be possible to change rate in Simple G/L Journal 
related to defect 0029618 closedaferraz G/L Journal Accounting amounts are not setted correctly 
causes defect 0029610 closedaferraz Error in GLJournalAccountingCheck validation 
causes defect 0029897 closededuardo_Argal False positives in GLJournalAccountingCheck validation 

-  Notes
(0076006)
hgbot (developer)
2015-03-26 13:52

Repository: erp/devel/pi
Changeset: e1e05d8bbccb1f539354289c33fbdf4921464453
Author: Alvaro Ferraz <alvaro.ferraz <at> openbravo.com>
Date: Tue Mar 17 13:17:04 2015 +0100
URL: http://code.openbravo.com/erp/devel/pi/rev/e1e05d8bbccb1f539354289c33fbdf4921464453 [^]

Fixes issue 29222: G/L Journal Accounting amounts are not setted correctly

Conversion rate to apply to accounting amounts will be getted from the system when it is setted as multi-general ledger and from the document when it is not

---
M src/org/openbravo/erpCommon/ad_forms/DocGLJournal.java
---
(0076007)
hgbot (developer)
2015-03-26 13:52

Repository: erp/devel/pi
Changeset: d21dd3116c92194f50a74e73d3023669da3938ef
Author: Alvaro Ferraz <alvaro.ferraz <at> openbravo.com>
Date: Thu Mar 26 11:01:08 2015 +0100
URL: http://code.openbravo.com/erp/devel/pi/rev/d21dd3116c92194f50a74e73d3023669da3938ef [^]

Related to issue 29222: Add a build validation to create an alert if wrong data

A build validation will be executed to check if it exists wrong data (g/l journal accounting with wrong amounts) related to the issue. In that case an alert will be created to tell the user to reset accounting, but when fixed it will be deactivated to avoid execute it again.
The build validation will only be executed when updating from Q1 or Q1.1, because the issue is introduced in Q1 and resolved in Q1.2.

---
A src-util/buildvalidation/build/classes/org/openbravo/buildvalidation/GLJournalAccountingCheck.class
A src-util/buildvalidation/build/classes/org/openbravo/buildvalidation/GLJournalAccountingCheckData.class
A src-util/buildvalidation/src/org/openbravo/buildvalidation/GLJournalAccountingCheck.java
A src-util/buildvalidation/src/org/openbravo/buildvalidation/GLJournalAccountingCheck_data.xsql
---
(0076008)
hgbot (developer)
2015-03-26 13:52

Repository: erp/devel/pi
Changeset: fae899b56870b17568c07b281f15f968ae4f6a5b
Author: Unai Martirena <unai.martirena <at> openbravo.com>
Date: Thu Mar 26 13:49:13 2015 +0100
URL: http://code.openbravo.com/erp/devel/pi/rev/fae899b56870b17568c07b281f15f968ae4f6a5b [^]

Related to issue 29222: Fix copyright

---
M src/org/openbravo/erpCommon/ad_forms/DocGLJournal.java
---
(0076010)
umartirena (developer)
2015-03-26 13:53

Code Review + Testing OK
(0076039)
hudsonbot (developer)
2015-03-27 02:12

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/b8858c8b542b [^]
Maturity status: Test
(0076040)
hudsonbot (developer)
2015-03-27 02:12

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/b8858c8b542b [^]
Maturity status: Test
(0076041)
hudsonbot (developer)
2015-03-27 02:12

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/b8858c8b542b [^]
Maturity status: Test

- Issue History
Date Modified Username Field Change
2015-03-10 14:02 aferraz New Issue
2015-03-10 14:02 aferraz Assigned To => aferraz
2015-03-10 14:02 aferraz Modules => Core
2015-03-10 14:02 aferraz Regression level => Production - QA Approved
2015-03-10 14:02 aferraz Regression date => 2014-11-28
2015-03-10 14:02 aferraz Regression introduced in release => 3.0PR15Q1
2015-03-10 14:02 aferraz Regression introduced by commit => https://code.openbravo.com/erp/devel/pi/rev/7c00db2d6532 [^]
2015-03-10 14:02 aferraz Triggers an Emergency Pack => No
2015-03-10 17:51 aferraz Status new => scheduled
2015-03-11 09:54 aferraz Steps to Reproduce Updated View Revisions
2015-03-12 13:47 aferraz Relationship added related to 0029256
2015-03-12 13:48 aferraz Relationship added related to 0029257
2015-03-13 17:52 dmitry_mezentsev Tag Attached: Approved
2015-03-13 17:52 dmitry_mezentsev Tag Detached: Approved
2015-03-13 17:52 dmitry_mezentsev Relationship added caused by 0027104
2015-03-17 13:00 aferraz Relationship added related to 0029315
2015-03-17 19:18 aferraz Relationship added related to 0029322
2015-03-26 13:52 hgbot Checkin
2015-03-26 13:52 hgbot Note Added: 0076006
2015-03-26 13:52 hgbot Status scheduled => resolved
2015-03-26 13:52 hgbot Resolution open => fixed
2015-03-26 13:52 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/e1e05d8bbccb1f539354289c33fbdf4921464453 [^]
2015-03-26 13:52 hgbot Checkin
2015-03-26 13:52 hgbot Note Added: 0076007
2015-03-26 13:52 hgbot Checkin
2015-03-26 13:52 hgbot Note Added: 0076008
2015-03-26 13:53 umartirena Review Assigned To => umartirena
2015-03-26 13:53 umartirena Note Added: 0076010
2015-03-26 13:53 umartirena Status resolved => closed
2015-03-26 13:53 umartirena Fixed in Version => pi
2015-03-27 02:12 hudsonbot Checkin
2015-03-27 02:12 hudsonbot Note Added: 0076039
2015-03-27 02:12 hudsonbot Checkin
2015-03-27 02:12 hudsonbot Note Added: 0076040
2015-03-27 02:12 hudsonbot Checkin
2015-03-27 02:12 hudsonbot Note Added: 0076041
2015-04-16 19:09 dmitry_mezentsev Relationship added causes 0029610
2015-04-17 11:55 aferraz Relationship added related to 0029618
2015-05-15 12:23 aferraz Relationship added causes 0029897


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker