Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0029897
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] 09. Financial managementminoralways2015-05-15 10:452015-07-10 10:40
ReportermalsasuaView Statuspublic 
Assigned Toeduardo_Argal 
PriorityimmediateResolutionfixedFixed in Version3.0PR15Q3
StatusclosedFix in branchFixed in SCM revisionb57f80503cdc
ProjectionnoneETAnoneTarget Version
OSLinux 32 bitDatabasePostgreSQLJava version1.6.0_18
OS VersionCommunity ApplianceDatabase version8.3.9Ant version1.7.1
Product VersionSCM revision 
Review Assigned Toaferraz
Web browser
ModulesCore
Regression levelProduction - Confirmed Stable
Regression date2015-03-26
Regression introduced in release3.0PR15Q1.2
Regression introduced by commithttps://code.openbravo.com/erp/devel/pi/rev/d21dd3116c92194f50a74e73d3023669da3938ef [^]
Triggers an Emergency PackNo
Summary

0029897: False positives in GLJournalAccountingCheck validation

DescriptionWhen exist records in the fact_acct with the same record_id, and line_id, but distinct ad_table_id (it occurs in old records when the key of tables were numerics, not uuids), this build validation is failing
Steps To Reproducecreate records in the fact_acct with the same record_id and line_id, but distinct amounts
Proposed Solutionin the query, one filter by ad_table_id should be added.
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
depends on backport 00298993.0PR15Q2.1 closededuardo_Argal False positives in GLJournalAccountingCheck validation 
depends on backport 00299003.0PR15Q1.4 closededuardo_Argal False positives in GLJournalAccountingCheck validation 
caused by defect 0029222 closedaferraz G/L Journal Accounting amounts are not setted correctly 

-  Notes
(0077497)
hgbot (developer)
2015-05-15 15:10

Repository: erp/devel/pi
Changeset: b57f80503cdcec10dc33b1cdea32cd707f2783f6
Author: Eduardo Argal Guibert <eduardo.argal <at> openbravo.com>
Date: Fri May 15 12:01:31 2015 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/b57f80503cdcec10dc33b1cdea32cd707f2783f6 [^]

Fixes issue 29897: False positives in GLJournalAccountingCheck validation
Missing ad_table_id constraint ends up in wrong validation when there are old records using numeric values for ids.

---
M src-util/buildvalidation/src/org/openbravo/buildvalidation/GLJournalAccountingCheck_data.xsql
---
(0077500)
aferraz (developer)
2015-05-15 15:13

Code review + Testing OK
(0077512)
hudsonbot (developer)
2015-05-16 05:21

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/33b0ebaa36ae [^]
Maturity status: Test

- Issue History
Date Modified Username Field Change
2015-05-15 10:45 malsasua New Issue
2015-05-15 10:45 malsasua Assigned To => Triage Finance
2015-05-15 10:45 malsasua Modules => Core
2015-05-15 10:45 malsasua Triggers an Emergency Pack => No
2015-05-15 11:59 aferraz Assigned To Triage Finance => eduardo_Argal
2015-05-15 11:59 aferraz Status new => scheduled
2015-05-15 12:04 aferraz Regression level => Production - Confirmed Stable
2015-05-15 12:04 aferraz Regression date => 2015-03-26
2015-05-15 12:04 aferraz Regression introduced in release => 3.0PR15Q1.2
2015-05-15 12:04 aferraz Regression introduced by commit => https://code.openbravo.com/erp/devel/pi/rev/d21dd3116c92194f50a74e73d3023669da3938ef [^]
2015-05-15 12:23 aferraz Relationship added caused by 0029222
2015-05-15 15:10 hgbot Checkin
2015-05-15 15:10 hgbot Note Added: 0077497
2015-05-15 15:10 hgbot Status scheduled => resolved
2015-05-15 15:10 hgbot Resolution open => fixed
2015-05-15 15:10 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/b57f80503cdcec10dc33b1cdea32cd707f2783f6 [^]
2015-05-15 15:13 aferraz Review Assigned To => aferraz
2015-05-15 15:13 aferraz Note Added: 0077500
2015-05-15 15:13 aferraz Status resolved => closed
2015-05-15 15:13 aferraz Fixed in Version => 3.0PR15Q3
2015-05-16 05:21 hudsonbot Checkin
2015-05-16 05:21 hudsonbot Note Added: 0077512
2015-07-10 10:40 dmitry_mezentsev Severity major => minor


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker