Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0029440
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] 09. Financial managementmajorhave not tried2015-03-27 12:572015-03-31 00:07
ReporterjonalegriaesarteView Statuspublic 
Assigned Toumartirena 
PrioritynormalResolutionfixedFixed in Version
StatusclosedFix in branchFixed in SCM revision1377ec164924
ProjectionnoneETAnoneTarget Version3.0PR15Q3
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product Version3.0PR15Q1.1SCM revision 
Review Assigned Tovmromanos
Web browser
ModulesCore
Regression levelProduction - QA Approved
Regression date2015-02-16
Regression introduced in release3.0PR15Q1.1
Regression introduced by commithttps://code.openbravo.com/erp/devel/pi/rev/7a7b3954ec59 [^]
Triggers an Emergency PackNo
Summary

0029440: In a environment with costs not calculated the user can not get the sales invoice dimensional report

DescriptionIn a environment with costs not calculated the user can not get the sales invoice dimensional report. The issue comes from the following commit:
https://code.openbravo.com/erp/devel/pi/rev/7a7b3954ec59 [^]

In this commit, a cost initialization was added, to set a value in a new column. If the costing process fails the first time the initialization is done, the process reverts all the changes and the preference needed to show the report is not set. That's why the report fails.
Steps To Reproduce- Environment in Q3.7 where the cost process is failing.
- Update to Q1.1.
- Costing background process still failing
- Sales invoice dimensional report is not working fine
Proposed SolutionAdd a commit in the initialization process in costing background process.
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
depends on backport 00294543.0PR15Q1.3 closedumartirena In a environment with costs not calculated the user can not get the sales invoice dimensional report 
caused by defect 00281113.0PR15Q2 closedumartirena InitializeMTransCostDateacctData modulescript has several performance issues 

-  Notes
(0076147)
hgbot (developer)
2015-03-30 16:31

Repository: erp/devel/pi
Changeset: 1377ec1649244e79cb535cbc02ff18403727bc06
Author: Unai Martirena <unai.martirena <at> openbravo.com>
Date: Mon Mar 30 10:10:41 2015 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/1377ec1649244e79cb535cbc02ff18403727bc06 [^]

Fixes bug 29440: Initialize dateacct column is always been done.

At the beginning of costing background a process to initialize dateacct column of m_transaction_cost has being added. This process is independant from Costing Background, but it was added here to avoid the performance problems that it was causing when executing as a modulescript.

It this columns are not initialized it will not be possible to launch 'Sales Invoice Dimensional Report' and 'Valued Stock Report'. The problem happens when the Costing Background process fails for the first transaction that is calculating, because it rollbacks everything, including the process to initialize dateacct column, so, it is not possible to launch the two reports.

A OBDal.getInstance().getConnection(true).commit() has been added right after initializing dateacct to maintain this changes even when the Costing background fails on the first transaction.

---
M src/org/openbravo/costing/CostingBackground.java
---
(0076148)
vmromanos (developer)
2015-03-30 16:32

Code review + testing OK
(0076165)
hudsonbot (developer)
2015-03-31 00:07

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/34da08f135b8 [^]
Maturity status: Test

- Issue History
Date Modified Username Field Change
2015-03-27 12:57 jonalegriaesarte New Issue
2015-03-27 12:57 jonalegriaesarte Assigned To => umartirena
2015-03-27 12:57 jonalegriaesarte Modules => Core
2015-03-27 12:57 jonalegriaesarte Triggers an Emergency Pack => No
2015-03-27 14:34 umartirena Regression level => Production - QA Approved
2015-03-27 14:34 umartirena Regression date => 2015-02-16
2015-03-27 14:34 umartirena Regression introduced in release => 3.0PR15Q1.1
2015-03-27 14:34 umartirena Regression introduced by commit => https://code.openbravo.com/erp/devel/pi/rev/7a7b3954ec59 [^]
2015-03-27 16:33 dmitry_mezentsev Relationship added caused by 0028111
2015-03-30 10:12 umartirena Status new => scheduled
2015-03-30 13:59 jonalegriaesarte Target Version 3.0PR15Q2 => 3.0PR15Q3
2015-03-30 16:31 hgbot Checkin
2015-03-30 16:31 hgbot Note Added: 0076147
2015-03-30 16:31 hgbot Status scheduled => resolved
2015-03-30 16:31 hgbot Resolution open => fixed
2015-03-30 16:31 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/1377ec1649244e79cb535cbc02ff18403727bc06 [^]
2015-03-30 16:32 vmromanos Review Assigned To => vmromanos
2015-03-30 16:32 vmromanos Note Added: 0076148
2015-03-30 16:32 vmromanos Status resolved => closed
2015-03-31 00:07 hudsonbot Checkin
2015-03-31 00:07 hudsonbot Note Added: 0076165


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker