Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0029454
TypeCategorySeverityReproducibilityDate SubmittedLast Update
backport[Openbravo ERP] 09. Financial managementmajorhave not tried2015-03-27 12:572015-04-01 17:11
ReporterjonalegriaesarteView Statuspublic 
Assigned Toumartirena 
PrioritynormalResolutionfixedFixed in Version
StatusclosedFix in branchFixed in SCM revisiona5760416a340
ProjectionnoneETAnoneTarget Version3.0PR15Q1.3
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product Version3.0PR15Q1.1SCM revision 
Review Assigned Tovmromanos
Web browser
ModulesCore
Regression levelProduction - QA Approved
Regression date2015-02-16
Regression introduced in release3.0PR15Q1.1
Regression introduced by commithttps://code.openbravo.com/erp/devel/pi/rev/7a7b3954ec59 [^]
Triggers an Emergency PackNo
Summary

0029454: In a environment with costs not calculated the user can not get the sales invoice dimensional report

DescriptionIn a environment with costs not calculated the user can not get the sales invoice dimensional report. The issue comes from the following commit:
https://code.openbravo.com/erp/devel/pi/rev/7a7b3954ec59 [^]

In this commit, a cost initialization was added, to set a value in a new column. If the costing process fails the first time the initialization is done, the process reverts all the changes and the preference needed to show the report is not set. That's why the report fails.
Steps To Reproduce- Environment in Q3.7 where the cost process is failing.
- Update to Q1.1.
- Costing background process still failing
- Sales invoice dimensional report is not working fine
Proposed SolutionAdd a commit in the initialization process in costing background process.
TagsApproved
Attached Files? file icon 29454.export [^] (1,470 bytes) 2015-03-30 16:33

- Relationships Relation Graph ] Dependency Graph ]
blocks defect 00294403.0PR15Q3 closedumartirena In a environment with costs not calculated the user can not get the sales invoice dimensional report 

-  Notes
(0076149)
vmromanos (developer)
2015-03-30 16:34

Attached diff that fixes the issue.

Pending to be pushed to backport branch when available (code review + testing already done)
(0076324)
hgbot (developer)
2015-04-01 17:10

Repository: erp/backports/3.0PR15Q1.3
Changeset: a5760416a340b3d92830651dd0c45aa56e33d0bf
Author: Unai Martirena <unai.martirena <at> openbravo.com>
Date: Mon Mar 30 10:15:36 2015 +0200
URL: http://code.openbravo.com/erp/backports/3.0PR15Q1.3/rev/a5760416a340b3d92830651dd0c45aa56e33d0bf [^]

Fixes bug 29454: Initialize dateacct column is always been done.

At the beginning of costing background a process to initialize dateacct column of m_transaction_cost has being added. This process is independant from Costing Background, but it was added here to avoid the performance problems that it was causing when executing as a modulescript.

It this columns are not initialized it will not be possible to launch 'Sales Invoice Dimensional Report' and 'Valued Stock Report'. The problem happens when the Costing Background process fails for the first transaction that is calculating, because it rollbacks everything, including the process to initialize dateacct column, so, it is not possible to launch the two reports.

---
M src/org/openbravo/costing/CostingBackground.java
---
(0076325)
vmromanos (developer)
2015-04-01 17:11

Code review + testing OK

- Issue History
Date Modified Username Field Change
2015-03-30 10:12 umartirena Type defect => backport
2015-03-30 10:12 umartirena Target Version 3.0PR15Q2 => 3.0PR15Q1.3
2015-03-30 16:33 vmromanos File Added: 29454.export
2015-03-30 16:34 vmromanos Note Added: 0076149
2015-03-30 19:49 dmitry_mezentsev Tag Attached: Approved
2015-04-01 17:10 hgbot Checkin
2015-04-01 17:10 hgbot Note Added: 0076324
2015-04-01 17:10 hgbot Status scheduled => resolved
2015-04-01 17:10 hgbot Resolution open => fixed
2015-04-01 17:10 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/backports/3.0PR15Q1.3/rev/a5760416a340b3d92830651dd0c45aa56e33d0bf [^]
2015-04-01 17:11 vmromanos Review Assigned To => vmromanos
2015-04-01 17:11 vmromanos Note Added: 0076325
2015-04-01 17:11 vmromanos Status resolved => closed


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker