Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0027730
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] B. User interfaceminorhave not tried2014-10-01 19:292014-12-30 23:22
ReporterjonalegriaesarteView Statuspublic 
Assigned ToAugustoMauch 
PriorityimmediateResolutionfixedFixed in Version3.0PR15Q1
StatusclosedFix in branchFixed in SCM revisionff95c8c768e7
ProjectionnoneETAnoneTarget Version3.0PR15Q1
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Toalostale
Web browser
ModulesCore
Regression levelProduction - Confirmed Stable
Regression date2014-06-11
Regression introduced in release3.0PR14Q2.2
Regression introduced by commithttps://code.openbravo.com/erp/devel/pi/rev/b4ba48792e4850c804c42001d8f818f1e0575f81 [^]
Triggers an Emergency PackNo
Summary

0027730: Enter key at the end of the line does not work as expected in grid view

DescriptionEnter key at the end of the line does not work as expected. In MP31.X, the enter key at the end of the line in grid view created a new line in the grid. After PR14Q2.X series, it is not working anymore.
Steps To Reproduce- Sales invoice window. Create a new header
- In grid view, create a new record in the Lines tab, and in the last field of the grid (Tax), press enter. Nothing happens (tab key is working fine, it creates a new record saving the actual one).

This only happens if the last field (Tax) is not modified by the user, or if the user clicks on the field unselecting all the text before pressing enter
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
caused by defect 00268173.0PR14Q3 closedshankarb In Financial Account window, autosave is wrongly triggered while navigating with keyboard 
related to defect 0028646 closedalostale Grid view creation of prices in the Price tab of the product window is not correct 

-  Notes
(0070692)
hgbot (developer)
2014-10-03 13:47

Repository: erp/devel/pi
Changeset: 7d7b36e1e61e8c2f2749f4ff3c6107fd7215bb36
Author: Augusto Mauch <augusto.mauch <at> openbravo.com>
Date: Fri Oct 03 13:12:58 2014 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/7d7b36e1e61e8c2f2749f4ff3c6107fd7215bb36 [^]

Related with issue 27730: Adds missing js formatting

---
M modules/org.openbravo.userinterface.smartclient/web/org.openbravo.userinterface.smartclient/js/ob-smartclient.js
---
(0070693)
hgbot (developer)
2014-10-03 13:47

Repository: erp/devel/pi
Changeset: ff95c8c768e799db4f7d8ea1d43edd1edf793beb
Author: Augusto Mauch <augusto.mauch <at> openbravo.com>
Date: Fri Oct 03 13:46:05 2014 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/ff95c8c768e799db4f7d8ea1d43edd1edf793beb [^]

Fixes issue 27730: Pressing enter in the last editable grid line creates record

The fix [1] of this issue [2] added a check to prevent creating a new line when, in an editable grid, a value was selected from a picklist by pressing the Enter key. The fix consisted in overwriting the ha
ndleKeyPress function of TextItem. The problem was that because of the way the fix was implemented, the new function was invoked but the original implementation of TextItem.handleKeyPress was never execute
d. This missing code was causing a strange behaviour in how the EventHandler set the items that are object of the events, and as a result of this the current issue was being reproducible.

To fix this, the issue [2] has been implemented differently. The root cause of that issue is that the keyDown event was done in a formitem (the selector) and the keyPress on another item (in this case the
description column). When this was detected, the call the handleKeyPress was intercepted to prevent adding a new line. Now, the interception is done in the cellEditEnd. This has two benefits:
- handleKeyPress is not overwritten, so the problems caused by the missing TextItem.handleKeyPress invocation disappear
- the interception is done in a more specific point. handleKeyPress is called constantly, but the cellEditEnd is only called when the focus leaves a grid cell.

[1] https://code.openbravo.com/erp/devel/pi/rev/b4ba48792e4850c804c42001d8f818f1e0575f81 [^]
[2] https://issues.openbravo.com/view.php?id=26817 [^]

---
M modules/org.openbravo.client.application/web/org.openbravo.client.application/js/grid/ob-view-grid.js
M modules/org.openbravo.userinterface.smartclient/web/org.openbravo.userinterface.smartclient/js/ob-smartclient.js
---
(0070723)
alostale (developer)
2014-10-06 08:58

Code reviewed.

Tested:
-Defined steps to reproduce in issue
-Issue 0026817 is still not reproducible. Tested: http://tools.openbravo.com:8891/testlink/linkto.php?tprojectPrefix=Communit&item=testcase&id=Communit-7695 [^]
(0072886)
hudsonbot (developer)
2014-12-30 23:22

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/6525fe229e06 [^]
Maturity status: Test
(0072887)
hudsonbot (developer)
2014-12-30 23:22

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/6525fe229e06 [^]
Maturity status: Test

- Issue History
Date Modified Username Field Change
2014-10-01 19:29 jonalegriaesarte New Issue
2014-10-01 19:29 jonalegriaesarte Assigned To => AugustoMauch
2014-10-01 19:29 jonalegriaesarte Modules => Core
2014-10-01 19:29 jonalegriaesarte Triggers an Emergency Pack => No
2014-10-01 19:31 jonalegriaesarte Severity major => minor
2014-10-02 12:41 AugustoMauch Steps to Reproduce Updated View Revisions
2014-10-02 14:35 AugustoMauch Regression level => Production - Confirmed Stable
2014-10-02 14:35 AugustoMauch Regression date => 2014-06-11
2014-10-02 14:35 AugustoMauch Regression introduced in release => 3.0PR14Q2.2
2014-10-02 14:35 AugustoMauch Regression introduced by commit => https://code.openbravo.com/erp/devel/pi/rev/b4ba48792e4850c804c42001d8f818f1e0575f81 [^]
2014-10-03 13:15 AugustoMauch Relationship added caused by 0026817
2014-10-03 13:46 AugustoMauch Issue Monitored: alostale
2014-10-03 13:47 AugustoMauch Review Assigned To => alostale
2014-10-03 13:47 hgbot Checkin
2014-10-03 13:47 hgbot Note Added: 0070692
2014-10-03 13:47 hgbot Checkin
2014-10-03 13:47 hgbot Note Added: 0070693
2014-10-03 13:47 hgbot Status new => resolved
2014-10-03 13:47 hgbot Resolution open => fixed
2014-10-03 13:47 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/ff95c8c768e799db4f7d8ea1d43edd1edf793beb [^]
2014-10-06 08:58 alostale Note Added: 0070723
2014-10-06 08:58 alostale Status resolved => closed
2014-10-06 08:58 alostale Fixed in Version => 3.0PR15Q1
2014-12-30 23:22 hudsonbot Checkin
2014-12-30 23:22 hudsonbot Note Added: 0072886
2014-12-30 23:22 hudsonbot Checkin
2014-12-30 23:22 hudsonbot Note Added: 0072887
2015-01-19 12:17 alostale Relationship added related to 0028646


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker