Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0026817
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] B. User interfacemajoralways2014-06-09 16:572014-06-17 15:48
ReporterplujanView Statuspublic 
Assigned Toshankarb 
PriorityimmediateResolutionfixedFixed in Version3.0PR14Q3
StatusclosedFix in branchFixed in SCM revision738d333f9c80
ProjectionnoneETAnoneTarget Version3.0PR14Q3
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product Version3.0PR14Q2SCM revision 
Review Assigned Toalostale
Web browser
ModulesCore
Regression levelProduction - QA Approved
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0026817: In Financial Account window, autosave is wrongly triggered while navigating with keyboard

DescriptionWhen editing the grid, selecting a value from the drop down list in Imported Bank Statement tab wrongly fires the autosave. See steps.
Steps To Reproduce1. Login as Openbravo user
2. Go to Financial Account window
3. Select a record and move to Bank Statement tab
4. Select a record and move to Imported Bank Statement tab.
5. Select any record and change to edit in grid mode
6. Using the keyboard type a letter and seek for a record (i.e. "a" for selecting "Alimentos y Bebidas"
7. Hit Enter to select the value. The focus move to G/L item first but autosave is fired later, ending the edition [WRONG]
8. Repeat steps 5 to 7 but hit Tab instead of Enter. It works as expected [CORRECT]
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
causes defect 00277303.0PR15Q1 closedAugustoMauch Enter key at the end of the line does not work as expected in grid view 

-  Notes
(0067851)
alostale (developer)
2014-06-10 17:00

The same issue can be reproduced in the GL Journal window in live.builds.openbravo.com
Choose pi environment
Login
Navigate to GL Journal
In an existing batch, create a new header and navigate to Line tab
In grid mode, create a new record
The focus is in the account field.
Type "1" to trigger auto-complete. Using arrow down, pick an account and press Enter to confirm selection.
Record autosaves resulting in an error
(0067914)
hgbot (developer)
2014-06-12 06:25

Repository: erp/devel/pi
Changeset: b4ba48792e4850c804c42001d8f818f1e0575f81
Author: Shankar Balachandran <shankar.balachandran <at> openbravo.com>
Date: Wed Jun 11 23:38:19 2014 +0530
URL: http://code.openbravo.com/erp/devel/pi/rev/b4ba48792e4850c804c42001d8f818f1e0575f81 [^]

Fixes Issue 26817: In Financial Account window, autosave is wrongly triggered while navigating with keyboard

handles a corner case where the event of the previous field is called for the current field,
in this case, the request is prevented

---
M modules/org.openbravo.userinterface.selector/web/org.openbravo.userinterface.selector/js/ob-formitem-fk-combo.js
---
(0067937)
hgbot (developer)
2014-06-12 11:10

Repository: erp/devel/pi
Changeset: 153d5f9b6e1bc248af464ea811b0608815016196
Author: Shankar Balachandran <shankar.balachandran <at> openbravo.com>
Date: Thu Jun 12 14:38:24 2014 +0530
URL: http://code.openbravo.com/erp/devel/pi/rev/153d5f9b6e1bc248af464ea811b0608815016196 [^]

Related to issue 0026817: Returned super method call

---
M modules/org.openbravo.userinterface.selector/web/org.openbravo.userinterface.selector/js/ob-formitem-fk-combo.js
---
(0067938)
shankarb (developer)
2014-06-12 11:10

In livebuilds, the issue is reproducible from MP29.4 in google chrome version 35.0.1916.114. But in Firefox 29.0, it is reproducible only from Q2.
(0067959)
hudsonbot (developer)
2014-06-12 16:41

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/f7e99944d00b [^]
Maturity status: Test
(0068000)
hudsonbot (developer)
2014-06-13 13:13

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/32a1b3e93024 [^]
Maturity status: Test
(0068063)
hgbot (developer)
2014-06-16 16:57

Repository: erp/devel/pi
Changeset: 6b17763435cfc729aff8b5e1578920c201b49a94
Author: Shankar Balachandran <shankar.balachandran <at> openbravo.com>
Date: Mon Jun 16 20:24:09 2014 +0530
URL: http://code.openbravo.com/erp/devel/pi/rev/6b17763435cfc729aff8b5e1578920c201b49a94 [^]

Fixes Issue 26817: In Financial Account window, autosave is wrongly triggered while navigating with keyboard

handles a corner case where the event of the previous field is called for the current field,
in this case, the request is prevented. The same fix is also applied to ob-formitem-fk-combo.js
since it will used from Q3.

---
M modules/org.openbravo.client.application/web/org.openbravo.client.application/js/form/formitem/ob-formitem-fk.js
---
(0068082)
hudsonbot (developer)
2014-06-17 03:53

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/f0a8426c68e6 [^]
Maturity status: Test
(0068085)
alostale (developer)
2014-06-17 07:57

Code reviewed + tested
(0068086)
hgbot (developer)
2014-06-17 08:26

Repository: erp/devel/pi
Changeset: 738d333f9c80fc137ef30fdb8727031fb0a8886b
Author: Asier Lostalé <asier.lostale <at> openbravo.com>
Date: Tue Jun 17 08:26:14 2014 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/738d333f9c80fc137ef30fdb8727031fb0a8886b [^]

fixed bug 26817: incorrect handling of enter event

  moved code to generic FormItem to handle this case in all scenarios

---
M modules/org.openbravo.client.application/web/org.openbravo.client.application/js/form/formitem/ob-formitem-fk.js
M modules/org.openbravo.userinterface.selector/web/org.openbravo.userinterface.selector/js/ob-formitem-fk-combo.js
M modules/org.openbravo.userinterface.smartclient/web/org.openbravo.userinterface.smartclient/js/ob-smartclient.js
---
(0068099)
hudsonbot (developer)
2014-06-17 15:48

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/bcb2db0f0a22 [^]
Maturity status: Test

- Issue History
Date Modified Username Field Change
2014-06-09 16:57 plujan New Issue
2014-06-09 16:57 plujan Assigned To => dbaz
2014-06-09 16:57 plujan Modules => Core
2014-06-09 16:57 plujan Triggers an Emergency Pack => No
2014-06-09 16:58 plujan Regression level => Production - QA Approved
2014-06-09 17:02 dbaz Assigned To dbaz => shankarb
2014-06-10 11:56 alostale Priority normal => immediate
2014-06-10 11:56 alostale Target Version => PR14Q3
2014-06-10 17:00 alostale Note Added: 0067851
2014-06-12 06:21 shankarb Review Assigned To => alostale
2014-06-12 06:21 shankarb Issue Monitored: alostale
2014-06-12 06:25 hgbot Checkin
2014-06-12 06:25 hgbot Note Added: 0067914
2014-06-12 06:25 hgbot Status new => resolved
2014-06-12 06:25 hgbot Resolution open => fixed
2014-06-12 06:25 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/b4ba48792e4850c804c42001d8f818f1e0575f81 [^]
2014-06-12 11:10 hgbot Checkin
2014-06-12 11:10 hgbot Note Added: 0067937
2014-06-12 11:10 shankarb Note Added: 0067938
2014-06-12 16:41 hudsonbot Checkin
2014-06-12 16:41 hudsonbot Note Added: 0067959
2014-06-13 13:13 hudsonbot Checkin
2014-06-13 13:13 hudsonbot Note Added: 0068000
2014-06-16 16:57 hgbot Checkin
2014-06-16 16:57 hgbot Note Added: 0068063
2014-06-16 16:57 hgbot Fixed in SCM revision http://code.openbravo.com/erp/devel/pi/rev/b4ba48792e4850c804c42001d8f818f1e0575f81 [^] => http://code.openbravo.com/erp/devel/pi/rev/6b17763435cfc729aff8b5e1578920c201b49a94 [^]
2014-06-17 03:53 hudsonbot Checkin
2014-06-17 03:53 hudsonbot Note Added: 0068082
2014-06-17 07:57 alostale Note Added: 0068085
2014-06-17 07:57 alostale Status resolved => closed
2014-06-17 07:57 alostale Fixed in Version => PR14Q3
2014-06-17 08:26 hgbot Checkin
2014-06-17 08:26 hgbot Note Added: 0068086
2014-06-17 08:26 hgbot Status closed => resolved
2014-06-17 08:26 hgbot Fixed in SCM revision http://code.openbravo.com/erp/devel/pi/rev/6b17763435cfc729aff8b5e1578920c201b49a94 [^] => http://code.openbravo.com/erp/devel/pi/rev/738d333f9c80fc137ef30fdb8727031fb0a8886b [^]
2014-06-17 08:26 alostale Status resolved => closed
2014-06-17 15:48 hudsonbot Checkin
2014-06-17 15:48 hudsonbot Note Added: 0068099
2014-10-03 13:15 AugustoMauch Relationship added causes 0027730


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker