Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0028646
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] A. Platformminoralways2015-01-16 12:042015-01-20 17:43
ReporterpsanjuanView Statuspublic 
Assigned Toalostale 
PriorityurgentResolutionfixedFixed in Version3.0PR15Q2
StatusclosedFix in branchpiFixed in SCM revisionb4f4fca525d7
ProjectionnoneETAnoneTarget Version
OSLinux 32 bitDatabaseOracleJava version1.6
OS VersionUbuntu 8.04.1Database version11.1.0.6.0Ant version1.7.0
Product VersionSCM revision 
Review Assigned ToAugustoMauch
Web browser
ModulesCore
Regression levelProduction - Confirmed Stable
Regression date2014-02-26
Regression introduced in release3.0PR14Q2
Regression introduced by commithttps://code.openbravo.com/erp/devel/pi/rev/20eb3426d990 [^]
Triggers an Emergency PackNo
Summary

0028646: Grid view creation of prices in the Price tab of the product window is not correct

DescriptionGried view creation of prices in the Price tab of the product window is not correct
Steps To ReproduceGo to product window and create a new one in Grid view. Save
Navigate to Price tab. Create a new record in Grid view. Select a price list version and enter a unit/list price.
Press down arrow key and realize that a new record is wrongly created for the same price list. This new record can not be deleted unless you close the window.

TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
related to defect 00277303.0PR15Q1 closedAugustoMauch Enter key at the end of the line does not work as expected in grid view 
related to defect 0027957 closedAugustoMauch Changing tab can cause that grid records get stuck 
caused by feature request 0025574 closeddbaz Upgrade SmartClient 10.0d 

-  Notes
(0073574)
AugustoMauch (developer)
2015-01-16 14:29

Changed to minor because:
- The record is actually saved
- No data is lost
- A very specific flow has to be followed to reproduce this issue
(0073597)
alostale (developer)
2015-01-19 12:42

fixed by changeset: https://code.openbravo.com/erp/devel/pi/rev/b4f4fca525d7 [^]

(incorrect commit message)
(0073598)
alostale (developer)
2015-01-19 12:43

tested also issues 0027957 and 0027730
(0073599)
alostale (developer)
2015-01-19 12:48

Created test case in testLink: https://testlink.openbravo.com/testlink/linkto.php?tprojectPrefix=Communit&item=testcase&id=Communit-8021 [^]
(0073652)
AugustoMauch (developer)
2015-01-20 17:43

Code reviewed and verified in pi@b4f4fca525d7

- Issue History
Date Modified Username Field Change
2015-01-16 12:04 psanjuan New Issue
2015-01-16 12:04 psanjuan Assigned To => AugustoMauch
2015-01-16 12:04 psanjuan Modules => Core
2015-01-16 12:04 psanjuan Triggers an Emergency Pack => No
2015-01-16 14:29 AugustoMauch Note Added: 0073574
2015-01-16 14:29 AugustoMauch Severity major => minor
2015-01-16 14:30 AugustoMauch Regression level => Production - Confirmed Stable
2015-01-16 14:30 AugustoMauch Regression introduced in release => 3.0PR14Q2
2015-01-19 09:35 alostale Regression date => 2014-02-26
2015-01-19 09:35 alostale Regression introduced by commit => https://code.openbravo.com/erp/devel/pi/rev/20eb3426d990 [^]
2015-01-19 09:35 alostale Steps to Reproduce Updated View Revisions
2015-01-19 09:36 alostale Relationship added caused by 0025574
2015-01-19 12:17 alostale Relationship added related to 0027730
2015-01-19 12:17 alostale Relationship added related to 0027957
2015-01-19 12:31 alostale Review Assigned To => AugustoMauch
2015-01-19 12:31 alostale Assigned To AugustoMauch => alostale
2015-01-19 12:31 alostale Summary Gried view creation of prices in the Price tab of the product window is not correct => Grid view creation of prices in the Price tab of the product window is not correct
2015-01-19 12:41 alostale Status new => scheduled
2015-01-19 12:41 alostale fix_in_branch => pi
2015-01-19 12:42 alostale Note Added: 0073597
2015-01-19 12:42 alostale Status scheduled => resolved
2015-01-19 12:42 alostale Fixed in Version => 3.0PR15Q2
2015-01-19 12:42 alostale Fixed in SCM revision => https://code.openbravo.com/erp/devel/pi/rev/b4f4fca525d7 [^]
2015-01-19 12:42 alostale Resolution open => fixed
2015-01-19 12:43 alostale Note Added: 0073598
2015-01-19 12:48 alostale Note Added: 0073599
2015-01-20 17:43 AugustoMauch Note Added: 0073652
2015-01-20 17:43 AugustoMauch Status resolved => closed


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker