Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0026571
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] Z. Othersmajoralways2014-05-16 12:292014-12-30 23:26
ReportermaiteView Statuspublic 
Assigned ToAtulOpenbravo 
PriorityimmediateResolutionfixedFixed in Version
StatusclosedFix in branchFixed in SCM revisioncbb97a88d93a
ProjectionnoneETAnoneTarget Version3.0PR14Q3
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Torafaroda
Web browser
ModulesAdvanced Payables and Receivables Mngmt
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0026571: Error when paying a "cash vat" invoice with total amount lower than related order's amount

DescriptionFollowing error is obtained "percentage: Value (128.54) is larger than the max value: 100"
Steps To Reproduce1. Define your organization as "cash vat"
2. Register Sales Order for cash vat organization and invoice terms= immediate. Ensure that "cash vat" flag is checked in sales order header
3. Add any line setting price=5 and process order
3. Register Sales Invoice using "Create Lines From" process. Edit invoice's line to set price=4 and process invoice
4. Try to pay invoice and realize that following error is raised "percentage: Value (128.54) is larger than the max value: 100"
Proposed Solutionseems that percentage validation is not being performed for total amount but line by line
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
related to defect 00274843.0PR14Q4 closedAtulOpenbravo Wrong cash vat lines when payment is automatically created and invoice's amount is higher that order's amount 
related to defect 0033508 closedmarkmm82 Cannot post a Cash VAT payment that pays more than one invoice, Process failed during execution error is shown 
causes defect 00274603.0PR14Q4 closedAtulOpenbravo Error when posting Payment/Transaction/Reconciliation referencing several cash vat invoices 
causes defect 0028956 closedvmromanos Negative Cash VAT lines created while partially paying an AP/AR Credit Memo 

-  Notes
(0067489)
hgbot (developer)
2014-05-27 18:30

Repository: erp/devel/pi
Changeset: cbb97a88d93a77eb501c229068804e7bc1cc4990
Author: Atul Gaware <atul.gaware <at> openbravo.com>
Date: Fri May 23 16:41:21 2014 +0530
URL: http://code.openbravo.com/erp/devel/pi/rev/cbb97a88d93a77eb501c229068804e7bc1cc4990 [^]

Fixes Issue 26571:Error when paying a "cash vat" invoice with total amount
lower than related order's amount

---
M src-db/database/sourcedata/AD_COLUMN.xml
M src/org/openbravo/erpCommon/utility/CashVATUtil.java
---
(0067490)
hgbot (developer)
2014-05-27 18:30

Repository: erp/devel/pi
Changeset: f5796fb5b658e22a9b1b50d0ad17369a9c609c0f
Author: Atul Gaware <atul.gaware <at> openbravo.com>
Date: Mon May 26 16:34:59 2014 +0530
URL: http://code.openbravo.com/erp/devel/pi/rev/f5796fb5b658e22a9b1b50d0ad17369a9c609c0f [^]

Related To Issue 26571:Posting of Cash Vat lines for multi line schedule line

---
M src/org/openbravo/erpCommon/ad_forms/DocFINFinAccTransaction.java
M src/org/openbravo/erpCommon/ad_forms/DocFINPayment.java
M src/org/openbravo/erpCommon/ad_forms/DocFINReconciliation.java
M src/org/openbravo/erpCommon/ad_forms/DocLineCashVATReady_PaymentTransactionReconciliation.java
---
(0067491)
hgbot (developer)
2014-05-27 18:30

Repository: erp/devel/pi
Changeset: 10b6743505d4ae2a15e957c0ca505f999752ae38
Author: Atul Gaware <atul.gaware <at> openbravo.com>
Date: Tue May 27 18:27:11 2014 +0530
URL: http://code.openbravo.com/erp/devel/pi/rev/10b6743505d4ae2a15e957c0ca505f999752ae38 [^]

Related To Issue 26571:Reactivation of Payment impact on Cash Vat lines.
Reactivate payment by any option either by Reactivate Or Reactivate
and Delete Lines it will not keep Cash Vat Lines unless the payment is
processed properly.

---
M modules/org.openbravo.advpaymentmngt/src/org/openbravo/advpaymentmngt/process/FIN_ExecutePayment.java
M modules/org.openbravo.advpaymentmngt/src/org/openbravo/advpaymentmngt/process/FIN_PaymentProcess.java
M modules/org.openbravo.advpaymentmngt/src/org/openbravo/advpaymentmngt/utility/FIN_Utility.java
---
(0067493)
rafaroda (developer)
2014-05-27 19:08

We tested the following cycles:
* For both Sales and Purchase cycles
* with one full and with multiple payments
* Posting Financial Account Transaction + Posting Payment + Posting Reconciliation
* Also tested Reverse Payment

A) INVOICE LINE PRICE = 4 < ORDER LINE = 5
* 2 Cash VAT lines created (one positive and one negative) when full payment

B) INVOICE LINE PRICE = 6 > ORDER LINE = 5

C) INVOICE LINE PRICE = 5 = ORDER LINE = 5

D) INVOICE WITHOUT AN ORDER
(0067542)
hudsonbot (developer)
2014-05-28 19:08

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/ede645e45d60 [^]
Maturity status: Test
(0067543)
hudsonbot (developer)
2014-05-28 19:08

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/ede645e45d60 [^]
Maturity status: Test
(0067544)
hudsonbot (developer)
2014-05-28 19:08

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/ede645e45d60 [^]
Maturity status: Test
(0072096)
hgbot (developer)
2014-11-28 09:33

Repository: erp/devel/pi
Changeset: 81e131e2af2c79e0bf3cfe2e2d5964ad54b4db2d
Author: Atul Gaware <atul.gaware <at> openbravo.com>
Date: Mon Nov 24 20:20:57 2014 +0530
URL: http://code.openbravo.com/erp/devel/pi/rev/81e131e2af2c79e0bf3cfe2e2d5964ad54b4db2d [^]

Fixes Issues 27820:Error when posting Payment/Transaction/Reconciliation
referencing a cash vat invoice linked to several orders

Issue is a regression due to related fix for issue 26571. Cast Vat lines
were posted as many times the no. of orders linked with cash vat invoices.
So now posting is based on the payment details so the relevant cash vat line
associated with it is posted though it is looped as many times as the no. of
orders linked.

---
M src/org/openbravo/erpCommon/ad_forms/DocFINFinAccTransaction.java
M src/org/openbravo/erpCommon/ad_forms/DocFINPayment.java
M src/org/openbravo/erpCommon/ad_forms/DocFINReconciliation.java
M src/org/openbravo/erpCommon/ad_forms/DocLineCashVATReady_PaymentTransactionReconciliation.java
---
(0073153)
hudsonbot (developer)
2014-12-30 23:26

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/6525fe229e06 [^]
Maturity status: Test

- Issue History
Date Modified Username Field Change
2014-05-16 12:29 maite New Issue
2014-05-16 12:29 maite Assigned To => jonalegriaesarte
2014-05-16 12:29 maite Modules => Advanced Payables and Receivables Mngmt
2014-05-16 12:29 maite Triggers an Emergency Pack => No
2014-05-16 12:29 maite Proposed Solution updated
2014-05-16 12:30 maite Target Version => PR14Q3
2014-05-16 12:30 maite Issue Monitored: networkb
2014-05-19 14:33 jonalegriaesarte Assigned To jonalegriaesarte => pramakrishnan
2014-05-21 10:08 maite Priority urgent => immediate
2014-05-27 18:25 maite Assigned To pramakrishnan => AtulOpenbravo
2014-05-27 18:25 maite Status new => scheduled
2014-05-27 18:25 maite fix_in_branch => pi
2014-05-27 18:28 AtulOpenbravo Review Assigned To => rafaroda
2014-05-27 18:28 AtulOpenbravo fix_in_branch pi =>
2014-05-27 18:30 hgbot Checkin
2014-05-27 18:30 hgbot Note Added: 0067489
2014-05-27 18:30 hgbot Status scheduled => resolved
2014-05-27 18:30 hgbot Resolution open => fixed
2014-05-27 18:30 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/cbb97a88d93a77eb501c229068804e7bc1cc4990 [^]
2014-05-27 18:30 hgbot Checkin
2014-05-27 18:30 hgbot Note Added: 0067490
2014-05-27 18:30 hgbot Checkin
2014-05-27 18:30 hgbot Note Added: 0067491
2014-05-27 19:08 rafaroda Note Added: 0067493
2014-05-27 19:08 rafaroda Status resolved => closed
2014-05-28 19:08 hudsonbot Checkin
2014-05-28 19:08 hudsonbot Note Added: 0067542
2014-05-28 19:08 hudsonbot Checkin
2014-05-28 19:08 hudsonbot Note Added: 0067543
2014-05-28 19:08 hudsonbot Checkin
2014-05-28 19:08 hudsonbot Note Added: 0067544
2014-08-26 09:13 maite Relationship added causes 0027460
2014-08-27 12:02 rafaroda Relationship added related to 0027484
2014-11-28 09:33 hgbot Checkin
2014-11-28 09:33 hgbot Note Added: 0072096
2014-12-30 23:26 hudsonbot Checkin
2014-12-30 23:26 hudsonbot Note Added: 0073153
2015-02-17 07:57 dmitry_mezentsev Relationship added causes 0028956
2016-07-26 11:49 aferraz Relationship added related to 0033508


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker