Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0028956
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] 09. Financial managementmajoralways2015-02-16 17:522015-02-23 05:11
ReporterpsanjuanView Statuspublic 
Assigned Tovmromanos 
PriorityurgentResolutionfixedFixed in Versionpi
StatusclosedFix in branchpiFixed in SCM revisiond6d3d6ca0aac
ProjectionnoneETAnoneTarget Version
OSLinux 32 bitDatabaseOracleJava version1.6
OS VersionUbuntu 8.04.1Database version11.1.0.6.0Ant version1.7.0
Product VersionSCM revision 
Review Assigned Toumartirena
Web browser
ModulesCore
Regression levelProduction - Confirmed Stable
Regression date2014-05-23
Regression introduced in release3.0PR14Q3
Regression introduced by commithttps://code.openbravo.com/erp/devel/pi/rev/cbb97a88d93a77eb501c229068804e7bc1cc4990 [^]
Triggers an Emergency PackNo
Summary

0028956: Negative Cash VAT lines created while partially paying an AP/AR Credit Memo

DescriptionCash VAT lines populated in negative while paying partially an AP/AR Credit Memo.
Those lines should also be positive.

In case of total payment Cash VAT lines are created positive, which is correct.

This scenario have an impact on the way those amounts are being handled on VAT Tax Form as those tax forms consider those lines must be positive.
Steps To ReproduceIn F&B España create a vendor configured as a Cash VAT vendor.
Create a purchase invoice for that vendor dated on 2015.
Add a product, Enter 20 units of that product. Make sure that the Tax Rate used is a Cash VAT tax rate.

Complete and post. Partially pay this invoice. Navigate to Tax tab, Cash VAT sub-tab and make sure that the values shown there are positive.

Create an AP Credit Memo for that vendor, dated on 2015.
Select the same product and enter 1 (positive) unit of that product. Make sure that the Tax Rate used is a Cash VAT tax rate.

Complete and post.

Partially pay this credit memo. Navigate to Tax tab, Cash VAT sub-tab and realize that the values shown there are negative. That is not correct.

Proposed SolutionWhile partially paying a credit memo that includes Cash VAT, Cash VAT lines should be positive.
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
caused by defect 00265713.0PR14Q3 closedAtulOpenbravo Openbravo ERP Error when paying a "cash vat" invoice with total amount lower than related order's amount 
blocks defect 0028966 closedvmromanos Modules Modulescript required related to issue 28956 

-  Notes
(0074553)
vmromanos (developer)
2015-02-17 13:22

Requirements:
1. Fix Core's code in charge of populating Cash VAT Info
2. Create a module script in Cash VAT module to fix wrong data
(0074554)
hgbot (developer)
2015-02-17 13:44

Repository: erp/devel/pi
Changeset: 17600da4f044972bbd8a1ccf70c7a4c2f14ef069
Author: Víctor Martínez Romanos <victor.martinez <at> openbravo.com>
Date: Mon Feb 16 18:04:56 2015 +0100
URL: http://code.openbravo.com/erp/devel/pi/rev/17600da4f044972bbd8a1ccf70c7a4c2f14ef069 [^]

Related to issue 28956: Applied Openbravo's code format

---
M src/org/openbravo/erpCommon/utility/CashVATUtil.java
---
(0074555)
hgbot (developer)
2015-02-17 13:44

Repository: erp/devel/pi
Changeset: d6d3d6ca0aaccb3fbadff29549316471e39c3a63
Author: Víctor Martínez Romanos <victor.martinez <at> openbravo.com>
Date: Tue Feb 17 13:40:24 2015 +0100
URL: http://code.openbravo.com/erp/devel/pi/rev/d6d3d6ca0aaccb3fbadff29549316471e39c3a63 [^]

Fixed bug 28956: Negative Cash VAT info when partially paying Credit Memo

When there was a partial payment in cash vat, the calculated percentage had the wrong sign (negative, when it should be possitive).
Thus the tax and taxable amounts had also the opposite sign.

The fix negates the invoice's grand total amount in case of a "reversal" document (i.e. Credit Memo), so the percentage, tax and taxable amounts are OK.

Note that the tax and taxable amount sign must honor the correspondent c_invoicetax record.
(See testlink test case: "[cashVATe180] Sales Invoice AR Credit Memo (Cash VAT). Partial Payment. Transaction account" for more info)


For fixing previous wrong data, a module script will be available in Cash VAT module 1.0.8 or higher

---
M src/org/openbravo/erpCommon/utility/CashVATUtil.java
---
(0074574)
umartirena (developer)
2015-02-17 21:22

Code Review + Testing OK
(0074772)
hudsonbot (developer)
2015-02-23 05:11

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/6856352d7235 [^]
Maturity status: Test
(0074773)
hudsonbot (developer)
2015-02-23 05:11

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/6856352d7235 [^]
Maturity status: Test

- Issue History
Date Modified Username Field Change
2015-02-16 17:52 psanjuan New Issue
2015-02-16 17:52 psanjuan Assigned To => vmromanos
2015-02-16 17:52 psanjuan Modules => Core
2015-02-16 17:52 psanjuan Regression level => Production - Confirmed Stable
2015-02-16 17:52 psanjuan Regression date => 2014-05-23
2015-02-16 17:52 psanjuan Regression introduced in release => 3.0PR14Q3
2015-02-16 17:52 psanjuan Regression introduced by commit => https://code.openbravo.com/erp/devel/pi/rev/cbb97a88d93a77eb501c229068804e7bc1cc4990 [^]
2015-02-16 17:52 psanjuan Triggers an Emergency Pack => No
2015-02-16 18:40 psanjuan Summary Negative Cash VAT lines while partially paying an AP/AR Credit Memo => Negative Cash VAT lines created while partially paying an AP/AR Credit Memo
2015-02-16 18:40 psanjuan Description Updated View Revisions
2015-02-16 18:40 psanjuan Steps to Reproduce Updated View Revisions
2015-02-16 18:40 psanjuan Proposed Solution updated
2015-02-17 07:57 dmitry_mezentsev Relationship added caused by 0026571
2015-02-17 13:22 vmromanos Status new => scheduled
2015-02-17 13:22 vmromanos Note Added: 0074553
2015-02-17 13:22 vmromanos fix_in_branch => pi
2015-02-17 13:43 vmromanos Relationship added blocks 0028966
2015-02-17 13:44 hgbot Checkin
2015-02-17 13:44 hgbot Note Added: 0074554
2015-02-17 13:44 hgbot Checkin
2015-02-17 13:45 hgbot Note Added: 0074555
2015-02-17 13:45 hgbot Status scheduled => resolved
2015-02-17 13:45 hgbot Resolution open => fixed
2015-02-17 13:45 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/d6d3d6ca0aaccb3fbadff29549316471e39c3a63 [^]
2015-02-17 21:22 umartirena Review Assigned To => umartirena
2015-02-17 21:22 umartirena Note Added: 0074574
2015-02-17 21:22 umartirena Status resolved => closed
2015-02-17 21:22 umartirena Fixed in Version => pi
2015-02-23 05:11 hudsonbot Checkin
2015-02-23 05:11 hudsonbot Note Added: 0074772
2015-02-23 05:11 hudsonbot Checkin
2015-02-23 05:11 hudsonbot Note Added: 0074773


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker