Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0027460
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] Z. Othersmajoralways2014-08-25 13:572014-10-01 15:43
ReportermaiteView Statuspublic 
Assigned ToAtulOpenbravo 
PriorityimmediateResolutionfixedFixed in Version
StatusclosedFix in branchFixed in SCM revision35648d50070b
ProjectionnoneETAnoneTarget Version3.0PR14Q4
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Torafaroda
Web browser
ModulesCore
Regression levelProduction - QA Approved
Regression date2014-05-26
Regression introduced in release3.0PR14Q3
Regression introduced by commithttps://code.openbravo.com/erp/devel/pi/rev/f5796fb5b658e22a9b1b50d0ad17369a9c609c0f [^]
Triggers an Emergency PackNo
Summary

0027460: Error when posting Payment/Transaction/Reconciliation referencing several cash vat invoices

DescriptionError when posting Payment/Transaction/Reconciliation referencing several cash vat invoices
Steps To Reproduce0. Define your organization as "cash vat"
1. Register Sales Invoice for that Organization and any Business Partner (ensure that "cash vat" flag is selected). Add any line (ensure that cash vat tax is set) and process.
2. Post Sales Invoice and verify that tax transitory account is used
3. Register Reversed Sales Invoice for same Org and BP (ensure that "cash vat" flag is selected). Add any cheaper line (ensure that cash vat tax is set) and process.
4. Post Reversed Sales Invoice and verify that tax transitory account is used
5. Register new Payment In for same Org and BP. Select both invoices and process
6. Post Payment and realize that tax amount is duplicated in accounting entry
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
caused by defect 00265713.0PR14Q3 closedAtulOpenbravo Error when paying a "cash vat" invoice with total amount lower than related order's amount 
related to defect 00278203.0PR15Q1 closedAtulOpenbravo Error when posting Payment/Transaction/Reconciliation referencing a cash vat invoice linked to several orders 
causes defect 0033354 closedvmromanos No correct Cash VAT posting for the payment in case of more than one General Ledger assigned to the Organization. 

-  Notes
(0069758)
hgbot (developer)
2014-08-26 13:09

Repository: erp/devel/pi
Changeset: 35648d50070b5bde2cbd8ff287e098d98ed0044d
Author: Atul Gaware <atul.gaware <at> openbravo.com>
Date: Tue Aug 26 00:15:39 2014 +0530
URL: http://code.openbravo.com/erp/devel/pi/rev/35648d50070b5bde2cbd8ff287e098d98ed0044d [^]

Fixes Issue 27460

---
M src/org/openbravo/erpCommon/utility/CashVATUtil.java
---
(0069761)
rafaroda (developer)
2014-08-26 14:19

Verified that now posting of Cash VAT does not duplicate accounting entry for tax amount following the steps to reproduce: see screenshots at https://drive.google.com/folderview?id=0B649lz4ZYJcHQzlSRGF5Z25PbTg&usp=sharing [^]

Also verified again the steps for testing related issue 0026571: see https://issues.openbravo.com/view.php?id=26571#c67493 [^]
(0069780)
hudsonbot (developer)
2014-08-27 06:09

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/b0e6e54d6a80 [^]
Maturity status: Test

- Issue History
Date Modified Username Field Change
2014-08-25 13:57 maite New Issue
2014-08-25 13:57 maite Assigned To => dmiguelez
2014-08-25 13:57 maite Modules => Core
2014-08-25 13:57 maite Regression level => Production - QA Approved
2014-08-25 13:57 maite Regression introduced in release => 3.0PR14Q3
2014-08-25 13:57 maite Regression introduced by commit => https://code.openbravo.com/erp/devel/pi/rev/f5796fb5b658e22a9b1b50d0ad17369a9c609c0f [^]
2014-08-25 13:57 maite Triggers an Emergency Pack => No
2014-08-25 13:57 maite Issue Monitored: networkb
2014-08-25 14:23 jonalegriaesarte Target Version => 3.0PR14Q4
2014-08-25 20:33 AtulOpenbravo Assigned To dmiguelez => AtulOpenbravo
2014-08-25 20:33 AtulOpenbravo Status new => scheduled
2014-08-25 20:33 AtulOpenbravo fix_in_branch => pi
2014-08-26 09:13 maite Relationship added caused by 0026571
2014-08-26 13:07 AtulOpenbravo Review Assigned To => rafaroda
2014-08-26 13:07 AtulOpenbravo fix_in_branch pi =>
2014-08-26 13:09 hgbot Checkin
2014-08-26 13:09 hgbot Note Added: 0069758
2014-08-26 13:09 hgbot Status scheduled => resolved
2014-08-26 13:09 hgbot Resolution open => fixed
2014-08-26 13:09 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/35648d50070b5bde2cbd8ff287e098d98ed0044d [^]
2014-08-26 14:19 rafaroda Note Added: 0069761
2014-08-26 14:19 rafaroda Status resolved => closed
2014-08-27 06:09 hudsonbot Checkin
2014-08-27 06:09 hudsonbot Note Added: 0069780
2014-10-01 15:43 plujan Regression date => 2014-05-26
2014-10-09 17:34 maite Relationship added related to 0027820
2016-06-27 11:11 vmromanos Relationship added causes 0033354


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker