Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0016841
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] B. User interfacemajorhave not tried2011-04-18 16:342011-06-06 10:58
ReporterplujanView Statuspublic 
Assigned Toshuehner 
PriorityurgentResolutionfixedFixed in Version3.0MP0
StatusclosedFix in branchFixed in SCM revision55ed8b361075
ProjectionnoneETAnoneTarget Version3.0MP0
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionpiSCM revision 
Review Assigned To
Web browser
ModulesCore
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0016841: It is possible to click New in Audit Trail

DescriptionIf I go to Audit Trial window and there is no records, I have a "no records yet Create one" message. If I click it, I can create a new record. The record is not saved thought.
Steps To Reproduce1. Go to Audit Trail window
2. If no records were found, a message appears. Click the "Create One" link
Tagscontrib
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
related to defect 0016287 closedshuehner I can click New in Audit Trial window 
related to defect 00165643.0MP0 closedshuehner In tabs where the UI pattern is "Edit only" through the contextual menu you are able either to delete or insert 
related to defect 0017440 closedguilleaer Recent list shows '*' to create new for Tabs which have UIpattern 'read only' or 'single record' 
related to defect 0017441 closedguilleaer 'No data in grid. Create One' still shown when tab is writable in general but current user/role has only readonly access 
has duplicate defect 00172543.0MP0 closedshuehner It is possible to create a record on read only tabs 
related to defect 00287613.0PR15Q2 closedinigosanchez Navigate to read only logic tab does not work an empty tab is displayed 

-  Notes
(0037836)
shuehner (administrator)
2011-05-31 17:48

Re-open on request of plujan.
(0037838)
shuehner (administrator)
2011-05-31 17:49

Updating to MP0 as the duplicate created later (and now closed) was scheduled as urgent for MP0.
(0037843)
hgbot (developer)
2011-05-31 19:02

Repository: erp/devel/pi
Changeset: 55ed8b361075464cfd69363980822942a0253834
Author: Stefan Hühner <stefan.huehner <at> openbravo.com>
Date: Tue May 31 19:02:01 2011 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/55ed8b361075464cfd69363980822942a0253834 [^]

Fixed 16841. Fixed 16287. Fixed 16564. Remove new & delete options for tabs with
UIPattern read-only or single-record. This affects 'create one' link shown on
empty grid, context menu on empty grid, context menu for grid with lines shown.

---
M modules/org.openbravo.client.application/src/org/openbravo/client/application/templates/ob-view-grid.js.ftl
M modules/org.openbravo.client.application/src/org/openbravo/client/application/window/OBViewGridComponent.java
M modules/org.openbravo.client.application/web/org.openbravo.client.application/js/grid/ob-view-grid.js
---
(0037969)
hudsonbot (developer)
2011-06-03 13:26

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/2a05e66b60ca [^]

Maturity status: Test
(0038017)
mtaal (developer)
2011-06-06 10:58

Works

- Issue History
Date Modified Username Field Change
2011-04-18 16:34 plujan New Issue
2011-04-18 16:34 plujan Assigned To => alostale
2011-04-18 16:34 plujan Modules => Core
2011-04-18 16:34 plujan Relationship added related to 0016287
2011-04-18 18:13 alostale Tag Attached: contrib
2011-04-18 18:14 alostale Target Version => 3.0
2011-04-18 18:14 alostale Status new => scheduled
2011-04-18 18:14 alostale Assigned To alostale => thirumalaik
2011-04-18 18:14 alostale fix_in_branch => pi
2011-05-17 09:15 iperdomo Priority urgent => normal
2011-05-17 14:27 alostale Relationship added related to 0016564
2011-05-23 11:33 plujan Target Version 3.0MP0 => 3.0MP1
2011-05-23 11:33 plujan fix_in_branch pi =>
2011-05-31 17:39 shuehner Assigned To thirumalaik => shuehner
2011-05-31 17:39 shuehner Relationship added related to 0017440
2011-05-31 17:42 shuehner Relationship added duplicate of 0017254
2011-05-31 17:42 shuehner Status scheduled => closed
2011-05-31 17:42 shuehner Resolution open => duplicate
2011-05-31 17:48 shuehner Note Added: 0037836
2011-05-31 17:48 shuehner Status closed => new
2011-05-31 17:48 shuehner Resolution duplicate => open
2011-05-31 17:49 shuehner Relationship replaced has duplicate 0017254
2011-05-31 17:49 shuehner Note Added: 0037838
2011-05-31 17:49 shuehner Priority normal => urgent
2011-05-31 17:49 shuehner Severity minor => major
2011-05-31 17:49 shuehner Target Version 3.0MP1 => 3.0MP0
2011-05-31 17:51 shuehner Relationship added related to 0017441
2011-05-31 19:02 hgbot Checkin
2011-05-31 19:02 hgbot Note Added: 0037843
2011-05-31 19:02 hgbot Status new => resolved
2011-05-31 19:02 hgbot Resolution open => fixed
2011-05-31 19:02 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/55ed8b361075464cfd69363980822942a0253834 [^]
2011-06-03 13:26 hudsonbot Checkin
2011-06-03 13:26 hudsonbot Note Added: 0037969
2011-06-06 10:58 mtaal Note Added: 0038017
2011-06-06 10:58 mtaal Status resolved => closed
2011-06-06 10:58 mtaal Fixed in Version => 3.0MP0
2015-02-19 10:07 inigosanchez Relationship added related to 0028761


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker