Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0028761
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] A. Platformmajoralways2015-01-26 10:012015-02-27 12:43
ReporterjecharriView Statuspublic 
Assigned Toinigosanchez 
PriorityurgentResolutionfixedFixed in Version
StatusclosedFix in branchFixed in SCM revision00eaadc3ade7
ProjectionnoneETAnoneTarget Version3.0PR15Q2
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned ToAugustoMauch
Web browserGoogle Chrome
ModulesCore
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0028761: Navigate to read only logic tab does not work an empty tab is displayed

DescriptionNavigate to read only logic tab does not work an empty tab is displayed
Steps To Reproduce-Go to ERP
-Mark the role that you are using as tab Product not editable (role -> window access -> product -> not editable)
-Go to sales order window
-Go to line and press right button and select "open on tab"
-You will be redirect to product tab but the header will be empty
-Only child tabs will have values
TagsNo tags attached.
Attached Filespng file icon empty.png [^] (110,463 bytes) 2015-01-26 10:01

- Relationships Relation Graph ] Dependency Graph ]
related to defect 00168413.0MP0 closedshuehner It is possible to click New in Audit Trail 
related to defect 0017441 closedguilleaer 'No data in grid. Create One' still shown when tab is writable in general but current user/role has only readonly access 

-  Notes
(0074641)
hgbot (developer)
2015-02-19 10:05

Repository: erp/devel/pi
Changeset: 00eaadc3ade7bdd01fbef1cd73089139c038f70e
Author: Inigo Sanchez <inigo.sanchez <at> openbravo.com>
Date: Thu Feb 19 10:03:12 2015 +0100
URL: http://code.openbravo.com/erp/devel/pi/rev/00eaadc3ade7bdd01fbef1cd73089139c038f70e [^]

Fixed issue 28761: A tab will be empty when the user role has readOnly access

The problem was that if a user role has readOnly access to a particular tab and this tab is
opened by using "open on tab", an empty tab is displayed. This problem was because there was
a invalidate cache between a request to the datasource and receipt of the answer.


The cache invalidation occurred because refreshContents() were called in "setReadOnlyMode".
This cache invalidation generated a bad behaviour for displaying the tab.

To check this, It has been obtained a trace of the functions that are invoked. Briefly, after
each call to the DataSource it must be seen as the data arrives (arrives in fetchRemoteDataReply())
 without invalidating cache. It should be noted, in the first call to DataSource we can find an
invalidateCache (main problem):

*** 2 *** Run invalidateCache() for isc_OBViewGrid_7. (ResultSet.js)
*** 1 *** Call to DataSource: sendDSRequest for isc_OBViewGrid_7. (DataSource.js)
*** 2 *** Run invalidateCache() for isc_OBViewGrid_7. (ResultSet.js)
*** 1 *** Call to DataSource: sendDSRequest for isc_OBViewGrid_7. (DataSource.js)
*** 3 *** Run fetchRemoteDataReply() for isc_OBViewGrid_7. (ResultSet.js).
It has been detected that the cache is invalidated. (ResultSet.js)
*** 3 *** Run fetchRemoteDataReply() for isc_OBViewGrid_7. (ResultSet.js)

To avoid this problem, it has been deleted method refresContent() in method setReadOnlyMode() because
it was not necessary. This action avoids the invalidation of the cache.

---
M modules/org.openbravo.client.application/web/org.openbravo.client.application/js/grid/ob-view-grid.js
---
(0074642)
inigosanchez (developer)
2015-02-19 10:06
edited on: 2015-02-19 10:12

Test related issues [16841] and [17441]:
It has been checked the issues that created and modified the setReadOnlyMode() function. It has been verified that works fine by testing with:
- User/role readOnly access to a product tab.
- Product tab UI Pattern: readOnly.
- Both.

(0074787)
hudsonbot (developer)
2015-02-23 05:11

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/6856352d7235 [^]
Maturity status: Test
(0075030)
AugustoMauch (developer)
2015-02-27 12:43

Code reviewed and verified in pi@60961105cec1

- Issue History
Date Modified Username Field Change
2015-01-26 10:01 jecharri New Issue
2015-01-26 10:01 jecharri Assigned To => AugustoMauch
2015-01-26 10:01 jecharri File Added: empty.png
2015-01-26 10:01 jecharri Web browser => Google Chrome
2015-01-26 10:01 jecharri Modules => Core
2015-01-26 10:01 jecharri Triggers an Emergency Pack => No
2015-01-26 10:12 eugeni Issue Monitored: eugeni
2015-01-29 10:12 alostale Status new => acknowledged
2015-02-05 10:42 alostale Assigned To AugustoMauch => inigosanchez
2015-02-05 10:42 alostale Status acknowledged => scheduled
2015-02-05 10:42 alostale fix_in_branch => pi
2015-02-05 11:47 dbaz Issue Monitored: dbaz
2015-02-19 10:03 inigosanchez Review Assigned To => AugustoMauch
2015-02-19 10:03 inigosanchez Web browser Google Chrome => Google Chrome
2015-02-19 10:03 inigosanchez Resolution open => fixed
2015-02-19 10:03 inigosanchez fix_in_branch pi =>
2015-02-19 10:04 inigosanchez Issue Monitored: AugustoMauch
2015-02-19 10:05 hgbot Checkin
2015-02-19 10:05 hgbot Note Added: 0074641
2015-02-19 10:05 hgbot Status scheduled => resolved
2015-02-19 10:05 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/00eaadc3ade7bdd01fbef1cd73089139c038f70e [^]
2015-02-19 10:06 inigosanchez Note Added: 0074642
2015-02-19 10:07 inigosanchez Relationship added related to 0016841
2015-02-19 10:07 inigosanchez Relationship added related to 0017441
2015-02-19 10:12 inigosanchez Note Edited: 0074642 View Revisions
2015-02-23 05:11 hudsonbot Checkin
2015-02-23 05:11 hudsonbot Note Added: 0074787
2015-02-27 12:43 AugustoMauch Note Added: 0075030
2015-02-27 12:43 AugustoMauch Status resolved => closed


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker