Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0017440
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] A. Platformmajorhave not tried2011-05-31 17:392012-04-02 06:10
ReportershuehnerView Statuspublic 
Assigned Toguilleaer 
PrioritynormalResolutionfixedFixed in Version3.0MP10
StatusclosedFix in branchpiFixed in SCM revision05fe024f0ee5
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned To
Web browser
ModulesCore
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0017440: Recent list shows '*' to create new for Tabs which have UIpattern 'read only' or 'single record'

Descriptionwhich allows the user to create new records in those tabs which is not allowed..

Examples:
- Audit Trail
- Process Monitor

Probably later saving of new records fails, but the '*' shouldn't be there in the first place.
Tagscontrib
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
related to defect 00168413.0MP0 closedshuehner It is possible to click New in Audit Trail 
related to defect 0017441 closedguilleaer 'No data in grid. Create One' still shown when tab is writable in general but current user/role has only readonly access 
related to design defect 0020057 acknowledgedplatform When the menu is being generated, the code doesn't check the defined windows access rights for the role of the current user. 
related to defect 00201453.0MP11 closedalostale Should not be possible to delete Matched Invoices records 

-  Notes
(0046462)
hgbot (developer)
2012-03-15 16:28

Repository: erp/devel/pi
Changeset: 05fe024f0ee5fac8d7754ec9fb72c3213d333ed6
Author: Guillermo Álvarez de Eulate <guillermo.alvarez <at> openbravo.com>
Date: Thu Mar 15 16:21:46 2012 +0100
URL: http://code.openbravo.com/erp/devel/pi/rev/05fe024f0ee5fac8d7754ec9fb72c3213d333ed6 [^]

Fixed issue 17440: Recent list doesn't show * when window is RO or SR.

Some parameters defined in menuItems are passed to openView function which generates the recent list

---
M modules/org.openbravo.client.application/web/org.openbravo.client.application/js/navbar/ob-application-menu.js
M modules/org.openbravo.client.application/web/org.openbravo.client.application/js/navbar/ob-quick-launch.js
M modules/org.openbravo.client.application/web/org.openbravo.client.application/js/utilities/ob-utilities.js
---
(0046471)
guilleaer (developer)
2012-03-15 17:35

Test plan:
1.Logged as F&B International Group Admin - F&B International Group
 2.1 -> Windows which are SingleRecords:
   2.1.1 -> Open window client using (menu or quick launch)
 2.2 -> Windows which are Readonly
   2.2.1 -> Open window audit trail using (menu or quick launch)
3. Close window
4. Window should appear in the recent list without *.

Note:
If your workspace shows recent items, probably they are obsolete and this fix won't work. It happens because they were saved in DB with the old mechanism (before this fix). To create a new and correct list of recent items just access to the windows by menu or quick launch, which are generated correctly. This actions will repair the recent list items.
(0046534)
guilleaer (developer)
2012-03-20 11:24

Note about this fix:

Now, when the menu is being generated, the engine doesn't check the defined access permissions for the role of the current user.

When one window is defined as writable in AD but defined as not editable (RO) for the current role the fix doesn't works. It happens because the menu is generated using only the information of AD.

https://issues.openbravo.com/view.php?id=20057 [^]
(0046692)
alostale (developer)
2012-03-23 14:34

code reviewed and verified on pi@5acb2f2f3505
(0047151)
hudsonbot (developer)
2012-04-02 06:10

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/7814864461ac [^]

Maturity status: Test

- Issue History
Date Modified Username Field Change
2011-05-31 17:39 shuehner New Issue
2011-05-31 17:39 shuehner Assigned To => alostale
2011-05-31 17:39 shuehner Modules => Core
2011-05-31 17:39 shuehner Relationship added related to 0016841
2011-06-06 13:14 alostale Tag Attached: contrib
2011-06-06 13:15 alostale Status new => scheduled
2011-06-06 13:15 alostale Assigned To alostale => thirumalaik
2011-06-06 13:15 alostale fix_in_branch => pi
2011-08-05 10:09 alostale Relationship added related to 0017441
2012-03-14 16:41 alostale Assigned To thirumalaik => guilleaer
2012-03-15 16:28 hgbot Checkin
2012-03-15 16:28 hgbot Note Added: 0046462
2012-03-15 16:28 hgbot Status scheduled => resolved
2012-03-15 16:28 hgbot Resolution open => fixed
2012-03-15 16:28 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/05fe024f0ee5fac8d7754ec9fb72c3213d333ed6 [^]
2012-03-15 17:35 guilleaer Note Added: 0046471
2012-03-20 11:24 guilleaer Note Added: 0046534
2012-03-20 11:26 guilleaer Relationship added related to 0020057
2012-03-23 14:34 alostale Note Added: 0046692
2012-03-23 14:34 alostale Status resolved => closed
2012-03-23 14:34 alostale Fixed in Version => 3.0MP10
2012-03-29 14:03 alostale Relationship added related to 0020145
2012-04-02 06:10 hudsonbot Checkin
2012-04-02 06:10 hudsonbot Note Added: 0047151


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker