Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0045681
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] A. Platformminoralways2021-01-05 15:152021-01-05 15:15
ReporteraaroncaleroView Statuspublic 
Assigned Toplatform 
PrioritynormalResolutionopenFixed in Version
StatusnewFix in branchFixed in SCM revision
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned To
Web browser
ModulesCore
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0045681: Values not updated after saving fails in a P&E grid that allows additions

DescriptionIn P&E processes that contain editable grid parameters (i.e. [Payment In] > Add Details) if a new record is added to the grid, but not all mandatory parameters are populated before clicking on Done, the new record in the grid remains in an inconsistent state until it is removed.
Even if the missing mandatory field(s) are populated after that, the P&E process will continue to fail until the (originally failing) record in the grid is replaced by a new one.
Steps To Reproduce1) Go to the [Payment In] window
2) Create a new record in the header with an amount of 20
3) Click in the "Add Details" button
4) In the "GL Items" grid parameter, click in "Add New" to add a new record and type a 20 in the 'Received in' field.
5) Click on Done and verify that the process fails as expected.
6) Edit the GL Item record and select a value in the G/L Item combo
7) Click on Done again.
The P&E process keeps failing stating that some mandatory fields have not been filled.
8) Remove the 'broken' G/L item, add a new one and populate all mandatory fields ('G/L Item' combo and 'Received in')
Click again on Done and verify that the process works.
Proposed SolutionThe issue might be related to 0040969. The function hasNewRecordWithEmptyMandatoryFields added while fixing that issue keeps returning true even when all fields have been populated
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]

-  Notes
There are no notes attached to this issue.

- Issue History
Date Modified Username Field Change
2021-01-05 15:15 aaroncalero New Issue
2021-01-05 15:15 aaroncalero Assigned To => platform
2021-01-05 15:15 aaroncalero Modules => Core
2021-01-05 15:15 aaroncalero Triggers an Emergency Pack => No


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker