Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0040969
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] A. Platformminorhave not tried2019-05-29 12:052019-05-31 09:53
ReportercaristuView Statuspublic 
Assigned Tocaristu 
PriorityhighResolutionfixedFixed in Version3.0PR19Q3
StatusclosedFix in branchFixed in SCM revisionc220c40da810
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Toalostale
Web browser
ModulesCore
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0040969: Maximum call stack size exceeded can be thrown in P&E grids that allow record addition

DescriptionA maximum call stack size exceeded error can be thrown in P&E grids that allow record addition. The error happens when selecting an already added record while a another record is being edited.

Error trace:

Uncaught RangeError: Maximum call stack size exceeded
    at _2.isc_ListGrid__changeEditCell [as $32f] (ISC_Combined.js:6067)
    at _2.isc_ListGrid_startEditing [as startEditing] (ISC_Combined.js:6066)
    at _2.isc_c_Class_invokeSuper [as invokeSuper] (ISC_Combined.js:245)
    at _2.isc_c_Class_Super [as Super] (ISC_Combined.js:237)
    at _2.startEditing (6f3a914d7fabaa1bb096c1fa3a77342f.js:1153)
    at _2.isc_ListGrid_showInlineEditor [as showInlineEditor] (ISC_Combined.js:6092)
    at _2.isc_c_Class_invokeSuper [as invokeSuper] (ISC_Combined.js:245)
    at _2.isc_c_Class_Super [as Super] (ISC_Combined.js:237)
    at _2.showInlineEditor (6f3a914d7fabaa1bb096c1fa3a77342f.js:2818)
    at _2.isc_ListGrid__startEditing [as $31u] (ISC_Combined.js:6088)
Steps To Reproduce1) Go to the [Add Payment] window
2) Create a new record in the header
3) Click in the "Add Details" button
4) In the "GL Items" grid parameter, click in "Add New" to add a new record and populate all the fields
5) Click in "Add New" again to add a second record
6) Without completing the edition of the second record, click in the record created on the first place
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
related to defect 0040723 closedcaristu Client validation not launched in Process Definition if record is not selected in a Pick and Execute without selected column 
related to defect 0036320 closedcaristu Create Lines P&E window in Purchase Order does not respond to select other record after selecting any of the record 
related to defect 0045681 closedcberner Values not updated after saving fails in a P&E grid that allows additions 

-  Notes
(0112240)
hgbot (developer)
2019-05-29 17:39

Repository: erp/devel/pi
Changeset: c220c40da810e1d762c2ef9a4a5d983bc9a3e535
Author: Carlos Aristu <carlos.aristu <at> openbravo.com>
Date: Wed May 29 17:28:40 2019 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/c220c40da810e1d762c2ef9a4a5d983bc9a3e535 [^]

fixes bug 40969: Max call stack size error in P&E grids that allow addition

  P&E grids have specific code to prevent hiding the inline editor of the grid when not all mandatory fields of a new record being added are populated. When this happens, the standard "hideInlineEditor" function of Smartclient's ListGrid is not executed, preventing the clearing of the "_editorShowing" flag. If this flag is not cleared and afterwards the "showInlineEditor" is invoked the maximum call stack size error appears because the function enters into a recursive loop.

  To fix this problem we now also prevent the execution of the "showInlineEditor" function when not all mandatory fields of a new record being added are populated. Exactly the same logic that the "hideInlineEditor" function of P&E grids already has.

---
M modules/org.openbravo.client.application/web/org.openbravo.client.application/js/process/ob-pick-and-execute-grid.js
---
(0112241)
hgbot (developer)
2019-05-29 17:41

Repository: erp/devel/pi
Changeset: 7b1f1a487277467949b25cf511e6fcb28c7d9ff2
Author: Carlos Aristu <carlos.aristu <at> openbravo.com>
Date: Wed May 29 17:41:37 2019 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/7b1f1a487277467949b25cf511e6fcb28c7d9ff2 [^]

related to bug 40969: minor code improvements

  - Remove useless assignment

---
M modules/org.openbravo.client.application/web/org.openbravo.client.application/js/process/ob-pick-and-execute-grid.js
---
(0112249)
hudsonbot (developer)
2019-05-30 04:01

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/2785551137d4 [^]
Maturity status: Test
(0112250)
hudsonbot (developer)
2019-05-30 04:01

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/2785551137d4 [^]
Maturity status: Test
(0112292)
alostale (developer)
2019-05-31 09:53

reviewed + tested

- Issue History
Date Modified Username Field Change
2019-05-29 12:05 caristu New Issue
2019-05-29 12:05 caristu Assigned To => caristu
2019-05-29 12:05 caristu Modules => Core
2019-05-29 12:05 caristu Triggers an Emergency Pack => No
2019-05-29 12:05 caristu Relationship added related to 0040723
2019-05-29 16:27 caristu Relationship added related to 0036320
2019-05-29 17:29 caristu Summary Maximum call stack size exceeded can be thrown in P&E grids that allows record addition => Maximum call stack size exceeded can be thrown in P&E grids that allow record addition
2019-05-29 17:29 caristu Description Updated View Revisions
2019-05-29 17:39 hgbot Checkin
2019-05-29 17:39 hgbot Note Added: 0112240
2019-05-29 17:39 hgbot Status new => resolved
2019-05-29 17:39 hgbot Resolution open => fixed
2019-05-29 17:39 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/c220c40da810e1d762c2ef9a4a5d983bc9a3e535 [^]
2019-05-29 17:39 caristu Review Assigned To => alostale
2019-05-29 17:41 hgbot Checkin
2019-05-29 17:41 hgbot Note Added: 0112241
2019-05-30 04:01 hudsonbot Checkin
2019-05-30 04:01 hudsonbot Note Added: 0112249
2019-05-30 04:01 hudsonbot Checkin
2019-05-30 04:01 hudsonbot Note Added: 0112250
2019-05-31 09:53 alostale Note Added: 0112292
2019-05-31 09:53 alostale Status resolved => closed
2019-05-31 09:53 alostale Fixed in Version => 3.0PR19Q3
2021-03-01 09:50 cberner Relationship added related to 0045681


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker