Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0040723
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] A. Platformmajorhave not tried2019-04-30 13:382019-05-31 09:50
ReporteraferrazView Statuspublic 
Assigned Tocaristu 
PrioritynormalResolutionfixedFixed in Version3.0PR19Q3
StatusclosedFix in branchFixed in SCM revision268662168c37
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Toalostale
Web browser
ModulesCore
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0040723: Client validation not launched in Process Definition if record is not selected in a Pick and Execute without selected column

DescriptionClient validation not launched in Process Definition if record is not selected in a Pick and Execute without selected column
Steps To Reproduce- As System Admin, check GL Item tab in APRM GL Item window has Show Select Column = false.
- As F&B Admin, create a new Payment In
- Click on Add Details
- Set Actual Payment = 2.00
- Add a new record in GL Items pick and execute and select it:
  G/L Item (mandatory): empty
  Business Partner: empty
  Project: empty
  Received In: 2.00
  Paid Out: 0.00-
- Click on Done
- Realize client validation is not launched
- Repeat above steps but selecting the record in the pick and execute and realize client validation is launched
Proposed Solutionvalidators function in ob-formitem-pickeditgrid.js should be launched for every record if Pick and Execute has Show Select Column = false.
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
related to defect 0040721 closedcaristu Mandatory field in pick and execute not correctly checked 
related to defect 0040969 closedcaristu Maximum call stack size exceeded can be thrown in P&E grids that allow record addition 

-  Notes
(0112231)
hgbot (developer)
2019-05-29 16:24

Repository: erp/devel/pi
Changeset: 268662168c3708b48b513bf1d8e1c2786e286d59
Author: Carlos Aristu <carlos.aristu <at> openbravo.com>
Date: Wed May 29 13:56:33 2019 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/268662168c3708b48b513bf1d8e1c2786e286d59 [^]

fixes bug 40723: Client validation skipped in P&E grids without select column

  The client validations done to ensure that mandatory fields in a P&E grid are populated before executing a process were not being executed for those grids that does not allow selection.

  This is because validations were done just for the selected records of the P&E grid.

  Now we validate all the records in case the P&E grid does not allow selection.

---
M modules/org.openbravo.client.application/web/org.openbravo.client.application/js/form/formitem/ob-formitem-pickeditgrid.js
---
(0112247)
hudsonbot (developer)
2019-05-30 04:01

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/2785551137d4 [^]
Maturity status: Test
(0112291)
alostale (developer)
2019-05-31 09:50

reviewed + tested

- Issue History
Date Modified Username Field Change
2019-04-30 13:38 aferraz New Issue
2019-04-30 13:38 aferraz Assigned To => Retail
2019-04-30 13:38 aferraz Modules => Core
2019-04-30 13:38 aferraz Triggers an Emergency Pack => No
2019-04-30 13:38 aferraz Relationship added related to 0040721
2019-05-28 19:06 caristu Assigned To Retail => caristu
2019-05-29 12:05 caristu Relationship added related to 0040969
2019-05-29 16:24 hgbot Checkin
2019-05-29 16:24 hgbot Note Added: 0112231
2019-05-29 16:24 hgbot Status new => resolved
2019-05-29 16:24 hgbot Resolution open => fixed
2019-05-29 16:24 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/268662168c3708b48b513bf1d8e1c2786e286d59 [^]
2019-05-29 16:25 caristu Review Assigned To => alostale
2019-05-30 04:01 hudsonbot Checkin
2019-05-30 04:01 hudsonbot Note Added: 0112247
2019-05-31 09:50 alostale Note Added: 0112291
2019-05-31 09:50 alostale Status resolved => closed
2019-05-31 09:50 alostale Fixed in Version => 3.0PR19Q3


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker