Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0040721
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] A. Platformmajorhave not tried2019-04-30 13:262019-05-31 09:43
ReporteraferrazView Statuspublic 
Assigned Tocaristu 
PrioritynormalResolutionfixedFixed in Version3.0PR19Q3
StatusclosedFix in branchFixed in SCM revisionea3c09846afd
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Toalostale
Web browser
ModulesCore
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0040721: Mandatory field in pick and execute not correctly checked

DescriptionMandatory field in pick and execute not correctly checked
Steps To Reproduce- Create a Process Definition with a Pick and Execute parameter including a Date mandatory field
OR
- Use Add Special Schedule process definition in Schedule window included in: https://code.openbravo.com/erp/pmods-branches/org.openbravo.retail.config-crosspayment [^]
- Select a record in the pick and execute leaving the mandatory date field empty
- Click on Done
- Realize no error is shown
Proposed SolutionFollowing line in ob-formitem-pickeditgrid.js seems to be wrong:

if (record[fields[j].name] === null || record[fields[j].name] === '' || record[fields[j] === undef]) {
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
related to defect 0040723 closedcaristu Client validation not launched in Process Definition if record is not selected in a Pick and Execute without selected column 
related to defect 00267223.0PR14Q3 closedguillermogil P&E after selecting all the system does not check if the mandatory fields are set 

-  Notes
(0112214)
hgbot (developer)
2019-05-28 18:55

Repository: erp/devel/pi
Changeset: ea3c09846afd8af4f7b37583ae13de950cbf149d
Author: Carlos Aristu <carlos.aristu <at> openbravo.com>
Date: Tue May 28 18:48:54 2019 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/ea3c09846afd8af4f7b37583ae13de950cbf149d [^]

fixes bug 40721: Mandatory field in P&E grids not correctly checked

  There was a wrong condition when checking if the mandatory fields in a record of a P&E grid. Fixing it together with minor improvements:

  - Deleted wrong condition to check undefined value: "record[fields[j] === undef]"
  - Use "!record[fields[j].name]" expression to check if the value is null or undefined
  - Avoid unnecessary nested "if"
  - Use "!lineNumbers" instead of "lineNumbers === undef"

---
M modules/org.openbravo.client.application/web/org.openbravo.client.application/js/form/formitem/ob-formitem-pickeditgrid.js
---
(0112219)
hudsonbot (developer)
2019-05-29 03:20

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/f61d63883754 [^]
Maturity status: Test
(0112221)
hgbot (developer)
2019-05-29 10:03

Repository: erp/devel/pi
Changeset: 8671a3b792fffce9d045d8a8f4f34f701e15ba5c
Author: Carlos Aristu <carlos.aristu <at> openbravo.com>
Date: Wed May 29 10:00:12 2019 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/8671a3b792fffce9d045d8a8f4f34f701e15ba5c [^]

related to bug 40721: fix null/undefined check

  Replaced "!record[fields[j].name]" with direct checking of null/undefined values. This is because if having a numeric field populated with a value of 0, the field was wrongly detected as empty.

---
M modules/org.openbravo.client.application/web/org.openbravo.client.application/js/form/formitem/ob-formitem-pickeditgrid.js
---
(0112244)
hudsonbot (developer)
2019-05-29 20:49

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/0705db562021 [^]
Maturity status: Test
(0112290)
alostale (developer)
2019-05-31 09:43

reviewed + tested

- Issue History
Date Modified Username Field Change
2019-04-30 13:26 aferraz New Issue
2019-04-30 13:26 aferraz Assigned To => platform
2019-04-30 13:26 aferraz Modules => Core
2019-04-30 13:26 aferraz Triggers an Emergency Pack => No
2019-04-30 13:38 aferraz Relationship added related to 0040723
2019-04-30 13:42 aferraz Proposed Solution updated
2019-05-07 18:44 caristu Relationship added related to 0026722
2019-05-28 18:55 hgbot Checkin
2019-05-28 18:55 hgbot Note Added: 0112214
2019-05-28 18:55 hgbot Status new => resolved
2019-05-28 18:55 hgbot Resolution open => fixed
2019-05-28 18:55 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/ea3c09846afd8af4f7b37583ae13de950cbf149d [^]
2019-05-28 18:56 caristu Assigned To platform => caristu
2019-05-28 18:56 caristu Review Assigned To => alostale
2019-05-29 03:20 hudsonbot Checkin
2019-05-29 03:20 hudsonbot Note Added: 0112219
2019-05-29 10:03 hgbot Checkin
2019-05-29 10:03 hgbot Note Added: 0112221
2019-05-29 20:49 hudsonbot Checkin
2019-05-29 20:49 hudsonbot Note Added: 0112244
2019-05-31 09:43 alostale Note Added: 0112290
2019-05-31 09:43 alostale Status resolved => closed
2019-05-31 09:43 alostale Fixed in Version => 3.0PR19Q3


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker