Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0044937
TypeCategorySeverityReproducibilityDate SubmittedLast Update
feature request[Openbravo ERP] A. Platformminorhave not tried2020-08-31 13:322020-09-16 11:01
ReportercaristuView Statuspublic 
Assigned Tocaristu 
PriorityhighResolutionfixedFixed in VersionPR20Q4
StatusclosedFix in branchFixed in SCM revision1cc1f00fa6db
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Toalostale
Web browser
ModulesCore
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0044937: Update fileUpload library

DescriptionCurrent fileUpload library used in core (1.2.2) should be updated to the latest version available (1.4)[1]

[1] https://commons.apache.org/proper/commons-fileupload/ [^]
Steps To Reproduce.
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
depends on backport 0045064PR20Q3.1 closedcaristu Update fileUpload library 
depends on backport 0045065PR20Q2.2 closedcaristu Update fileUpload library 
blocks defect 0044973 closedplatform Stack Update for PR20Q4 release 

-  Notes
(0122501)
hgbot (developer)
2020-09-01 10:19

Merge Request created: https://gitlab.com/openbravo/product/openbravo/-/merge_requests/132 [^]
(0122506)
hgbot (developer)
2020-09-01 13:03

Merge Request created: https://gitlab.com/openbravo/product/pmods/org.openbravo.retail.copystore/-/merge_requests/3 [^]
(0122736)
hgbot (developer)
2020-09-07 11:43

Directly closing issue as related merge request is already approved.

Repository: https://gitlab.com/openbravo/product/openbravo [^]
Changeset: 1cc1f00fa6db5780ba858122a87f1485d8d402e3
Author: Carlos Aristu <carlos.aristu@openbravo.com>
Date: 2020-09-07T11:34:22+02:00
URL: https://gitlab.com/openbravo/product/openbravo/-/commit/1cc1f00fa6db5780ba858122a87f1485d8d402e3 [^]

fixes BUG-44937: Update Apache Commons FileUpload

  Update Apache Commons FileUpload library to version 1.4. Together with
the library upgrade some minor changes are required:

  - FileItem class is no longer serializable[1]. For this reason with the
commons-fileupload update to version 1.4 we are no longer calling
"setSessionObject(String attribute, Serializable value)" with FileItem
as second argument but "setSessionObject(String attribute, Object value)"
which is deprecated.

  The problem is that with this change the session is no longer serializable
after setting into it a FileItem object. For the moment no additional
actions are going to be applied as this is only happening in
ModuleManagement window. So we are just adding a comment and the
SuppressWarnings annotation.

  - Removed unnecessary @SuppressWarnings("unchecked"). The
ServletFileUpload.parseRequest method does no longer require it as now
it is returning List<FileItem> instead of List.

  - Applied some minor code cleanup: removed commented-out code and use
a logger to log the exception.

[1] https://issues.apache.org/jira/browse/FILEUPLOAD-279 [^]

---
A lib/runtime/commons-fileupload-1.4.jar
M legal/Licensing.txt
M src-core/.classpath
M src-core/src/org/openbravo/base/VariablesBase.java
M src/org/openbravo/erpCommon/ad_forms/ModuleManagement.java
R lib/runtime/commons-fileupload-1.2.2.jar
---
(0122737)
hgbot (developer)
2020-09-07 11:43

Merge request merged: https://gitlab.com/openbravo/product/openbravo/-/merge_requests/132 [^]
(0122739)
hgbot (developer)
2020-09-07 11:47

Merge request merged: https://gitlab.com/openbravo/product/pmods/org.openbravo.retail.copystore/-/merge_requests/3 [^]
(0122740)
hgbot (developer)
2020-09-07 11:47

Repository: https://gitlab.com/openbravo/product/pmods/org.openbravo.retail.copystore [^]
Changeset: 77801f2287cea21c5200bedb3df8d7c0a1afd044
Author: Carlos Aristu <carlos.aristu@openbravo.com>
Date: 2020-09-01T13:01:27+02:00
URL: https://gitlab.com/openbravo/product/pmods/org.openbravo.retail.copystore/-/commit/77801f2287cea21c5200bedb3df8d7c0a1afd044 [^]

related to BUG-44937: Unnecessary @SuppressWarnings("unchecked")

---
M src/org/openbravo/retail/copystore/process/CopyBaseActionHandler.java
---
(0122741)
hgbot (developer)
2020-09-07 11:50

Repository: https://gitlab.com/openbravo/tools/platform/dependencies [^]
Changeset: dc56cff553d68109014dc9a8f0fa2db906314aa3
Author: Carlos Aristu <carlos.aristu@openbravo.com>
Date: 2020-09-07T11:50:19+02:00
URL: https://gitlab.com/openbravo/tools/platform/dependencies/-/commit/dc56cff553d68109014dc9a8f0fa2db906314aa3 [^]

ISSUE-44937: update fileupload to 1.4

---
M build.gradle
---
(0123097)
caristu (developer)
2020-09-16 10:58

Reopened to schedule backports

- Issue History
Date Modified Username Field Change
2020-08-31 13:32 caristu New Issue
2020-08-31 13:32 caristu Assigned To => platform
2020-08-31 13:32 caristu Modules => Core
2020-08-31 13:32 caristu Triggers an Emergency Pack => No
2020-08-31 13:32 caristu Assigned To platform => caristu
2020-08-31 13:32 caristu Description Updated View Revisions
2020-08-31 13:33 caristu Description Updated View Revisions
2020-09-01 10:19 hgbot Note Added: 0122501
2020-09-01 13:03 hgbot Note Added: 0122506
2020-09-02 14:51 shuehner Issue Monitored: shuehner
2020-09-03 09:52 caristu Relationship added blocks 0044973
2020-09-07 11:43 hgbot Resolution open => fixed
2020-09-07 11:43 hgbot Status new => closed
2020-09-07 11:43 hgbot Fixed in Version => PR20Q4
2020-09-07 11:43 hgbot Note Added: 0122736
2020-09-07 11:43 hgbot Note Added: 0122737
2020-09-07 11:47 hgbot Note Added: 0122739
2020-09-07 11:47 hgbot Note Added: 0122740
2020-09-07 11:50 hgbot Note Added: 0122741
2020-09-16 10:58 caristu Note Added: 0123097
2020-09-16 10:58 caristu Status closed => new
2020-09-16 10:58 caristu Resolution fixed => open
2020-09-16 10:58 caristu Fixed in Version PR20Q4 =>
2020-09-16 11:01 caristu Status new => scheduled
2020-09-16 11:01 caristu Status scheduled => resolved
2020-09-16 11:01 caristu Fixed in Version => PR20Q4
2020-09-16 11:01 caristu Fixed in SCM revision => 1cc1f00fa6db5780ba858122a87f1485d8d402e3
2020-09-16 11:01 caristu Resolution open => fixed
2020-09-16 11:01 caristu Review Assigned To => alostale
2020-09-16 11:01 caristu Status resolved => closed


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker