Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0042153
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] A. Platformminorhave not tried2019-10-30 14:042019-12-12 23:01
ReporterALopeteguiView Statuspublic 
Assigned Toalostale 
PriorityimmediateResolutionfixedFixed in Version3.0PR20Q1
StatusclosedFix in branchFixed in SCM revisionb67ca267208b
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned ToAugustoMauch
Web browser
ModulesCore
Regression levelProduction - Confirmed Stable
Regression date2018-07-24
Regression introduced in release3.0PR18Q4
Regression introduced by commithttp://code.openbravo.com/erp/devel/pi/rev/95dcfa93d706654e1fbddfc3966bec7280081ac1 [^]
Triggers an Emergency PackNo
Summary

0042153: Grid timeout returns unclear message in the backoffice

DescriptionThe grid timeout returns unclear message to the user:

org.hibernate.exception.GenericJDBCException: could not extract ResultSet
Steps To ReproduceDefine low value to db.queryTimeout.grid in Openbravo.properties.

Open a window in the backend and filter the window to provoke a timeout.

The grid shows the unclear message.
Proposed SolutionHandle the hibernate exception to show better message to the user.
TagsNo tags attached.
Attached Filesjpg file icon Message.jpg [^] (30,574 bytes) 2019-10-30 14:04


 file icon gridTiemoutlog [^] (12,718 bytes) 2019-10-30 14:05 [Show Content]

- Relationships Relation Graph ] Dependency Graph ]
related to defect 0035268 closedjarmendariz Request timeout message is not handled properly in the UI 
depends on backport 00421613.0PR19Q4 closedalostale Grid timeout returns unclear message in the backoffice 
depends on backport 00421623.0PR19Q3.2 closedalostale Grid timeout returns unclear message in the backoffice 
depends on backport 00421633.0PR19Q2.4 closedalostale Grid timeout returns unclear message in the backoffice 
caused by feature request 0037064 closedcaristu upgrade hibernate 

-  Notes
(0115398)
hgbot (developer)
2019-11-05 09:01

Repository: erp/devel/pi
Changeset: b67ca267208bac298155eeae1f9c862c8ac6548a
Author: Asier Lostalé <asier.lostale <at> openbravo.com>
Date: Thu Oct 31 09:05:28 2019 +0100
URL: http://code.openbravo.com/erp/devel/pi/rev/b67ca267208bac298155eeae1f9c862c8ac6548a [^]

fixed bug 42153: grid timeout returns unclear message

When a query timeout occurs fetching grid data, the message displayed in
UI is not user friendly.

This is caused by different exception thrown after Hibernate upgrade.

---
M modules/org.openbravo.service.json/src/org/openbravo/service/json/JsonUtils.java
---
(0115416)
AugustoMauch (developer)
2019-11-05 15:43

Code reviewed and verified
(0116271)
hudsonbot (developer)
2019-12-12 23:01

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/954d2b7a66fb [^]
Maturity status: Test

- Issue History
Date Modified Username Field Change
2019-10-30 14:04 ALopetegui New Issue
2019-10-30 14:04 ALopetegui Assigned To => platform
2019-10-30 14:04 ALopetegui File Added: Message.jpg
2019-10-30 14:04 ALopetegui Modules => Core
2019-10-30 14:04 ALopetegui Regression level => Production - Confirmed Stable
2019-10-30 14:04 ALopetegui Regression date => 2019-01-01
2019-10-30 14:04 ALopetegui Regression introduced in release => 3.0PR19Q1
2019-10-30 14:04 ALopetegui Triggers an Emergency Pack => No
2019-10-30 14:05 ALopetegui File Added: gridTiemoutlog
2019-10-31 08:00 alostale Relationship added related to 0035268
2019-10-31 08:45 alostale Assigned To platform => alostale
2019-10-31 09:08 alostale Relationship added caused by 0037064
2019-10-31 09:10 alostale Regression date 2019-01-01 => 2018-07-24
2019-10-31 09:10 alostale Regression introduced in release 3.0PR19Q1 => 3.0PR18Q4
2019-10-31 09:10 alostale Regression introduced by commit => http://code.openbravo.com/erp/devel/pi/rev/95dcfa93d706654e1fbddfc3966bec7280081ac1 [^]
2019-10-31 09:10 alostale Priority normal => immediate
2019-10-31 09:10 alostale Summary Grid timeout returns unclear message in the backend => Grid timeout returns unclear message in the backoffice
2019-10-31 09:10 alostale Review Assigned To => AugustoMauch
2019-10-31 09:11 alostale Status new => scheduled
2019-11-05 09:01 hgbot Checkin
2019-11-05 09:01 hgbot Note Added: 0115398
2019-11-05 09:01 hgbot Status scheduled => resolved
2019-11-05 09:01 hgbot Resolution open => fixed
2019-11-05 09:01 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/b67ca267208bac298155eeae1f9c862c8ac6548a [^]
2019-11-05 15:43 AugustoMauch Note Added: 0115416
2019-11-05 15:43 AugustoMauch Status resolved => closed
2019-11-05 15:43 AugustoMauch Fixed in Version => 3.0PR20Q1
2019-12-12 23:01 hudsonbot Checkin
2019-12-12 23:01 hudsonbot Note Added: 0116271


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker