Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0042161
TypeCategorySeverityReproducibilityDate SubmittedLast Update
backport[Openbravo ERP] A. Platformminorhave not tried2019-10-30 14:042019-11-05 10:08
ReporterALopeteguiView Statuspublic 
Assigned Toalostale 
PriorityimmediateResolutionfixedFixed in Version3.0PR19Q4
StatusclosedFix in branchFixed in SCM revision1fb0e69076ad
ProjectionnoneETAnoneTarget Version3.0PR19Q4
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned ToAugustoMauch
Web browser
ModulesCore
Regression levelProduction - Confirmed Stable
Regression date2018-07-24
Regression introduced in release3.0PR18Q4
Regression introduced by commithttp://code.openbravo.com/erp/devel/pi/rev/95dcfa93d706654e1fbddfc3966bec7280081ac1 [^]
Triggers an Emergency PackNo
Summary

0042161: Grid timeout returns unclear message in the backoffice

DescriptionThe grid timeout returns unclear message to the user:

org.hibernate.exception.GenericJDBCException: could not extract ResultSet
Steps To ReproduceDefine low value to db.queryTimeout.grid in Openbravo.properties.

Open a window in the backend and filter the window to provoke a timeout.

The grid shows the unclear message.
Proposed SolutionHandle the hibernate exception to show better message to the user.
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
blocks defect 0042153 closedalostale Grid timeout returns unclear message in the backoffice 

-  Notes
(0115401)
hgbot (developer)
2019-11-05 09:21

Repository: erp/backports/3.0PR19Q4
Changeset: 1fb0e69076add0d20c59cac83407c40f49ecaf3a
Author: Asier Lostalé <asier.lostale <at> openbravo.com>
Date: Thu Oct 31 09:05:28 2019 +0100
URL: http://code.openbravo.com/erp/backports/3.0PR19Q4/rev/1fb0e69076add0d20c59cac83407c40f49ecaf3a [^]

fixed bug 42161: grid timeout returns unclear message

When a query timeout occurs fetching grid data, the message displayed in
UI is not user friendly.

This is caused by different exception thrown after Hibernate upgrade.

---
M modules/org.openbravo.service.json/src/org/openbravo/service/json/JsonUtils.java
---
(0115404)
AugustoMauch (developer)
2019-11-05 10:08

Code reviewed and verified

- Issue History
Date Modified Username Field Change
2019-10-31 09:11 alostale Type defect => backport
2019-10-31 09:11 alostale Target Version => 3.0PR19Q4
2019-11-05 09:21 hgbot Checkin
2019-11-05 09:21 hgbot Note Added: 0115401
2019-11-05 09:21 hgbot Status scheduled => resolved
2019-11-05 09:21 hgbot Resolution open => fixed
2019-11-05 09:21 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/backports/3.0PR19Q4/rev/1fb0e69076add0d20c59cac83407c40f49ecaf3a [^]
2019-11-05 10:08 AugustoMauch Note Added: 0115404
2019-11-05 10:08 AugustoMauch Status resolved => closed
2019-11-05 10:08 AugustoMauch Fixed in Version => 3.0PR19Q4


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker