Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0042162
TypeCategorySeverityReproducibilityDate SubmittedLast Update
backport[Openbravo ERP] A. Platformminorhave not tried2019-10-30 14:042019-11-05 10:27
ReporterALopeteguiView Statuspublic 
Assigned Toalostale 
PriorityimmediateResolutionfixedFixed in Version3.0PR19Q3.2
StatusclosedFix in branchFixed in SCM revision23a72ef4e19b
ProjectionnoneETAnoneTarget Version3.0PR19Q3.2
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned ToAugustoMauch
Web browser
ModulesCore
Regression levelProduction - Confirmed Stable
Regression date2018-07-24
Regression introduced in release3.0PR18Q4
Regression introduced by commithttp://code.openbravo.com/erp/devel/pi/rev/95dcfa93d706654e1fbddfc3966bec7280081ac1 [^]
Triggers an Emergency PackNo
Summary

0042162: Grid timeout returns unclear message in the backoffice

DescriptionThe grid timeout returns unclear message to the user:

org.hibernate.exception.GenericJDBCException: could not extract ResultSet
Steps To ReproduceDefine low value to db.queryTimeout.grid in Openbravo.properties.

Open a window in the backend and filter the window to provoke a timeout.

The grid shows the unclear message.
Proposed SolutionHandle the hibernate exception to show better message to the user.
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
blocks defect 0042153 closedalostale Grid timeout returns unclear message in the backoffice 

-  Notes
(0115399)
hgbot (developer)
2019-11-05 09:13

Repository: erp/backports/3.0PR19Q3.2
Changeset: 23a72ef4e19bfb5b37556112664dcdcb650bafad
Author: Asier Lostalé <asier.lostale <at> openbravo.com>
Date: Thu Oct 31 09:05:28 2019 +0100
URL: http://code.openbravo.com/erp/backports/3.0PR19Q3.2/rev/23a72ef4e19bfb5b37556112664dcdcb650bafad [^]

fixed bug 42162: grid timeout returns unclear message

When a query timeout occurs fetching grid data, the message displayed in
UI is not user friendly.

This is caused by different exception thrown after Hibernate upgrade.

---
M modules/org.openbravo.service.json/src/org/openbravo/service/json/JsonUtils.java
---
(0115408)
AugustoMauch (developer)
2019-11-05 10:27

Code reviewed and verified

- Issue History
Date Modified Username Field Change
2019-10-31 09:11 alostale Type defect => backport
2019-10-31 09:11 alostale Target Version => 3.0PR19Q3.2
2019-11-05 09:13 hgbot Checkin
2019-11-05 09:13 hgbot Note Added: 0115399
2019-11-05 09:13 hgbot Status scheduled => resolved
2019-11-05 09:13 hgbot Resolution open => fixed
2019-11-05 09:13 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/backports/3.0PR19Q3.2/rev/23a72ef4e19bfb5b37556112664dcdcb650bafad [^]
2019-11-05 10:27 AugustoMauch Note Added: 0115408
2019-11-05 10:27 AugustoMauch Status resolved => closed
2019-11-05 10:27 AugustoMauch Fixed in Version => 3.0PR19Q3.2


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker