Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0041133
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] 07. Sales managementmajorhave not tried2019-06-20 13:142019-08-22 11:29
ReporteraferrazView Statuspublic 
Assigned Tononofrancisco 
PrioritynormalResolutionfixedFixed in Version
StatusclosedFix in branchFixed in SCM revision78b5dfcfa2eb
ProjectionnoneETAnoneTarget Version3.0PR19Q3
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned ToSandrahuguet
Web browser
ModulesCore
Regression levelProduction - QA Approved
Regression date2019-02-28
Regression introduced in release3.0PR19Q2
Regression introduced by commithttps://code.openbravo.com/erp/devel/pi/rev/aed4d4a47cd18723828c141de4ab3e43b40c161d [^]
Triggers an Emergency PackNo
Summary

0041133: Sales Representative selector doesn't filter by natural tree anymore

DescriptionAfter allowing cross organization reference in some SalesRep_ID columns, Sales Representative selector doesn't filter by natural tree anymore.
Steps To ReproduceUsing F&B group admin role:
- Create a new Sales Order
- Select F&B España - Región Norte organization
- Click on Sales Representative selector
Check Sales Representatives from USA are displayed.
Only Sales Representatives from Spain should be displayed.
Proposed SolutionAdd a validation to filter by natural tree organizations in following columns:
C_Order.SalesRep_ID
M_InOut.SalesRep_ID
C_Invoice.SalesRep_ID
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
depends on backport 00411373.0PR19Q2.1 closednonofrancisco Openbravo ERP Sales Representative selector doesn't filter by natural tree anymore 
caused by feature request 0040257RR19Q2 closedaferraz Retail Modules Cross Store Payments & Returns project 
related to defect 00411323.0PR19Q3 closednonofrancisco Openbravo ERP Business Partner selector doesn't filter by natural tree anymore 
related to feature request 0041135 newplatform Openbravo ERP Add the ability to filter by natural tree in selectors based on columns allowing cross org reference 

-  Notes
(0112925)
nonofrancisco (developer)
2019-06-20 20:24

Test Plan

As Openbravo / F&B International Group Admin:

Create a new Sales Order
  Organization: F&B España - Región Norte
  Click on Sales Representative selector
Verify just Sales Representatives from España are shown (Javier Martin and Juan López)
  Change Orgaization to F&B US East Coast
Verify just Sales Representatives from USA are shown (John Smith)
(0113041)
hgbot (developer)
2019-06-26 17:34

Repository: erp/devel/pi
Changeset: 78b5dfcfa2ebe9670eeaa67f7b383f85f2712711
Author: Nono Carballo <nonofce <at> gmail.com>
Date: Mon Jun 24 10:08:08 2019 -0400
URL: http://code.openbravo.com/erp/devel/pi/rev/78b5dfcfa2ebe9670eeaa67f7b383f85f2712711 [^]

Fixes issue 41133: Filters AD_User by natural tree organization

A new validation rule was added to filters AD_User by natural tree organization.
The new rule was applied to columns C_Order.SalesRep_ID, M_InOut.SalesRep_ID
and C_Invoice.SalesRep_ID.

Test class was updated.

---
M src-db/database/sourcedata/AD_COLUMN.xml
M src-db/database/sourcedata/AD_VAL_RULE.xml
M src-test/src/org/openbravo/test/security/CrossOrganizationUI.java
---
(0113044)
Sandrahuguet (developer)
2019-06-26 17:45

code review + testing ok
(0113085)
hudsonbot (developer)
2019-06-28 00:15

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/a42da0b1e061 [^]
Maturity status: Test
(0114116)
Sandrahuguet (developer)
2019-08-22 11:29

automated test created

- Issue History
Date Modified Username Field Change
2019-06-20 13:14 aferraz New Issue
2019-06-20 13:14 aferraz Assigned To => Triage Finance
2019-06-20 13:14 aferraz Modules => Core
2019-06-20 13:14 aferraz Regression level => Production - QA Approved
2019-06-20 13:14 aferraz Regression date => 2019-02-28
2019-06-20 13:14 aferraz Regression introduced in release => 3.0PR19Q2
2019-06-20 13:14 aferraz Regression introduced by commit => https://code.openbravo.com/erp/devel/pi/rev/aed4d4a47cd18723828c141de4ab3e43b40c161d [^]
2019-06-20 13:14 aferraz Triggers an Emergency Pack => No
2019-06-20 13:14 aferraz Issue generated from 0041132
2019-06-20 13:16 aferraz Relationship added related to 0041132
2019-06-20 13:16 aferraz Relationship added caused by 0040257
2019-06-20 13:45 Sandrahuguet Assigned To Triage Finance => nonofrancisco
2019-06-20 13:51 aferraz Relationship added related to 0041135
2019-06-20 13:52 aferraz Target Version => 3.0PR19Q3
2019-06-20 15:54 Sandrahuguet Status new => scheduled
2019-06-20 20:24 nonofrancisco Note Added: 0112925
2019-06-26 17:34 hgbot Checkin
2019-06-26 17:34 hgbot Note Added: 0113041
2019-06-26 17:34 hgbot Status scheduled => resolved
2019-06-26 17:34 hgbot Resolution open => fixed
2019-06-26 17:34 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/78b5dfcfa2ebe9670eeaa67f7b383f85f2712711 [^]
2019-06-26 17:45 Sandrahuguet Review Assigned To => Sandrahuguet
2019-06-26 17:45 Sandrahuguet Note Added: 0113044
2019-06-26 17:45 Sandrahuguet Status resolved => closed
2019-06-26 17:45 Sandrahuguet Fixed in Version => 3.0PR19Q3
2019-06-26 17:57 Sandrahuguet Status closed => new
2019-06-26 17:57 Sandrahuguet Resolution fixed => open
2019-06-26 17:57 Sandrahuguet Fixed in Version 3.0PR19Q3 =>
2019-06-27 08:42 Sandrahuguet Status new => scheduled
2019-06-27 08:42 Sandrahuguet Status scheduled => resolved
2019-06-27 08:42 Sandrahuguet Resolution open => fixed
2019-06-27 08:42 Sandrahuguet Status resolved => closed
2019-06-28 00:15 hudsonbot Checkin
2019-06-28 00:15 hudsonbot Note Added: 0113085
2019-08-22 11:29 Sandrahuguet Note Added: 0114116


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker