Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0041132
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] 07. Sales managementmajorhave not tried2019-06-20 13:092019-08-22 11:29
ReporteraferrazView Statuspublic 
Assigned Tononofrancisco 
PrioritynormalResolutionfixedFixed in Version3.0PR19Q3
StatusclosedFix in branchFixed in SCM revisionb0c04c46544d
ProjectionnoneETAnoneTarget Version3.0PR19Q3
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned ToSandrahuguet
Web browser
ModulesCore
Regression levelPre packaging ( pi )
Regression date2019-06-03
Regression introduced in releasepi
Regression introduced by commithttps://code.openbravo.com/erp/devel/pi/rev/f5c363681f43fab6f8bcadd6aad21ec14be00edc [^]
Triggers an Emergency PackNo
Summary

0041132: Business Partner selector doesn't filter by natural tree anymore

DescriptionAfter allowing cross organization reference in some C_BPartner_ID columns, Business Partner selector doesn't filter by natural tree anymore.
Steps To ReproduceUsing F&B group admin role:
- Create a new Sales Order
- Select F&B España - Región Norte organization
- Click on Business Partner selector
Check Business Partners from USA are displayed.
Only Business Partners from Spain should be displayed.
Proposed SolutionAdd a validation to filter by natural tree organizations in following columns:
C_Order.C_BPartner_ID
C_OrderLine.C_BPartner_ID
M_InOut.C_BPartner_ID
M_InOutLine.C_Bpartner_ID
C_Invoice.C_BPartner_ID
C_InvoiceLine.C_Bpartner_ID
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
related to defect 00411333.0PR19Q3 closednonofrancisco Openbravo ERP Sales Representative selector doesn't filter by natural tree anymore 
caused by feature request 0041006RR19Q3 closedaferraz Retail Modules Cross Store Sales project 
related to feature request 0041135 newplatform Openbravo ERP Add the ability to filter by natural tree in selectors based on columns allowing cross org reference 

-  Notes
(0112926)
nonofrancisco (developer)
2019-06-20 22:55

Test Plan

As Openbravo / F&B International Group Admin:

Create a new Sales Order
  Organization: F&B España - Región Norte
  Click on Business Partners selector
Verify just Business Partner from España are shown
  Change Orgaization to F&B US East Coast
Verify just Business Partners from USA are shown

Verify the Business Partner selector behave the same in the following windows
  Purchase Order
  Goods Receipt
  Goods Shipment
  Sales Invoice
  Purchase Invoice
(0113060)
hgbot (developer)
2019-06-27 15:43

Repository: erp/devel/pi
Changeset: b0c04c46544d06ade4dcc2f5011c924c0d71497c
Author: Nono Carballo <nonofce <at> gmail.com>
Date: Thu Jun 27 08:57:55 2019 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/b0c04c46544d06ade4dcc2f5011c924c0d71497c [^]

Fixes issue 41132: Filter BusinessPartner by natural organization

A new Filter Expression was added to BusinessPartner selector to filter business
partner by natural organization. The filter expression adds the filter only if
the selector is being used by BusinessPartner column in tables C_INVOICE,
C_INVOICELINE, M_INOUT, M_INOUTLINE, C_ORDER and C_ORDERLINE

Test class was updated.

---
M src-db/database/sourcedata/OBUISEL_SELECTOR.xml
M src-test/src/org/openbravo/test/security/CrossOrganizationUI.java
A src/org/openbravo/erpCommon/info/BusinessPartnerSelectorFilterExpression.java
---
(0113061)
Sandrahuguet (developer)
2019-06-27 15:49

code review + testing ok
(0113086)
hudsonbot (developer)
2019-06-28 00:15

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/a42da0b1e061 [^]
Maturity status: Test
(0114117)
Sandrahuguet (developer)
2019-08-22 11:29

automated test created

- Issue History
Date Modified Username Field Change
2019-06-20 13:09 aferraz New Issue
2019-06-20 13:09 aferraz Assigned To => Triage Finance
2019-06-20 13:09 aferraz Modules => Core
2019-06-20 13:09 aferraz Triggers an Emergency Pack => No
2019-06-20 13:10 aferraz Regression level => Pre packaging ( pi )
2019-06-20 13:10 aferraz Regression date => 2019-06-03
2019-06-20 13:10 aferraz Regression introduced in release => pi
2019-06-20 13:10 aferraz Regression introduced by commit => https://code.openbravo.com/erp/devel/pi/rev/f5c363681f43fab6f8bcadd6aad21ec14be00edc [^]
2019-06-20 13:11 aferraz Relationship added caused by 0041006
2019-06-20 13:14 aferraz Issue cloned 0041133
2019-06-20 13:16 aferraz Relationship added related to 0041133
2019-06-20 13:45 Sandrahuguet Assigned To Triage Finance => nonofrancisco
2019-06-20 13:51 aferraz Relationship added related to 0041135
2019-06-20 22:49 nonofrancisco Status new => scheduled
2019-06-20 22:55 nonofrancisco Note Added: 0112926
2019-06-27 15:43 hgbot Checkin
2019-06-27 15:43 hgbot Note Added: 0113060
2019-06-27 15:43 hgbot Status scheduled => resolved
2019-06-27 15:43 hgbot Resolution open => fixed
2019-06-27 15:43 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/b0c04c46544d06ade4dcc2f5011c924c0d71497c [^]
2019-06-27 15:49 Sandrahuguet Review Assigned To => Sandrahuguet
2019-06-27 15:49 Sandrahuguet Note Added: 0113061
2019-06-27 15:49 Sandrahuguet Status resolved => closed
2019-06-27 15:49 Sandrahuguet Fixed in Version => 3.0PR19Q3
2019-06-28 00:15 hudsonbot Checkin
2019-06-28 00:15 hudsonbot Note Added: 0113086
2019-08-22 11:29 Sandrahuguet Note Added: 0114117


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker