Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0040735
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] A. Platformmajoralways2019-04-30 17:262019-05-21 15:17
ReportermalsasuaView Statuspublic 
Assigned Tocaristu 
PrioritynormalResolutionfixedFixed in Version3.0PR19Q3
StatusclosedFix in branchFixed in SCM revision3d7237675ba2
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Toalostale
Web browser
ModulesCore
Regression levelProduction - Confirmed Stable
Regression date2017-11-28
Regression introduced in release3.0PR18Q1
Regression introduced by commithttps://code.openbravo.com/erp/devel/pi/rev/90ee5c965823996a7b4c0ae17d3a3ca71e3fc703 [^]
Triggers an Emergency PackNo
Summary

0040735: Records can not be exported to CSV

DescriptionIn grid view, if you filter by creation date, the export process to CSV is not working
Steps To Reproduce. go to Business Partner window
. in grid view, add column "Creation Date"
. filter by Creation Date (see screenshot attached)
. click in Export to Spreadsheet button
CSV file is downloaded but it is empty (see file attached)
TagsNo tags attached.
Attached Filespng file icon Screenshot from 2019-04-30 17-20-18.png [^] (106,010 bytes) 2019-04-30 17:26


csv file icon ExportedData (19).csv [^] (109 bytes) 2019-04-30 17:27

- Relationships Relation Graph ] Dependency Graph ]
depends on backport 00407423.0PR19Q2 closedcaristu Records can not be exported to CSV 
depends on backport 00407433.0PR19Q1.1 closedcaristu Records can not be exported to CSV 
caused by defect 0037079 closedcaristu more records than expected are fetched when filtering by date ranges 
has duplicate defect 0038805 closedplatform Export CSV after filtering date manually fails 
related to defect 0040829 closedcaristu Unable to create record with fields having references 'DateTime_From (Date)' and 'DateTime_To (Date)' 
related to design defect 0040794 newplatform Is not possible to filter a DateTime column by time 
related to defect 0040802 closedcaristu Use as filter option is not working properly with date columns 

-  Notes
(0111490)
caristu (developer)
2019-05-06 09:53
edited on: 2019-05-06 09:55

Repository: erp/devel/pi
Changeset: 3d7237675ba21defe75727ff05f83b132cee64ad
Author: Carlos Aristu <carlos.aristu <at> openbravo.com>
Date: Mon May 06 09:33:11 2019 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/3d7237675ba21defe75727ff05f83b132cee64ad [^]

fixes issue 40735: wrong export to CSV having the grid filtered by a date time

  After the following changeset[1], exporting the grid to CSV was not working properly having the grid filtered by a date time column. Although the fix is correct, it caused the criteria sent to the datasource in this type of requests to stop being handled properly.

  To avoid this problem, when exporting to CSV a grid filtered by a date time column we send in the criteria the plain date (in the same way as it is being done for the standard grid DS requests) and the datasource will take care of building the date filter properly through the AdvancedQueryBuilder.

[1] https://code.openbravo.com/erp/devel/pi/rev/90ee5c965823996a7b4c0ae17d3a3ca71e3fc703 [^]

---
M modules/org.openbravo.client.application/web/org.openbravo.client.application/js/grid/ob-grid.js

(0111497)
hgbot (developer)
2019-05-06 12:16

Repository: erp/devel/pi
Changeset: 3f7bc51bb14fc13152d8805cc537bc26e068ced3
Author: Carlos Aristu <carlos.aristu <at> openbravo.com>
Date: Mon May 06 12:12:55 2019 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/3f7bc51bb14fc13152d8805cc537bc26e068ced3 [^]

related to issue 40735: minor code improvements

  - Update copyright year
  - Removed duplicated null check for "record"
  - Initialize "i" when needed
  - Remove useless assignment to "drawArea"

---
M modules/org.openbravo.client.application/web/org.openbravo.client.application/js/grid/ob-grid.js
---
(0111528)
alostale (developer)
2019-05-07 11:14

reviewed + tested
(0111530)
hgbot (developer)
2019-05-07 11:15

Repository: erp/devel/pi
Changeset: 8c40baeab17c54750daded7b0d45998615531b47
Author: Carlos Aristu <carlos.aristu <at> openbravo.com>
Date: Tue May 07 11:14:50 2019 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/8c40baeab17c54750daded7b0d45998615531b47 [^]

related to issue 40735: add test case

  Added test case to cover the export of a grid filtered by a date column

---
M src-test/src/org/openbravo/test/AllAntTaskTests.java
M src-test/src/org/openbravo/test/base/TestConstants.java
A src-test/src/org/openbravo/test/datasource/GridExport.java
---
(0112009)
hudsonbot (developer)
2019-05-21 15:16

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/9b8f37d9d85e [^]
Maturity status: Test
(0112014)
hudsonbot (developer)
2019-05-21 15:17

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/9b8f37d9d85e [^]
Maturity status: Test

- Issue History
Date Modified Username Field Change
2019-04-30 17:26 malsasua New Issue
2019-04-30 17:26 malsasua Assigned To => platform
2019-04-30 17:26 malsasua File Added: Screenshot from 2019-04-30 17-20-18.png
2019-04-30 17:26 malsasua Modules => Core
2019-04-30 17:26 malsasua Resolution time => 1558303200
2019-04-30 17:26 malsasua Triggers an Emergency Pack => No
2019-04-30 17:27 malsasua File Added: ExportedData (19).csv
2019-05-02 11:18 caristu Assigned To platform => caristu
2019-05-02 11:19 caristu Regression level => Production - Confirmed Stable
2019-05-02 11:19 caristu Regression date => 2017-11-28
2019-05-02 11:19 caristu Regression introduced in release => 3.0PR18Q1
2019-05-02 11:19 caristu Regression introduced by commit => https://code.openbravo.com/erp/devel/pi/rev/90ee5c965823996a7b4c0ae17d3a3ca71e3fc703 [^]
2019-05-02 11:19 caristu Relationship added caused by 0037079
2019-05-02 11:29 caristu Status new => scheduled
2019-05-02 11:39 alostale Relationship added related to 0038805
2019-05-06 09:53 caristu Note Added: 0111490
2019-05-06 09:53 caristu Status scheduled => resolved
2019-05-06 09:53 caristu Fixed in SCM revision => 3d7237675ba2
2019-05-06 09:53 caristu Resolution open => fixed
2019-05-06 09:53 caristu Note Edited: 0111490 View Revisions
2019-05-06 09:55 caristu Note Edited: 0111490 View Revisions
2019-05-06 10:14 caristu Fixed in SCM revision 3d7237675ba2 => https://code.openbravo.com/erp/devel/pi/rev/3d7237675ba21defe75727ff05f83b132cee64ad [^]
2019-05-06 11:52 caristu Review Assigned To => alostale
2019-05-06 12:16 hgbot Checkin
2019-05-06 12:16 hgbot Note Added: 0111497
2019-05-06 12:31 caristu Relationship deleted related to 0038805
2019-05-06 12:33 caristu Relationship added has duplicate 0038805
2019-05-07 11:14 alostale Note Added: 0111528
2019-05-07 11:14 alostale Status resolved => closed
2019-05-07 11:14 alostale Fixed in Version => 3.0PR19Q3
2019-05-07 11:15 hgbot Checkin
2019-05-07 11:15 hgbot Note Added: 0111530
2019-05-10 09:39 alostale Relationship added related to 0040829
2019-05-20 16:29 caristu Relationship added related to 0040794
2019-05-20 16:29 caristu Relationship added related to 0040802
2019-05-21 15:16 hudsonbot Checkin
2019-05-21 15:16 hudsonbot Note Added: 0112009
2019-05-21 15:17 hudsonbot Checkin
2019-05-21 15:17 hudsonbot Note Added: 0112014


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker