Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0040829
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] A. Platformmajoralways2019-05-09 16:372019-05-21 15:17
Reporterprakashmurugesan88View Statuspublic 
Assigned Tocaristu 
PriorityimmediateResolutionfixedFixed in Version3.0PR19Q3
StatusclosedFix in branchFixed in SCM revision59d8a1189664
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Toalostale
Web browser
ModulesCore
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0040829: Unable to create record with fields having references 'DateTime_From (Date)' and 'DateTime_To (Date)'

Description1. Save Error:
While trying to create a record with fields having reference 'DateTime_From (Date)' or 'DateTime_To (Date)', an error occurs "Unparsable Date".
Please Refer Attachment "SaveError".

2. TimeStamp displayed in grid view but not in form view:
Try to generate record using reference "Date" instead of 'DateTime_From (Date)' or 'DateTime_To (Date)'.
Both in form view and grid view only date is visible.
Again change the reference from "Date" to 'DateTime_From (Date)' or 'DateTime_To (Date)'.
In Form View only date is visible but in grid view date with timestamp is visible.
Please Refer Attachment "FormView" & "GridView".
Steps To Reproduce* Alternative 1

Open Purchase Order window create a record say SPPO1000005.
As the reference for "Order Date" and "Scheduled Delivery Date" is "Date", record will be created successfully.
Now Notice the dates in form view as well grid view, only dates are displayed.

To Reproduce the issue configure "Order Date" and "Scheduled Delivery Date" in "Purchase Order" window as below,
    "Order Date" ==> Changed Reference from "Date" to "DateTime_From (Date)"
    "Scheduled Date" ==> Changed Reference from "Date" to "DateTime_To (Date)"

Build the Environment

1.Save Error:
Open "Purchase Order" window.
Try to create a record with "Order Date" and "Scheduled Delivery Date" and all other details and save.
Error "Unparseable Date" occurs.

2.Time Stamp:
Open Previously Created Record with date reference [Here SPPO1000005].
Notice in form view for "Order Date" and "Scheduled Delivery Date", date alone is displayed.
Close the form view.
Notice in grid view for "Order Date" and "Scheduled Delivery Date", date with timestamp is displayed.

* Alternative 2
1. Install Resource and Reservation Management module (org.openbravo.module.resources)
2. Create a new Resource with Water as Product Category
3. As F&B admin create a Sales Order header, in org F&B España - Región Norte
4. Add a new line with Agua sin gas as product
5. Create a new Reservation for that line



TagsNo tags attached.
Attached Filespng file icon SaveError.png [^] (220,128 bytes) 2019-05-09 16:37


png file icon FormView.png [^] (217,308 bytes) 2019-05-09 16:37


png file icon GridView.png [^] (167,157 bytes) 2019-05-09 16:38

- Relationships Relation Graph ] Dependency Graph ]
related to defect 0040735 closedcaristu Records can not be exported to CSV 
related to design defect 0040959 acknowledgedplatform While creating a reservation, it is different the info shown in grid and in form view. 

-  Notes
(0111723)
hgbot (developer)
2019-05-16 16:03

Repository: erp/devel/pi
Changeset: 59d8a1189664901f74cc2af8a2c8d07e34d5618d
Author: Carlos Aristu <carlos.aristu <at> openbravo.com>
Date: Thu May 16 14:01:42 2019 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/59d8a1189664901f74cc2af8a2c8d07e34d5618d [^]

fixes bug 40829: Can't save date taken from picker of DateTime_From/To fields

   It was not possible to save a date taken from the date picker of those fields using DateTime_From/To references. This is because the JsonToDataConverter expects a date time value to parse, but instead a plain date is received.

  The reason why a date was being received is because as this references are configured to not show the time (showTime: false), its date picker builds a logical date rather than a specific datetime value.

  To fix the problem we are setting the date received from the picker to be not logical, this way dates will be serialized to the expected DateTime value when sending the data to the Datasource in order to save/update the record.

---
M modules/org.openbravo.client.application/web/org.openbravo.client.application/js/form/formitem/ob-formitem-datetime.js
---
(0111724)
hgbot (developer)
2019-05-16 16:10

Repository: erp/devel/pi
Changeset: b82519cbc5e9cd9639123b624d7871dea53f277e
Author: Carlos Aristu <carlos.aristu <at> openbravo.com>
Date: Thu May 16 16:10:20 2019 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/b82519cbc5e9cd9639123b624d7871dea53f277e [^]

related to issue 40829: fix comments

---
M modules/org.openbravo.client.application/web/org.openbravo.client.application/js/form/formitem/ob-formitem-datetime.js
---
(0111756)
alostale (developer)
2019-05-17 08:21

reviewed + tested
(0112033)
hudsonbot (developer)
2019-05-21 15:17

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/9b8f37d9d85e [^]
Maturity status: Test
(0112034)
hudsonbot (developer)
2019-05-21 15:17

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/9b8f37d9d85e [^]
Maturity status: Test

- Issue History
Date Modified Username Field Change
2019-05-09 16:37 prakashmurugesan88 New Issue
2019-05-09 16:37 prakashmurugesan88 Assigned To => platform
2019-05-09 16:37 prakashmurugesan88 File Added: SaveError.png
2019-05-09 16:37 prakashmurugesan88 Modules => Core
2019-05-09 16:37 prakashmurugesan88 Triggers an Emergency Pack => No
2019-05-09 16:37 prakashmurugesan88 File Added: FormView.png
2019-05-09 16:38 prakashmurugesan88 File Added: GridView.png
2019-05-10 09:26 alostale Steps to Reproduce Updated View Revisions
2019-05-10 09:39 alostale Relationship added related to 0040735
2019-05-10 10:41 caristu Assigned To platform => caristu
2019-05-13 10:58 alostale Priority high => immediate
2019-05-15 11:06 caristu Status new => scheduled
2019-05-16 16:03 hgbot Checkin
2019-05-16 16:03 hgbot Note Added: 0111723
2019-05-16 16:03 hgbot Status scheduled => resolved
2019-05-16 16:03 hgbot Resolution open => fixed
2019-05-16 16:03 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/59d8a1189664901f74cc2af8a2c8d07e34d5618d [^]
2019-05-16 16:04 caristu Review Assigned To => alostale
2019-05-16 16:10 hgbot Checkin
2019-05-16 16:10 hgbot Note Added: 0111724
2019-05-17 08:21 alostale Note Added: 0111756
2019-05-17 08:21 alostale Status resolved => closed
2019-05-17 08:21 alostale Fixed in Version => 3.0PR19Q3
2019-05-21 15:17 hudsonbot Checkin
2019-05-21 15:17 hudsonbot Note Added: 0112033
2019-05-21 15:17 hudsonbot Checkin
2019-05-21 15:17 hudsonbot Note Added: 0112034
2019-05-28 12:36 caristu Relationship added related to 0040959


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker