Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0040802
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] A. Platformminorhave not tried2019-05-07 13:462019-05-27 13:54
ReportercaristuView Statuspublic 
Assigned Tocaristu 
PriorityhighResolutionfixedFixed in Version3.0PR19Q3
StatusclosedFix in branchFixed in SCM revision2bc577948e7d
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Toalostale
Web browser
ModulesCore
Regression levelProduction - Confirmed Stable
Regression date2017-11-28
Regression introduced in release3.0PR18Q1
Regression introduced by commithttps://code.openbravo.com/erp/devel/pi/rev/90ee5c965823996a7b4c0ae17d3a3ca71e3fc703 [^]
Triggers an Emergency PackNo
Summary

0040802: Use as filter option is not working properly with date columns

DescriptionUse as filter option is not working properly with date columns
Steps To Reproduce1) Go to the [Process Monitor] window
2) Select any record
3) Move the cursor to the "Start Time" column, right click and select "Set As Filter" option
4) Note that the text in the filter field is correctly updated but the result of the filtering is not correct
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
related to defect 0023203 closedAugustoMauch filter does not work with creation date fields 
related to design defect 0040794 newplatform Is not possible to filter a DateTime column by time 
related to defect 0040735 closedcaristu Records can not be exported to CSV 
depends on backport 00409163.0PR19Q2.1 closedcaristu Use as filter option is not working properly with date columns 
depends on backport 00409173.0PR19Q1.2 closedcaristu Use as filter option is not working properly with date columns 
caused by defect 0037079 closedcaristu more records than expected are fetched when filtering by date ranges 

-  Notes
(0111933)
hgbot (developer)
2019-05-20 16:25

Repository: erp/devel/pi
Changeset: 2bc577948e7d6e36e475a17d6baf2030dda8580a
Author: Carlos Aristu <carlos.aristu <at> openbravo.com>
Date: Mon May 20 16:11:56 2019 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/2bc577948e7d6e36e475a17d6baf2030dda8580a [^]

fixes bug 40802: "Use as filter" is not working properly with DateTime columns

  After this changeset[1] it was fixed the ability to filter properly by a range of DateTime values. However, this change broke the correct filtering by a single DateTime value in this type of columns.

  But when filtering a DateTime column with a single DateTime value (when not filtering by a range of dates), in general, the idea is to use the plain date value and build the criteria properly in the backend(See[2]).

  Therefore now we are adapting the way that the criteria is build using the "Use as Filter" menu option to generate the criteria in the same way as when the filter is entered manually in a DateTime column. And this is done by building the criteria to filter the DateTime column using a plain date.


[1] https://code.openbravo.com/erp/devel/pi/rev/90ee5c965823996a7b4c0ae17d3a3ca71e3fc703 [^]
[2] https://issues.openbravo.com/view.php?id=23203 [^]

---
M modules/org.openbravo.client.application/web/org.openbravo.client.application/js/grid/ob-view-grid.js
---
(0111935)
hgbot (developer)
2019-05-20 18:07

Repository: erp/devel/pi
Changeset: 72ee96e5a9f7b25949363e2658bbcf36c1af1f2b
Author: Carlos Aristu <carlos.aristu <at> openbravo.com>
Date: Mon May 20 18:06:19 2019 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/72ee96e5a9f7b25949363e2658bbcf36c1af1f2b [^]

related to bug 40802: additional code improvements

  - Remove useless assignment
  - Use single return statement
  - Remove checks which always evaluate to true

---
M modules/org.openbravo.client.application/web/org.openbravo.client.application/js/grid/ob-view-grid.js
---
(0112054)
hudsonbot (developer)
2019-05-21 15:17

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/9b8f37d9d85e [^]
Maturity status: Test
(0112055)
hudsonbot (developer)
2019-05-21 15:17

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/9b8f37d9d85e [^]
Maturity status: Test
(0112114)
alostale (developer)
2019-05-24 10:36

reviewed + tested
(0112117)
hgbot (developer)
2019-05-24 10:48

Repository: erp/devel/pi
Changeset: 6a1f11921b4b0e4c888c1a515b844084e5ce1150
Author: Carlos Aristu <carlos.aristu <at> openbravo.com>
Date: Fri May 24 10:47:32 2019 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/6a1f11921b4b0e4c888c1a515b844084e5ce1150 [^]

related to bug 40802: simplify return statement

---
M modules/org.openbravo.client.application/web/org.openbravo.client.application/js/grid/ob-view-grid.js
---
(0112173)
hudsonbot (developer)
2019-05-27 13:54

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/bdad8ace6f89 [^]
Maturity status: Test

- Issue History
Date Modified Username Field Change
2019-05-07 13:46 caristu New Issue
2019-05-07 13:46 caristu Assigned To => platform
2019-05-07 13:46 caristu Modules => Core
2019-05-07 13:46 caristu Triggers an Emergency Pack => No
2019-05-07 13:46 caristu Assigned To platform => caristu
2019-05-20 13:04 caristu Status new => scheduled
2019-05-20 16:25 hgbot Checkin
2019-05-20 16:25 hgbot Note Added: 0111933
2019-05-20 16:25 hgbot Status scheduled => resolved
2019-05-20 16:25 hgbot Resolution open => fixed
2019-05-20 16:25 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/2bc577948e7d6e36e475a17d6baf2030dda8580a [^]
2019-05-20 16:25 caristu Review Assigned To => alostale
2019-05-20 16:25 caristu Relationship added related to 0023203
2019-05-20 16:25 caristu Relationship added caused by 0037079
2019-05-20 16:26 caristu Regression level => Production - Confirmed Stable
2019-05-20 16:26 caristu Regression date => 2017-11-28
2019-05-20 16:26 caristu Regression introduced by commit => https://code.openbravo.com/erp/devel/pi/rev/90ee5c965823996a7b4c0ae17d3a3ca71e3fc703 [^]
2019-05-20 16:26 caristu Regression introduced in release => 3.0PR18Q1
2019-05-20 16:28 caristu Relationship added related to 0040794
2019-05-20 16:29 caristu Relationship added related to 0040735
2019-05-20 18:07 hgbot Checkin
2019-05-20 18:07 hgbot Note Added: 0111935
2019-05-21 15:17 hudsonbot Checkin
2019-05-21 15:17 hudsonbot Note Added: 0112054
2019-05-21 15:17 hudsonbot Checkin
2019-05-21 15:17 hudsonbot Note Added: 0112055
2019-05-24 10:36 alostale Note Added: 0112114
2019-05-24 10:36 alostale Status resolved => closed
2019-05-24 10:36 alostale Fixed in Version => 3.0PR19Q3
2019-05-24 10:48 hgbot Checkin
2019-05-24 10:48 hgbot Note Added: 0112117
2019-05-27 13:54 hudsonbot Checkin
2019-05-27 13:54 hudsonbot Note Added: 0112173


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker